Jump to content

Cant setup Forge 1.12.2 minecraft server


Recommended Posts

Im no beginner to running Minecraft servers and setting them up. Vanilla, Spigot, Forge, not an issue. But i cannot get Forge 1.12.2 to run the setup for the server.


I install the Forge 1.12.2 server to my designated folder, and create my run.bat for the forge file. But running the forge server file (either by double clicking, or by using the run.bat) it doesnt work. Double clicking just causes nothing to happen. And using the run.bat causes the cmd window to open temporarily and close. Here is what shows in the cmd window:



C:\\Users\\minem\\Desktop\\Minecraft Servers\\1.12.2 Forge - Scramblecraft>java -Xms3072M -Xmx3072M -jar forge-1.12.2- -o nogui A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke([NativeMethodAccessorImpl.java:64](https://NativeMethodAccessorImpl.java:64)) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke([DelegatingMethodAccessorImpl.java:43](https://DelegatingMethodAccessorImpl.java:43)) at java.base/java.lang.reflect.Method.invoke([Method.java:564](https://Method.java:564)) at [net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run](https://net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run)([ServerLaunchWrapper.java:62](https://ServerLaunchWrapper.java:62)) at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main([ServerLaunchWrapper.java:31](https://ServerLaunchWrapper.java:31)) Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap') at net.minecraft.launchwrapper.Launch.([Launch.java:34](https://Launch.java:34)) at net.minecraft.launchwrapper.Launch.main([Launch.java:28](https://Launch.java:28))"



And NO files are created. No eula.txt. No log folders. No mod or forge folders. Nothing. This is when trying to run the oldest version of 1.12.2 Forge, because i tried other versions to see if they would work


I tried the latest and also the recommended version. I have 64 bit java. I have about 7 other servers i run off and on, many different versions, some forge, and they all work. I dont know whats going on or what else to try. Any help would be much appreciated. Happy to provide more info if needed just let me know. Thank you.

Edited by Evan11
Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.