Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

---- Minecraft Crash Report ----
// Don't do that.

Time: 21-4-4 下午11:47
Description: Exception in server tick loop

java.lang.NoClassDefFoundError: org/apache/logging/log4j/util/ReflectionUtil
    at com.sk89q.worldedit-fabric.l4j.Log4jLoggerFactory.getContext(Log4jLoggerFactory.java:42) ~[worldedit:?] {re:classloading}
    at org.apache.logging.log4j.spi.AbstractLoggerAdapter.getLogger(AbstractLoggerAdapter.java:46) ~[log4j-api-2.11.2.jar:2.11.2] {}
    at com.sk89q.worldedit-fabric.l4j.Log4jLoggerFactory.getLogger(Log4jLoggerFactory.java:29) ~[worldedit:?] {re:classloading}
    at com.sk89q.worldedit-fabric.slf4j.LoggerFactory.getLogger(LoggerFactory.java:363) ~[worldedit:?] {re:classloading}
    at com.sk89q.worldedit-fabric.slf4j.LoggerFactory.getLogger(LoggerFactory.java:388) ~[worldedit:?] {re:classloading}
    at com.sk89q.worldedit.WorldEdit.<clinit>(WorldEdit.java:113) ~[worldedit:?] {re:classloading}
    at com.sk89q.worldedit.extension.platform.AbstractPlatform.<init>(AbstractPlatform.java:41) ~[worldedit:?] {re:classloading}
    at com.sk89q.worldedit.forge.ForgePlatform.<init>(ForgePlatform.java:69) ~[worldedit:?] {re:classloading}
    at com.sk89q.worldedit.forge.ForgeWorldEdit.setupPlatform(ForgeWorldEdit.java:142) ~[worldedit:?] {re:classloading}
    at com.sk89q.worldedit.forge.ForgeWorldEdit.serverStarted(ForgeWorldEdit.java:209) ~[worldedit:?] {re:classloading}
    at net.minecraftforge.eventbus.ASMEventHandler_7_ForgeWorldEdit_serverStarted_FMLServerStartedEvent.invoke(.dynamic) ~[?:?] {}
    at net.minecraftforge.eventbus.ASMEventHandler.invoke(ASMEventHandler.java:85) ~[eventbus-4.0.0.jar:?] {}
    at net.minecraftforge.eventbus.EventBus.post(EventBus.java:302) ~[eventbus-4.0.0.jar:?] {}
    at net.minecraftforge.eventbus.EventBus.post(EventBus.java:283) ~[eventbus-4.0.0.jar:?] {}
    at net.minecraftforge.fml.server.ServerLifecycleHooks.handleServerStarted(ServerLifecycleHooks.java:107) ~[forge:?] {re:classloading}
    at net.minecraft.server.MinecraftServer.func_240802_v_(MinecraftServer.java:622) ~[?:?] {re:classloading,pl:accesstransformer:B}
    at net.minecraft.server.MinecraftServer.func_240783_a_(MinecraftServer.java:232) ~[?:?] {re:classloading,pl:accesstransformer:B}
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_281] {}
Caused by: java.lang.ClassNotFoundException: org.apache.logging.log4j.util.ReflectionUtil
    at java.lang.ClassLoader.findClass(ClassLoader.java:523) ~[?:1.8.0_281] {}
    at java.lang.ClassLoader.loadClass(ClassLoader.java:418) ~[?:1.8.0_281] {}
    at cpw.mods.modlauncher.TransformingClassLoader.loadClass(TransformingClassLoader.java:94) ~[modlauncher-8.0.9.jar:?] {re:classloading,re:classloading}
    at java.lang.ClassLoader.loadClass(ClassLoader.java:351) ~[?:1.8.0_281] {}
    ... 18 more


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- System Details --
Details:
    Minecraft Version: 1.16.5
    Minecraft Version ID: 1.16.5
    Operating System: Windows 7 (amd64) version 6.1
    Java Version: 1.8.0_281, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 1406628264 bytes (1341 MB) / 2080374784 bytes (1984 MB) up to 2080374784 bytes (1984 MB)
    CPUs: 4
    JVM Flags: 11 total; -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=16M -XX:-UseAdaptiveSizePolicy -XX:-OmitStackTraceInFastThrow -Xmn128m -Xmx1980m -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump
    ModLauncher: 8.0.9+86+master.3cf110c
    ModLauncher launch target: fmlclient
    ModLauncher naming: srg
    ModLauncher services: 
        /mixin-0.8.2.jar mixin PLUGINSERVICE 
        /eventbus-4.0.0.jar eventbus PLUGINSERVICE 
        /forge-1.16.5-36.1.4.jar object_holder_definalize PLUGINSERVICE 
        /forge-1.16.5-36.1.4.jar runtime_enum_extender PLUGINSERVICE 
        /accesstransformers-3.0.1.jar accesstransformer PLUGINSERVICE 
        /forge-1.16.5-36.1.4.jar capability_inject_definalize PLUGINSERVICE 
        /forge-1.16.5-36.1.4.jar runtimedistcleaner PLUGINSERVICE 
        /mixin-0.8.2.jar mixin TRANSFORMATIONSERVICE 
        /preview_OptiFine_1.16.5_HD_U_G8_pre11.jar OptiFine TRANSFORMATIONSERVICE 
        /forge-1.16.5-36.1.4.jar fml TRANSFORMATIONSERVICE 
    FML: 36.1
    Forge: net.minecraftforge:36.1.4
    FML Language Providers: 
        javafml@36.1
        minecraft@1
    Mod List: 
        forge-1.16.5-36.1.4-client.jar                    |Minecraft                     |minecraft                     |1.16.5              |DONE      |NOSIGNATURE
        InventoryHud_[1.16.2-1.16.5].forge-3.2.2.jar      |Inventory HUD+(Forge edition) |inventoryhud                  |3.2.2               |DONE      |NOSIGNATURE
        worldedit-mod-7.2.4.jar                           |WorldEdit                     |worldedit                     |7.2.4+5723-e3bfc64  |DONE      |NOSIGNATURE
        Jade-1.16.4-2.6.1.jar                             |Jade                          |jade                          |2.6.1               |DONE      |NOSIGNATURE
        baubles-1.8.7-1.16.5.jar                          |Baubles                       |baubles                       |1.8.7               |DONE      |NOSIGNATURE
        CustomSkinLoader_Forge-14.13-SNAPSHOT-214.jar     |CustomSkinLoader              |customskinloader              |14.13-SNAPSHOT-214  |DONE      |4a:31:8b:cf:34:eb:d0:13:f3:19:39:d5:d2:b9:12:78:b5:f2:8d:91:3e:6f:8f:ed:97:48:00:69:e1:30:3a:54
        CreativeCore_v2.1.0_mc1.16.5.jar                  |CreativeCore                  |creativecore                  |2.0.0               |DONE      |NOSIGNATURE
        jei-1.16.5-7.6.1.75.jar                           |Just Enough Items             |jei                           |7.6.1.75            |DONE      |NOSIGNATURE
        ItemPhysic_v1.4.17_mc1.16.5.jar                   |ItemPhysic                    |itemphysic                    |1.6.0               |DONE      |NOSIGNATURE
        forgemod_VoxelMap-1.10.12_for_1.16.5.jar          |VoxelMap                      |voxelmap                      |1.10.15             |DONE      |NOSIGNATURE
        forge-1.16.5-36.1.4-universal.jar                 |Forge                         |forge                         |36.1.4              |DONE      |22:af:21:d8:19:82:7f:93:94:fe:2b:ac:b7:e4:41:57:68:39:87:b1:a7:5c:c6:44:f9:25:74:21:14:f5:0d:90
        CosmeticArmorReworked-1.16.5-v1b.jar              |CosmeticArmorReworked         |cosmeticarmorreworked         |1.16.5-v1b          |DONE      |5e:ed:25:99:e4:44:14:c0:dd:89:c1:a9:4c:10:b5:0d:e4:b1:52:50:45:82:13:d8:d0:32:89:67:56:57:01:53
        CodeChickenLib-1.16.4-3.5.1.408-universal.jar     |CodeChicken Lib               |codechickenlib                |3.5.1.408           |DONE      |31:e6:db:63:47:4a:6e:e0:0a:2c:11:d1:76:db:4e:82:ff:56:2d:29:93:d2:e5:02:bd:d3:bd:9d:27:47:a5:71
        Neat+1.7-27.jar                                   |Neat                          |neat                          |1.7-27              |DONE      |NOSIGNATURE
        gravestone-1.16.5-1.0.3.jar                       |Gravestone Mod                |gravestone                    |1.16.5-1.0.3        |DONE      |NOSIGNATURE
        OreExcavation-1.8.157.jar                         |Ore Excavation                |oreexcavation                 |1.8.157             |DONE      |e7:68:1c:0d:b9:7e:cf:f8:f3:40:9c:84:c5:39:d7:a4:59:78:b0:6b:c3:fd:b7:4f:69:18:a3:88:e3:76:8c:3f
    Crash Report UUID: 3ba304be-57a9-4912-9713-78afacebb060
    Player Count: 0 / 8; []
    Data Packs: vanilla, mod:inventoryhud, mod:worldedit (incompatible), mod:jade, mod:baubles (incompatible), mod:customskinloader (incompatible), mod:creativecore, mod:jei, mod:itemphysic, mod:voxelmap (incompatible), mod:forge, mod:cosmeticarmorreworked (incompatible), mod:codechickenlib (incompatible), mod:neat (incompatible), mod:gravestone, mod:oreexcavation
    Type: Integrated Server (map_client.txt)
    Is Modded: Definitely; Client brand changed to 'forge'
    OptiFine Version: OptiFine_1.16.5_HD_U_G8_pre11
    OptiFine Build: 20210324-231709
    Render Distance Chunks: 8
    Mipmaps: 4
    Anisotropic Filtering: 1
    Antialiasing: 0
    Multitexture: false
    Shaders: null
    OpenGlVersion: 4.4.0 - Build 21.20.16.4508
    OpenGlRenderer: Intel(R) HD Graphics 620
    OpenGlVendor: Intel
    CpuCount: 4

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hello @ChampionAsh5357, thank you for your reply! I do not use the newer version of netty directly. It's a transitive dependency of Discord4j: +--- com.discord4j:discord4j-core:3.1.3 | +--- io.projectreactor:reactor-bom:Dysprosium-SR15 | | ... | +--- com.discord4j:discord-json:1.5.6 | | ... | +--- com.discord4j:discord4j-rest:3.1.3 | | ... | | \--- com.discord4j:discord4j-common:3.1.3 | | +--- io.projectreactor:reactor-bom:Dysprosium-SR15 (*) | | +--- com.discord4j:discord-json:1.5.6 (*) | | +--- io.projectreactor.netty:reactor-netty:0.9.15.RELEASE | | | +--- io.netty:netty-codec-http:4.1.54.Final (BTW, Minecraft is using io.netty:netty-all:4.1.25.Final)   I thought those line will extend "compile" by "shadow" configuration, making "compile" inherit dependencies from "shaodw": https://github.com/tony84727/xp-tweak/blob/7f24df8f46f78840d145605db1d2cfdd988ef66b/build.gradle#L114-L117 But anyway, I tried. I added netty dependency to the buildscript and found out that ./gradlew runServer is working!🎉 (the PR) However, for intellij runs, still no luck. (I've run ./gradlew genIntellijRuns again after updating the buildscript). Starting server by IDE runs will still throw java.lang.NoSuchMethodError, indicating those runs are still using old version of netty.   I still wish I can launch server by IDE runs so I can use IDE's debug utilities.
    • now I don't know how to help you you may want to create a new topic asking for help with that   the only thing that comes to mind isthat if you're on intelliJ, check if those are actaully subdirectories and not a single directory with dots in the name (as that is a very common problem that happens when people are modding with intelliJ)
    • Yes! thank you, it works great now. One more thing though, I followed default minecraft code for the armor, but even though I have all my layers in assets/gemstones/textures/models/armor it still shows up on my character as the 'no-texture' texture.
    • Exception message: java.lang.IllegalArgumentException: Duplicate registration jade you're registering "jade" twice, I think that should be the only thing wrong oh also, your enum constants should be all uppercased (it won't cause any errors of course, but it's the standard)  
    • Sure, i played around with the code a bit and added a ".get()" to the end of the material, this removed all errors. Except its wrong because now I launch and the game crashes, yet eclipse gives me no errors. Heres my list: package djofox.gemstones.materials; import java.util.function.Supplier; import djofox.gemstones.init.ItemInit; import net.minecraft.item.IItemTier; import net.minecraft.item.crafting.Ingredient; import net.minecraft.util.LazyValue; public enum ToolMaterialList implements IItemTier { beryl(0, 131, 15.0f, 2.75f, 30, () -> { return Ingredient.of(ItemInit.beryl.get()); }), jade(2, 500, 7.0f, 2.25f, 23, () -> { return Ingredient.of(ItemInit.jade.get()); }), moissanite(2, 500, 7.0f, 2.25f, 23, () -> { return Ingredient.of(ItemInit.moissanite.get()); }), kunzite(0, 315, 12f, 0.5f, 20, () -> { return Ingredient.of(ItemInit.kunzite.get()); }), orpiment(2, 258, 10f, 0.5f, 20, () -> { return Ingredient.of(ItemInit.orpiment.get()); }), mercurySulfide(2, 1012, 5.5f, 2.0f, 14, () -> { return Ingredient.of(ItemInit.mercurySulfide.get()); }), blackDiamond(3, 2757, 8.0f, 3.0f, 2, () -> { return Ingredient.of(ItemInit.blackDiamond.get()); }), treatedCarbide(4, 2560, 10.0f, 5.0f, 2, () -> { return Ingredient.of(ItemInit.siliconCarbide.get()); }); private final int level; private final int uses; private final float speed; private final float damage; private final int enchantmentValue; private final LazyValue<Ingredient> repairIngredient; private ToolMaterialList(int p_i48458_3_, int p_i48458_4_, float p_i48458_5_, float p_i48458_6_, int p_i48458_7_, Supplier<Ingredient> p_i48458_8_) { this.level = p_i48458_3_; this.uses = p_i48458_4_; this.speed = p_i48458_5_; this.damage = p_i48458_6_; this.enchantmentValue = p_i48458_7_; this.repairIngredient = new LazyValue<>(p_i48458_8_); } public int getUses() { return this.uses; } public float getSpeed() { return this.speed; } public float getAttackDamageBonus() { return this.damage; } public int getLevel() { return this.level; } public int getEnchantmentValue() { return this.enchantmentValue; } public Ingredient getRepairIngredient() { return this.repairIngredient.get(); } } Heres my init class which causes the crash (from taking other stuff) And heres the error I get when I crash (I dont know if you need it but better safe than sorry)  
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.