Jump to content

Can't install forge-1.10.2- server


Recommended Posts

Installed Skyfactory 3 server and whenever I run the install bat which just launches the installer.jar, it instantly closes and leaves a text file. 


Installing server to current directory
A problem installing the server was detected, server install cannot continue


And when I try to run the installer on it's own, it still leaves a text file.


Exception in thread "main" java.lang.ExceptionInInitializerError
    at net.minecraftforge.installer.ClientInstall.getSponsorMessage(ClientInstall.java:401)
    at net.minecraftforge.installer.InstallerAction.getSponsorMessage(InstallerAction.java:60)
    at net.minecraftforge.installer.InstallerPanel.updateFilePath(InstallerPanel.java:334)
    at net.minecraftforge.installer.InstallerPanel.<init>(InstallerPanel.java:315)
    at net.minecraftforge.installer.SimpleInstaller.launchGui(SimpleInstaller.java:164)
    at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:51)
Caused by: java.lang.ArrayIndexOutOfBoundsException: 1
    at net.minecraftforge.installer.MirrorData.buildMirrorList(MirrorData.java:84)
    at net.minecraftforge.installer.MirrorData.<init>(MirrorData.java:63)
    at net.minecraftforge.installer.MirrorData.<clinit>(MirrorData.java:17)
    ... 6 more


I've tried reinstalling java, I've tried downgrading java, jarfix and I'm so lost on what's going on. 1.16.5 installer works fine, it's just the 1.10.2 installer. Been trying to fix it for 3 hours and no solutions have worked. Some help would be amazing!

Link to comment
Share on other sites

This topic is now closed to further replies.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.