Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Fifou_BE

Members
  • Content Count

    25
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Fifou_BE

  • Rank
    Tree Puncher

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Well, I kinda need to do a version 1.13.2 for people who plays on that version Tho it's only when I press button I think, like the inventory is not updating and stuff ? Or is it coming from the GUI
  2. Hello ! I'm actually trying to create a GUI Screen for one of my items, it opens and close, texture are there, button seems to work. But after closing the GUI I have intense delay/lag. I don't know why, that causes lag, ghost items and eating is infinite (see video down there). I started a "/debug start" on MC that gives me those logs, so it's lagging. Someone suggested to me that there is a infinite loop but I don't see to find where ? [17:44:49.048] [Server thread/WARN] [minecraft/Profiler]: Something's taking too
  3. So what's the fix about cache ? Do I need to redo with the new mdk out ? EDIT : ok switching to the new version of forge mdk, is working.
  4. Yes of course, so I'm using the javac 1.8.0_201 , jdk 1.8.0 v201 so the last one I think I'm using also the MDK forge 1.13.2 25.0.89 (so there is a new one out, gonna try it out) So first step is installing the jdk with the JAVA_HOME variable restart the pc make a folder with no space, no signs for the forge environment setup the build.gradle with the modid and version and other stuff Eclipse > import > Existing Gradle Prokect > chose the MDK folder Gradle tasks > fg_runs > genEclipseRuns Launch either client or server
  5. Already tried all of that. Reinstalled java completely, reinstall a new forge workspace, rerun the task and still not working
  6. Hello, I asked on a french community around Forge why this was not working and they responsded that they don't know why it's not working and they think I should report it cuz it maybe a bug, so after setting up my workspace with eclipse, importing a gradle project, run the gradle tasks, I end up with my main class and bug .. Yes the imports are correct. If i hover the "FMLJavaModLoadingContext" it gives me that reason. and If I hover the "getModEventBus()" it gives me that reason : So apparently no one know how to fix or correct
  7. OMG. Literraly I tried this by doing this but in one line and it was not working, It works perfectly I feel stupid but thx you so much !!
  8. Hi everyone, I'm trying to make something for my block, briefly I try to add the render of the item that is in the block ! It works very well, you can see on this gif, so the problems is not the render or anything it crashes when my cursor is pointing on an entity (like cow/sheep/etc): But I can't find why it crashes. Actually I found that in my code it's the worldIn.getBlockState that return a NPE but I can't manage to find a fix ... Here is my code @SideOnly(Side.CLIENT) @SubscribeEvent public void onDrawBlockHighlightEvent(DrawBlockHighlightEvent event) { EntityP
  9. Ok, yep I removed the capabilities and I've done that instead in my other class ! It works but is that correct ? I added in tile entity public ItemStackHandler getHandler() { return inventory_seller; } And then I've done that in container/guis IItemHandler inventory = te.getHandler(); It works perfectly fine ^^
  10. Hi, I created a new chest, but after many times I saw that it was possible with a hopper to extract item from my custom chest. But I didn't add anything and I wanted to know if there is a simple way to disable it ? I've searched and I saw IItemHandler but It didn't work. I added it in my tile entity and tried but without success This is my tile entity : package fr.fifou.economy.blocks.tileentity; import java.util.UUID; import javax.annotation.Nonnull; import javax.annotation.Nullable; import fr.fifou.economy.blocks.BlocksRegistery; import fr.fifou.economy.blocks.Blo
  11. I've changed all of this, thank you I have this prompt on the log but can it be linked to my mod or it's mc ? [18:09:04] [pool-2-thread-1/WARN]: Couldn't look up profile properties for com.mojang.authlib.GameProfile@7bd76e78[id=1180fda0-fbd6-4eaa-a861-61fd3910f6fc,name=Fifou_BE,properties={},legacy=false] com.mojang.authlib.exceptions.AuthenticationException: The client has sent too many requests within a certain amount of time at com.mojang.authlib.yggdrasil.YggdrasilAuthenticationService.makeRequest(YggdrasilAuthenticationService.java:79) ~[YggdrasilAuthenticationService.class:?
  12. That's what I've done, but I prefer to have the advice of someone really qualified ^^ It seems to worked but I should not use te.getTileData(). But how am I supposed to get the data from the tile entity then ? I looked trough all the methods and nothing is similar to getTileData() !
  13. Ok, so is my code correct or do you see some problems ? blockVault public void onBlockPlacedBy(World worldIn, BlockPos pos, IBlockState state, EntityLivingBase placer, ItemStack stack) { worldIn.setBlockState(pos, state.withProperty(FACING, placer.getHorizontalFacing()), 2); TileEntityBlockVault te = (TileEntityBlockVault)worldIn.getTileEntity(pos); te.setString(placer.getUniqueID().toString()); te.getTileData().setString("ownerS", placer.getUniqueID().toString()); System.out.println(te.getOwnerS()); } @Override public boolean
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.