Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

dgraygray

Members
  • Posts

    7
  • Joined

  • Last visited

Everything posted by dgraygray

  1. Okay, I got it working to where it places the additional block beside it and it's great, except for the fact that this block has a tile entity. I like the idea of making only half the block have access to the "furnace". The issue I have now is that when I break the side that does not have the TE, it just sets the side that does to air. Do you know of how I can drop the correct block with the correct TE?
  2. So right now I have a collision box which is the full 16x16x32, but what you're saying is that this won't work for actual player interactions/the world won't recognize it as a taken up block?
  3. I have a block which I have a model for that is 16x32. The block has the functions and block states in place to render and create the collisions correctly for the 16x32 area, but only half of the block is clickable. The other half you can even place things inside of it. I'm wondering what is remaining for me to do in order for the game to know that this block is in both positions.
  4. Thank you for the help! This should fix the issues I'm having! Last question: Is there a place where I can find out what should be done only on the client vs only on the server? Things like TE tick() and other things I should keep an I out for?
  5. And we also don't want to do the tick if it's on the client right?
  6. Thank you for the speedy reply! From what I can see here, these are the functions that handle this sorta thing correct? I don't see in the second example a place where you are touching the smelting values though
  7. I am trying to store some information inside of my block and most of it seems to be working fine. I can save the inventory perfectly, but when it comes to a few integers it seems that they are not appearing to be saved. When I show some logs after I pick up the block and put it back down, in the tick() method it shows the server with the correct int and the client with 0. Does anyone have any knowledge around this? My loot_table: My Tile Entity:
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.