Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Choice

Members
  • Posts

    9
  • Joined

  • Last visited

Everything posted by Choice

  1. Hey @diesieben07 even with the getAddEntityPacket and getEntitySpawningPacket my textures aren't loading and the entity is either invisible or is visible but in a very wrong state. Can you have a look at my code and see what's wrong with it? My EntityTypeInit - https://pastebin.com/8rY2gnma My ExampleEntity -https://pastebin.com/PymCXQiH My ExampleEntityModel - https://pastebin.com/sgtS6yeA My ExampleEntityRenderer - https://pastebin.com/BsCqtgUL My ClientEventBusSubscriber - https://pastebin.com/MNnWr1Kv My WeatherMod(main java) - https://pastebin.com/5hQqjsSX
  2. @poopoodicei did save them and I put them into the texture slot into Eclipse so it is there. Btw sorry if I’m bothering you.
  3. @poopoodice I got a problem again. The game no longer crashes but the model texture of the entity looks like this and the texture for the model is provided too. Any reason why this might be? It's supposed to look like a penguin
  4. @Luis_ST yeah my bad forgot to reply it works now thank you
  5. @Luis_ST Any chance you can put that in simpler words? Sorry I am really new to this. You don't have to as I know this isn't a school. It's just I don't exactly know what you mean.
  6. So recently someone pointed out a fix for registering the entity which I fixed but then when I summoned the example entity it spawns, all the attributes are working but the model is invisible. I had named the correct path for the textures and all the entitymodel.java looks okay with no errors. So I'm puzzled as to why it is still invisible. (This is my first time making a custom entity). Any help will be much appreciated ExampleEntityModel - https://hastebin.com/oputoziqik.yaml ExampleEntityRenderer - https://hastebin.com/wupabututa.java ExampleEntity - https://hastebin.com/awadamarub.java EntityTypeInit - https://hastebin.com/obenejabas.swift ClientEventBusSubscriber - https://hastebin.com/ahayobenud.css WeatherMod (my main.java) - https://hastebin.com/isixixijuw.swift My textures are located in src/main/resources/assets/(My mod ID/textures/entity.example/example.png
  7. @poopoodice Thank you so much the game doesn't crash anymore when I load the world now. It's always the little things. The texture of the model hasn't loaded but i can probably fix this. But honestly thanks. Appreciate it.
  8. Hi, I'm new to java and coding and I wanted to create an entity (an example one) just to see how it works and runs. However, when I summon the entity the game crashes and in the crash log it says the following error in the title. Been stuck for 2 days now as I don't know what's wrong with it. Crash Report - https://hastebin.com/goxemoquta.http My code: Main Class - https://hastebin.com/yiluqavazu.swift Rendering Registries - https://hastebin.com/ikakegaqum.swift EntityTypeInit - https://hastebin.com/ayewuhevov.swift ExampleEntityModel - https://hastebin.com/uvozeretum.yaml ExampleEntityRenderer - https://hastebin.com/uwijivifax.java ExampleEntity - https://hastebin.com/bawijecimi.java
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.