Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

jumpcutfindo

Members
  • Posts

    4
  • Joined

  • Last visited

jumpcutfindo's Achievements

Tree Puncher

Tree Puncher (2/8)

0

Reputation

  1. Ok, that's unfortunate. I've resorted to just removing and adding back the relevant handlers after to fix it for now, it seems to be ok (until I forget to add them back). Appreciate the help.
  2. Oh, that's most likely it then. Does this mean that if I want to use custom events, then there's no way to circumvent this issue? Or is there some other way I can add my custom event to the game without having this class-transformation occur 😐
  3. The problem arises regardless of whether I call the event or not, so I'm not sure if it matters? Just to be clear, the events that I post to the EVENT_BUS are being recognised and picked up by the handler (i.e. everything works fine, my custom event is recognised, my handler works etc.); the only issue is that hot swapping doesn't work when I have the handler implemented. As for registering the custom event itself, I haven't found any mention of having to register a custom event (not handler) in Forge. I'm not sure if this is something I need to do though. Thanks!
  4. Hi, I have an issue that's related to the hot swapping feature on IntelliJ. From some debugging, I've figured out that after I register an event handler with a custom event, the hot swapping features of IntelliJ will fail with the following errors: Tutorial [runClient]: schema change not implemented Tutorial [runClient]: Operation not supported by VM My event handler is registered something like this, with a simple TestEvent simply just extending Event: @Mod.EventBusSubscriber(modid = TutorialMod.MOD_ID, bus = Mod.EventBusSubscriber.Bus.FORGE) public class TestEventHandler { @SubscribeEvent public static void onTestEvent(TestEvent event) { // Do something } } This causes my hot swapping features to fail. I've tried to change the way the event is being registered (i.e. using MinecraftForge.EVENT_BUS.register(...), but to no avail. The only way for the hot swapping feature to work is to remove the registration of the event handler. Does anyone know what might be the issue? Thanks! EDIT: I updated my mod to 1.17.1 and the issue seems to have disappeared. The source was most likely what was mentioned below, probably the new update doesn't require that to happen anymore? Not sure myself.
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.