Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

HassanS6000

Members
  • Posts

    56
  • Joined

  • Last visited

Converted

  • Gender
    Undisclosed

HassanS6000's Achievements

Stone Miner

Stone Miner (3/8)

2

Reputation

  1. Hey, I was wondering if there was any way to check where an IMessage is sent from? That way I can filter out an IMessage sent from a certain mod to my SimpleNetworkWrapper? Is there an event or something I can use? Thanks, Hassan
  2. @jabelar @elix Thanks for the suggestions, but neither helped.
  3. No, that's not why. I showed my proxy class whose methods are called by my main class. My main class is the one with the @EventHandler annotations.
  4. Hi! Basically, I want to replace snow and ice so they do not melt, and use the substitution alias system to avoid using ASM. I have replaced the ItemBlock and Block here: https://gist.github.com/hsyyid/ae6e14b6128f5aee27d8 but to no avail. Instead of replacing the snow and the ice, it appears that the ItemBlock does nothing when right clicked, and the snow and ice items DO NOT have textures anymore. Any and all help would be greatly appreciated!
  5. Figured it out with help from IRC, it was because my inventory was null in my TileEntity
  6. First off, don't just thank fry, thank shadekiller666 as well (he wrote the loader). Where exactly are you registering your custom model resource location? In your Main class or in a proxy? What is the unlocalized name of the item "Usp"? Do you have your blockstate for the item in the correct area? You need to give more info.
  7. I'm trying to create a GUI for a TileEntity on Minecraft 1.8. Basically I want to be able to put in a single book that has been written in, otherwise open the book inside. I am stuck with the GUI allowing you to enter the book. However, I keep getting an Null Pointer Exception from the Slot class: http://pastebin.com/tDE1wAwP My code: Container: http://pastebin.com/9R5MrmG5 Gui: http://pastebin.com/YdCg8wtN Gui Handler: http://pastebin.com/tDwbBj41 Block: http://pastebin.com/UKtR0WtT Any ideas and help would be greatly appreciated!
  8. UPDATE No.2 I can get it to render - it's just screwed up. Here's what it's supposed to look like: http://snag.gy/hefWK.jpg Here's what it looks like: http://snag.gy/gqMQ0.jpg Here's my GitHub Repository: https://github.com/hsyyid/HaloMod Any help would be appreciated!
  9. UPDATE! I fixed the crashing issue.. I forgot about worldRenderer.startDrawingQuads() However, I still cannot see my model, as I don't know what to do for addVertex().. am I supposed to use the vertexData?
  10. Thanks Ernio! I'm not so sure what to do from here... It crashes now but I'm 80% sure I'm not using Tessellator correctly.. Crash-Report: http://pastebin.com/nt1gHi87 RenderMongooseEntity Class: http://pastebin.com/XXk6LVSh
  11. Alright I've used ModelBakeEvent to get my IBakedModel. Now, how would I do worldrenderer.addVertexData(); from there? I can get a list of all the quads from my IBakedModel, but that does not return a list of int's - I think..
  12. Yes I do. I can't use the event because I can't pass in any of the parameters.
  13. How? I can't use ModelBakeEvent because I don't know any of the parameters.. ModelManager, ModelLoader, and IRegistry
  14. Thanks! How would I actually use that in my class? I had a link to a paste-bin copy of it above. I don't have an IBakedModel - I have an IModel.
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.