Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Koopamillion

Forge Modder
  • Posts

    102
  • Joined

  • Last visited

Converted

  • Gender
    Male
  • URL
    http://lumtech.byethost33.com/mods/eKoop/modinfo.html

Koopamillion's Achievements

Creeper Killer

Creeper Killer (4/8)

0

Reputation

  1. Hi Guys, I have several inventories, the first one was created with a tutorial, it has no problems, the other like 20 were all based off the same, different tutorial. These 20 all bug out when trying to take items out. For example: Lets say the machine produces 2 iron dust, I try to take this out but it leaves some iron dust in there, eventually it will come out after being duplicated like 5 times. If it dosen't duplicate items, then it ghosts them. Does anyone know why my inventories bug out like this? I've given one the of the broken inventories code: TileEntity: https://gist.github.com/anonymous/62df4638182dcc2bef59e9ef12788346 Container: https://gist.github.com/anonymous/f0f9aff14c1715edda925c44bbe3503d Block: https://gist.github.com/anonymous/ba523a42838a2751a88a9c9123783ade ^^ This one may have random metas cause I screwed something up, ignore that, it isn't the problem.
  2. Hi Guys, I have several inventories, the first one was created with a tutorial, it has no problems, the other like 20 were all based off the same, different tutorial. These 20 all bug out when trying to take items out. For example: Lets say the machine produces 2 iron dust, I try to take this out but it leaves some iron dust in there, eventually it will come out after being duplicated like 5 times. If it dosen't duplicate items, then it ghosts them. Does anyone know why my inventories bug out like this? I've given one the of the broken inventories code: TileEntity: https://gist.github.com/anonymous/62df4638182dcc2bef59e9ef12788346 Container: https://gist.github.com/anonymous/f0f9aff14c1715edda925c44bbe3503d Block: https://gist.github.com/anonymous/ba523a42838a2751a88a9c9123783ade ^^ This one may have random metas cause I screwed something up, ignore that, it isn't the problem.
  3. OK, Basically, I have all the drawing done, all I want is to get the textures source from the animated texture. Look at my gui near the coolant bit.
  4. I'm sorry guys, but this is too complicated, I honestly don't have a clue, I kinda understand the switching between coords, but where do I put gui updatescreen?
  5. I tried to update, but I don't get anything, I had like 8000 errors, how does everyone else deal with all this...?
  6. Ok, here is what i've done so far, I have no idea how to fix the draw fluid quad section ;l https://gist.github.com/anonymous/2b3570c128225b2d3bde1c3031113cc1 Thanks
  7. Yup, it's different and, as a noob with updating/downgrading, i've only figured how to convert one bit of code. Sorry about my noobishness Also - what's lava and water's atlas name ? Thanks
  8. ok but I don't get where to put the update screen, my gui is just the simple draw foreground ect.
  9. Does anyone know how to make animated fluid, in this case water and lava, in a gui? Im a noob at this sort of stuff... Thanks in advance
  10. Yeah, I originally coded it to use meta data for different blocks depending on how much power they could hold, that screwed it up so I left it half like that. Now I have no idea how to change it all ;l
  11. I've tried everything to fix this error but my block still wont rotate. Heres the block code: https://gist.github.com/anonymous/d19441dc5b4ad7a7e4fea8d0e6a2ee83 Ask for any more
  12. Some mods, e.g: ic2/thermal expansion have it so that, when you fill up their machines with a liquid, the GUI animates as if the liquid is glistening. Does anyone know how to set that up, an animated GUI? Thanks!
  13. Welp, It fixed itself lol!!!!! Thanks everyone! Ill give you all a thank you
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.