Jump to content

Search the Community

Showing results for tags 'wrong java version'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Minecraft Forge
    • Releases
    • Support & Bug Reports
    • Suggestions
    • General Discussion
  • Mod Developer Central
    • Modder Support
    • User Submitted Tutorials
  • Non-Forge
    • Site News (non-forge)
    • Minecraft General
    • Off-topic
  • Forge Mods
    • Mods

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


XMPP/GTalk


Gender


URL


Location


ICQ


AIM


Yahoo IM


MSN Messenger


Personal Text

  1. This is the error from the console: ███╗ ███╗ ██████╗ ██╗ ██╗ ██╗ ███████╗ ████████╗ ████╗ ████║ ██╔═══██╗ ██║ ██║ ██║ ██╔════╝ ╚══██╔══╝ ██╔████╔██║ ██║ ██║ ███████║ ██║ ███████╗ ██║ ██║╚██╔╝██║ ██║ ██║ ██╔══██║ ██║ ╚════██║ ██║ ██║ ╚═╝ ██║ ╚██████╔╝ ██║ ██║ ██║ ███████║ ██║ ╚═╝ ╚═╝ ╚═════╝ ╚═╝ ╚═╝ ╚═╝ ╚══════╝ ╚═╝ Thanks for using Mohist - 1.20.1-541, Java(19.0.2) 63.0 Update in check... If you don't want to enable update check, set check_update in mohist-config/mohist.yml to false The latest Mohist version is 1.20.1-542 but you have 1.20.1-541. The latest version has been built on 2023-12-21 12:18:01. You should update to fix recent bugs! Checking libraries, please wait... All libraries are nice :)! Searching incompatible mods... [13:03:58 INFO]: ModLauncher running: args [--launchTarget, forgeserver, --fml.forgeVersion, 47.2.17, --fml.mcVersion, 1.20.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20230612.114412, nogui] [13:03:58 INFO]: ModLauncher 10.0.9+10.0.9+main.dcd20f30 starting: java version 19.0.2 by Oracle Corporation; OS Windows 10 arch amd64 version 10.0 [13:04:00 INFO]: ImmediateWindowProvider not loading because launch target is forgeserver [13:04:00 INFO]: Mixin Transmogrifier is definitely up to no good... [13:04:00 INFO]: crimes against java were committed [13:04:00 INFO]: Original mixin transformation service successfully crobbed by mixin-transmogrifier! [13:04:00 INFO]: SpongePowered MIXIN Subsystem Version=0.8.5 Source=union:/F:/Mattia/servermod/mods/Connector-1.0.0-beta.31+1.20.1.jar%23260%23263!/ Service=ModLauncher Env=SERVER [13:04:01 WARN]: Attempted to select two dependency jars from JarJar which have the same identification: Mod File: and Mod File: . Using Mod File: [13:04:01 WARN]: Attempted to select a dependency jar for JarJar which was passed in as source: curios. Using Mod File: F:\Mattia\servermod\mods\curios-forge-5.4.6+1.20.1.jar [13:04:01 INFO]: Found 56 dependencies adding them to mods collection [13:04:04 INFO]: Dependency resolution found 4 candidates to load [13:04:05 INFO]: Successfully made module authlib transformable [13:04:07 INFO]: Compatibility level set to JAVA_17 [13:04:08 INFO]: Launching target 'forgeserver' with arguments [nogui] [13:04:08 INFO]: Loaded configuration file for ModernFix 5.10.1+mc1.20.1: 72 options available, 0 override(s) found [13:04:08 INFO]: Applying Nashorn fix [13:04:08 INFO]: Applied Forge config corruption patch [13:04:08 WARN]: Reference map 'morevillagers-forge-forge-refmap.json' for morevillagers.mixins.json could not be read. If this is a development environment you can ignore this message [13:04:08 WARN]: Reference map 'oculus-refmap.json' for mixins.oculus.compat.json could not be read. If this is a development environment you can ignore this message [13:04:08 WARN]: Reference map 'nitrogen_internals.refmap.json' for nitrogen_internals.mixins.json could not be read. If this is a development environment you can ignore this message [13:04:08 INFO]: Loaded configuration file for Canary: 123 options available, 0 override(s) found [13:04:08 WARN]: Reference map 'mvs-forge-refmap.json' for mvs-forge.mixins.json could not be read. If this is a development environment you can ignore this message [13:04:08 WARN]: Reference map 'cristellib-forge-refmap.json' for cristellib.mixins.json could not be read. If this is a development environment you can ignore this message [13:04:10 INFO]: Patching IForgeItemStack#getEnchantmentLevel [13:04:10 INFO]: Patching IForgeItemStack#getEnchantmentLevel [13:04:13 INFO]: Loaded config for: structureessentials.json [13:04:15 INFO]: Replaced 2 calls to Enchantment#getMaxLevel() in net/minecraft/world/inventory/AnvilMenu [13:04:15 INFO]: Patching IForgeItemStack#getEnchantmentLevel [13:04:15 INFO]: Patching IForgeItemStack#getEnchantmentLevel [13:04:16 WARN]: Error loading class: com/hollingsworth/arsnouveau/common/items/SpellCrossbow (java.lang.ClassNotFoundException: com.hollingsworth.arsnouveau.common.items.SpellCrossbow) [13:04:16 ERROR]: Attempted to load class net/minecraft/client/MouseHandler for invalid dist DEDICATED_SERVER [13:04:16 WARN]: Error loading class: net/minecraft/client/MouseHandler (java.lang.RuntimeException: Attempted to load class net/minecraft/client/MouseHandler for invalid dist DEDICATED_SERVER) [13:04:16 WARN]: @Mixin target net.minecraft.client.MouseHandler was not found fabric-screen-api-v1.mixins.json:MouseMixin from mod fabric_screen_api_v1 [13:04:16 ERROR]: Attempted to load class net/minecraft/client/gui/screens/Screen for invalid dist DEDICATED_SERVER [13:04:16 WARN]: Error loading class: net/minecraft/client/gui/screens/Screen (java.lang.RuntimeException: Attempted to load class net/minecraft/client/gui/screens/Screen for invalid dist DEDICATED_SERVER) [13:04:16 WARN]: @Mixin target net.minecraft.client.gui.screens.Screen was not found fabric-screen-api-v1.mixins.json:ScreenAccessor from mod fabric_screen_api_v1 [13:04:29 INFO]: Initializing MixinExtras via com.llamalad7.mixinextras.service.MixinExtrasServiceImpl(version=0.3.1). [13:04:33 INFO]: ModernFix reached bootstrap stage (40.93 s after launch) [13:04:35 INFO]: Injecting BlockStateBase cache population hook into getNeighborPathNodeType from com.abdelaziz.canary.mixin.ai.pathing.BlockStateBaseMixin [13:04:35 INFO]: Injecting BlockStateBase cache population hook into getPathNodeType from com.abdelaziz.canary.mixin.ai.pathing.BlockStateBaseMixin [13:04:35 INFO]: Injecting BlockStateBase cache population hook into getAllFlags from com.abdelaziz.canary.mixin.util.block_tracking.BlockStateBaseMixin Exception in thread "main" java.lang.RuntimeException: java.lang.reflect.InvocationTargetException at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:32) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:53) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:71) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.Launcher.run(Launcher.java:108) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.Launcher.main(Launcher.java:78) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:26) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:23) at [email protected]/cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:141) at com.mohistmc.MohistMCStart.main(MohistMCStart.java:104) Caused by: java.lang.reflect.InvocationTargetException at java.base/jdk.internal.reflect.DirectMethodHandleAccessor.invoke(DirectMethodHandleAccessor.java:119) at java.base/java.lang.reflect.Method.invoke(Method.java:578) at MC-BOOTSTRAP/[email protected]/net.minecraftforge.fml.loading.targets.CommonLaunchHandler.runTarget(CommonLaunchHandler.java:111) at MC-BOOTSTRAP/[email protected]/net.minecraftforge.fml.loading.targets.CommonLaunchHandler.serverService(CommonLaunchHandler.java:103) at MC-BOOTSTRAP/[email protected]/net.minecraftforge.fml.loading.targets.CommonServerLaunchHandler.lambda$makeService$0(CommonServerLaunchHandler.java:27) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:30) ... 8 more Caused by: java.lang.NoClassDefFoundError: net/minecraft/world/level/block/LiquidBlock at TRANSFORMER/[email protected]/net.minecraft.world.level.block.FireBlock.m_53484_(FireBlock.java:358) at TRANSFORMER/[email protected]/net.minecraft.server.Bootstrap.m_135870_(Bootstrap.java:46) at TRANSFORMER/[email protected]/net.minecraft.server.Main.main(Main.java:161) at java.base/jdk.internal.reflect.DirectMethodHandleAccessor.invoke(DirectMethodHandleAccessor.java:104) ... 13 more Caused by: java.lang.ClassNotFoundException: net.minecraft.world.level.block.LiquidBlock at cpw.mods.securejarhandler/cpw.mods.cl.ModuleClassLoader.loadClass(ModuleClassLoader.java:157) at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521) ... 17 more This is the error from the log: [13:03:58] [main/INFO] [cpw.mods.modlauncher.Launcher]: ModLauncher running: args [--launchTarget, forgeserver, --fml.forgeVersion, 47.2.17, --fml.mcVersion, 1.20.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20230612.114412, nogui] [13:03:58] [main/INFO] [cpw.mods.modlauncher.Launcher]: ModLauncher 10.0.9+10.0.9+main.dcd20f30 starting: java version 19.0.2 by Oracle Corporation; OS Windows 10 arch amd64 version 10.0 [13:04:00] [main/INFO] [net.minecraftforge.fml.loading.ImmediateWindowHandler]: ImmediateWindowProvider not loading because launch target is forgeserver [13:04:00] [main/INFO] [mixin-transmog]: Mixin Transmogrifier is definitely up to no good... [13:04:00] [main/INFO] [mixin-transmog]: crimes against java were committed [13:04:00] [main/INFO] [mixin-transmog]: Original mixin transformation service successfully crobbed by mixin-transmogrifier! [13:04:00] [main/INFO] [mixin]: SpongePowered MIXIN Subsystem Version=0.8.5 Source=union:/F:/Mattia/servermod/mods/Connector-1.0.0-beta.31+1.20.1.jar%23260%23263!/ Service=ModLauncher Env=SERVER [13:04:01] [main/WARN] [net.minecraftforge.jarjar.selection.JarSelector]: Attempted to select two dependency jars from JarJar which have the same identification: Mod File: and Mod File: . Using Mod File: [13:04:01] [main/WARN] [net.minecraftforge.jarjar.selection.JarSelector]: Attempted to select a dependency jar for JarJar which was passed in as source: curios. Using Mod File: F:\Mattia\servermod\mods\curios-forge-5.4.6+1.20.1.jar [13:04:01] [main/INFO] [net.minecraftforge.fml.loading.moddiscovery.JarInJarDependencyLocator]: Found 56 dependencies adding them to mods collection [13:04:04] [main/INFO] [dev.su5ed.sinytra.connector.locator.DependencyResolver]: Dependency resolution found 4 candidates to load [13:04:05] [main/INFO] [dev.su5ed.sinytra.connector.service.ModuleLayerMigrator]: Successfully made module authlib transformable [13:04:07] [main/INFO] [mixin]: Compatibility level set to JAVA_17 [13:04:08] [main/INFO] [cpw.mods.modlauncher.LaunchServiceHandler]: Launching target 'forgeserver' with arguments [nogui] [13:04:08] [main/INFO] [ModernFix]: Loaded configuration file for ModernFix 5.10.1+mc1.20.1: 72 options available, 0 override(s) found [13:04:08] [main/INFO] [ModernFix]: Applying Nashorn fix [13:04:08] [main/INFO] [ModernFix]: Applied Forge config corruption patch [13:04:08] [main/WARN] [mixin]: Reference map 'morevillagers-forge-forge-refmap.json' for morevillagers.mixins.json could not be read. If this is a development environment you can ignore this message [13:04:08] [main/WARN] [mixin]: Reference map 'oculus-refmap.json' for mixins.oculus.compat.json could not be read. If this is a development environment you can ignore this message [13:04:08] [main/WARN] [mixin]: Reference map 'nitrogen_internals.refmap.json' for nitrogen_internals.mixins.json could not be read. If this is a development environment you can ignore this message [13:04:08] [main/INFO] [Canary]: Loaded configuration file for Canary: 123 options available, 0 override(s) found [13:04:08] [main/WARN] [mixin]: Reference map 'mvs-forge-refmap.json' for mvs-forge.mixins.json could not be read. If this is a development environment you can ignore this message [13:04:08] [main/WARN] [mixin]: Reference map 'cristellib-forge-refmap.json' for cristellib.mixins.json could not be read. If this is a development environment you can ignore this message [13:04:10] [main/INFO] [net.minecraftforge.coremod.CoreMod.placebo]: Patching IForgeItemStack#getEnchantmentLevel [13:04:10] [main/INFO] [net.minecraftforge.coremod.CoreMod.placebo]: Patching IForgeItemStack#getEnchantmentLevel [13:04:13] [main/INFO] [com.cupboard.Cupboard]: Loaded config for: structureessentials.json [13:04:15] [main/INFO] [net.minecraftforge.coremod.CoreMod.apotheosis]: Replaced 2 calls to Enchantment#getMaxLevel() in net/minecraft/world/inventory/AnvilMenu [13:04:15] [main/INFO] [net.minecraftforge.coremod.CoreMod.placebo]: Patching IForgeItemStack#getEnchantmentLevel [13:04:15] [main/INFO] [net.minecraftforge.coremod.CoreMod.placebo]: Patching IForgeItemStack#getEnchantmentLevel [13:04:16] [main/WARN] [mixin]: Error loading class: com/hollingsworth/arsnouveau/common/items/SpellCrossbow (java.lang.ClassNotFoundException: com.hollingsworth.arsnouveau.common.items.SpellCrossbow) [13:04:16] [main/ERROR] [net.minecraftforge.fml.loading.RuntimeDistCleaner]: Attempted to load class net/minecraft/client/MouseHandler for invalid dist DEDICATED_SERVER [13:04:16] [main/WARN] [mixin]: Error loading class: net/minecraft/client/MouseHandler (java.lang.RuntimeException: Attempted to load class net/minecraft/client/MouseHandler for invalid dist DEDICATED_SERVER) [13:04:16] [main/WARN] [mixin]: @Mixin target net.minecraft.client.MouseHandler was not found fabric-screen-api-v1.mixins.json:MouseMixin from mod fabric_screen_api_v1 [13:04:16] [main/ERROR] [net.minecraftforge.fml.loading.RuntimeDistCleaner]: Attempted to load class net/minecraft/client/gui/screens/Screen for invalid dist DEDICATED_SERVER [13:04:16] [main/WARN] [mixin]: Error loading class: net/minecraft/client/gui/screens/Screen (java.lang.RuntimeException: Attempted to load class net/minecraft/client/gui/screens/Screen for invalid dist DEDICATED_SERVER) [13:04:16] [main/WARN] [mixin]: @Mixin target net.minecraft.client.gui.screens.Screen was not found fabric-screen-api-v1.mixins.json:ScreenAccessor from mod fabric_screen_api_v1 [13:04:29] [main/INFO] [MixinExtras|Service]: Initializing MixinExtras via com.llamalad7.mixinextras.service.MixinExtrasServiceImpl(version=0.3.1). [13:04:33] [main/INFO] [net.minecraft.server.Bootstrap]: ModernFix reached bootstrap stage (40.93 s after launch) [13:04:35] [main/INFO] [ModernFix]: Injecting BlockStateBase cache population hook into getNeighborPathNodeType from com.abdelaziz.canary.mixin.ai.pathing.BlockStateBaseMixin [13:04:35] [main/INFO] [ModernFix]: Injecting BlockStateBase cache population hook into getPathNodeType from com.abdelaziz.canary.mixin.ai.pathing.BlockStateBaseMixin [13:04:35] [main/INFO] [ModernFix]: Injecting BlockStateBase cache population hook into getAllFlags from com.abdelaziz.canary.mixin.util.block_tracking.BlockStateBaseMixin HELP ME PLS!
  2. I'm trying to install forge to play with my friends in a minecraft server with mods, but yesterday while I was waiting for Forge to install, it appeared that "These libraries failed to downland. Try again." I was trying to solve it with tutorials, until one of those appeared that I must download the files that appear in the panel where the errors appeared (that is, what I should download, I can't explain myself.) In which, I had two problems : 1. There were things that I couldn't download, either because I didn't understand full English or because when I searched for it in my browser there were no pages that would let them download. 2. In my search, a user appeared to fix my Java version (My Java version is 8, or higer) or if it didn't work, to delete the library folder. This last one caused me big problems, since not being so experienced in these types of problems was already stressing me out at this point, so I then decided to try opening forge and now I have even more files to download - some of which I tried to download. try and there weren't even any pages explaining it or people with a similar error. Currently I can't see the forge log either, so I don't know what to do. (I apologize if there are any errors in the text, I am Spanish speaking and the vast majority of this was written with a translator.)
  3. I wanted to start up a server me and my friends have been playing on. We pased for about 4 month now. When I press the run.bat file ist opens up, takes a few seconds and says pleas press a button. When I press one it closes as if nothing had happened. I tryed creating a second server, but the same problem. could someone help me?
  4. I downloaded this modpack today and i have no clue why it keeps crashing when loading the mods, my drivers and windows are up to date and im pretty stumped about this Debug Log: https://pastebin.com/hDu7pFfx
  5. Exception in thread "main" java.lang.IllegalStateException: Current Java is 1.8.0_271 but we require at least 17 at net.minecraftforge.bootstrap.shim.Main.main(Main.java:32) Never have successfully gotten a minecraft server up and running so I thought i'd try again. Instant unfixable issue.
  6. hello! A problem occurred running the Server Exception in thread " main " java.lang.RuntimeException: java.lang.reflect.InvocationTragetException at MC-BOOSTRAP/[email protected]/cwp.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:53) +7 more Caused by: java.lang.reflect.InvocationTargetException at java.base/jdk.internal.reflect.DirectMethodHandleAccessor.invoke(DirectMethodHandleAccesor.java:118) and other things what is the issue with this server thing?
  7. I can't start my modded 1.18.2 minecraft server because I think it keeps crashing or something. Here's all the code lines from CMD: https://paste.ee/p/Rm2bU
  8. So I'm trying to run an RLCraft on the Ubuntu server version, created mods file but when I try to use run.sh I get: Exception in thread "main" java.lang.IllegalArgumentException: kotlin.native.concurrent: Invalid package name: 'native' is not a Java identifier The current version of Java I have installed is: OpenJDK version "17.0.10" 2024-01-16 OpenJDK Runtime Environment (build 17.0.10+7-Ubuntu-122.04.1) OpenJDK 64-Bit Server VM (build 17.0.10+7-Ubuntu-122.04.1, mixed mode, sharing) I tried to manually input all of the RLCrafts files for the zipped server download by just unzipping and putting them into their dedicated places. EX: I removed the created mods file, then implemented it back in with all of the RLCrafts mods along with config. Then I added the stuff that was missing, like resource packs and resources the forge version I installed for the server was I think 1.20.2 or something like that I downloaded the recommend one This is my first time doing this plz help brain hurts
  9. Cuando quiero abrir mi server de minecraft forge 1.20.1, abro el .bat y me vota error me dice "Error: no se ha encontrado o cargado la clase principal @user_jvm_args.txt" que puedo hacer?
  10. If I try to run the provided batch file, I recieve an error regarding opening the file 'user_jvm_args.txt'. If I replace the 'user_jvm_args.txt' with my memory settings, I recieve the same error regarding 'win_args.txt', located in the folder 'libraries/net/minecraftforge/1.20.1-47.2.0'. If I try and directly run the forge server file located in the afformentioned folder, I recieve an error referencing a possibly corrupted jarfile If I run the forge installer directly from cmd, the output I recieve in the terminal is: Please note that I have attempted various other forge server versions and tried downloading the installer multiple times, yet I have consistently recieved the above errors. Please also note that the reason I am using 1.20.1 is because that is Create has not as of yet updated to any more recent versions. Bear in mind I may be stupid 🙏
  11. Recently, every time I try to launch Minecraft using 1.20.1 Forge (even without mods) the game crashes. I even tried downloading a different version of Forge 1.20.1 and that didn't work either. I tried updating my drivers but they were all up to date. I restarted my computer and even uninstalled and reinstalled both Minecraft and Forge, neither of which worked. Here is a link to the log: https://pastebin.com/ViXCATLy
  12. thus is the text it keeps creating C:\Users\Toby\Desktop\server>java -Xmx8g -Xms8g -jar forge-1.12.2-14.23.5.2860.jar nogui A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:77) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.base/java.lang.reflect.Method.invoke(Method.java:568) at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:70) at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:34) Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap') at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34) at net.minecraft.launchwrapper.Launch.main(Launch.java:28) ... 6 more C:\Users\Toby\Desktop\server>PAUSE Press any key to continue . . . also if i launch it using the jar file it works fine im using the bat because it crashes due to to little memory
  13. The version is 1.12.2 (ik it's not supported, but I think it's not a very difficult problem). Basically the server crashes on startup and it doesn't leave any crash log. I tried with both 14.23.5.2859 and 14.23.5.2860 and it happens the same.
  14. When i try to install forge 1.20.1 I get the error in the description. I am using an M2 macbook pro if that helps, also i gave the log files for both the recommended and latest, i couldn't figure out how to upload the file, so thats why i'm giving 2 google doc links: Latest: https://docs.google.com/document/d/1w8XphCjgTD2SGiUNNWFcyaIJBRgYiKFpvUX_Mmp7Co8/edit?usp=sharing Recommended: https://docs.google.com/document/d/10w-AiyLPuL_gq_WvYiIUm5HSsX9o7gtCwkg9v9ZepkQ/edit?usp=sharing
  15. So I am making a 19.2 Minecraft server, and anytime I try running the run.bat program, it gives me: Error: Could not find or load main class @user_jvm_args.txt Press any key to continue . . . How can I fix this? I uninstalled and reinstalled and it still will not work
  16. so i am trying to set up a modded server with some friends but when i downloaded it i tried using the run.bat file and it said "Error: Could not find or load main class @user_jvm_args.txt Press any key to continue . . ." now i did check the forums a bit but not to much so sorry if someone has the same problem
  17. 2023-08-26 01:27:07,558 main WARN Advanced terminal features are not available in this environment [01:27:07] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--launchTarget, forgeserver, --fml.forgeVersion, 43.2.0, --fml.mcVersion, 1.19.2, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20220805.130853] [01:27:07] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 10.0.8+10.0.8+main.0ef7e830 starting: java version 20.0.2 by Oracle Corporation; OS Windows 10 arch amd64 version 10.0 [01:27:08] [main/INFO] [op.OptiFineTransformationService/]: OptiFineTransformationService.onLoad [01:27:08] [main/INFO] [op.OptiFineTransformationService/]: OptiFine ZIP file URL: union:/C:/Users/Acer/Desktop/server%20redbit%20mods/mods/OptiFine-OptiFine-1.19.2_HD_U_I1.jar%23127!/ [01:27:08] [main/INFO] [op.OptiFineTransformationService/]: OptiFine ZIP file: C:\Users\Acer\Desktop\server redbit mods\mods\OptiFine-OptiFine-1.19.2_HD_U_I1.jar [01:27:08] [main/INFO] [op.OptiFineTransformer/]: Target.PRE_CLASS is available [01:27:08] [main/INFO] [mixin/]: SpongePowered MIXIN Subsystem Version=0.8.5 Source=union:/C:/Users/Acer/Desktop/server%20redbit%20mods/libraries/org/spongepowered/mixin/0.8.5/mixin-0.8.5.jar%2363!/ Service=ModLauncher Env=SERVER [01:27:08] [main/INFO] [op.OptiFineTransformationService/]: OptiFineTransformationService.initialize [01:27:09] [main/WARN] [ne.mi.fm.lo.mo.ModFileParser/LOADING]: Mod file C:\Users\Acer\Desktop\server redbit mods\libraries\net\minecraftforge\fmlcore\1.19.2-43.2.0\fmlcore-1.19.2-43.2.0.jar is missing mods.toml file [01:27:09] [main/WARN] [ne.mi.fm.lo.mo.ModFileParser/LOADING]: Mod file C:\Users\Acer\Desktop\server redbit mods\libraries\net\minecraftforge\javafmllanguage\1.19.2-43.2.0\javafmllanguage-1.19.2-43.2.0.jar is missing mods.toml file [01:27:09] [main/WARN] [ne.mi.fm.lo.mo.ModFileParser/LOADING]: Mod file C:\Users\Acer\Desktop\server redbit mods\libraries\net\minecraftforge\lowcodelanguage\1.19.2-43.2.0\lowcodelanguage-1.19.2-43.2.0.jar is missing mods.toml file [01:27:09] [main/WARN] [ne.mi.fm.lo.mo.ModFileParser/LOADING]: Mod file C:\Users\Acer\Desktop\server redbit mods\libraries\net\minecraftforge\mclanguage\1.19.2-43.2.0\mclanguage-1.19.2-43.2.0.jar is missing mods.toml file [01:27:09] [main/INFO] [ne.mi.fm.lo.mo.JarInJarDependencyLocator/]: No dependencies to load found. Skipping! [01:27:09] [main/INFO] [op.OptiFineTransformationService/]: OptiFineTransformationService.transformers [01:27:09] [main/INFO] [op.OptiFineTransformer/]: Targets: 386 [01:27:10] [main/INFO] [op.OptiFineTransformationService/]: additionalClassesLocator: [optifine., net.optifine.] [01:27:11] [main/INFO] [mixin/]: Compatibility level set to JAVA_17 [01:27:11] [main/INFO] [mixin/]: Successfully loaded Mixin Connector [org.tlauncher.MixinConnector] [01:27:11] [main/INFO] [cp.mo.mo.LaunchServiceHandler/MODLAUNCHER]: Launching target 'forgeserver' with arguments [] [01:27:12] [main/WARN] [mixin/]: Error loading class: net/minecraft/world/entity/LivingEntity (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:12] [main/WARN] [mixin/]: @Mixin target net.minecraft.world.entity.LivingEntity was not found citadel.mixins.json:LivingEntityMixin [01:27:12] [main/WARN] [mixin/]: Error loading class: net/minecraft/server/MinecraftServer (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:12] [main/WARN] [mixin/]: @Mixin target net.minecraft.server.MinecraftServer was not found citadel.mixins.json:MinecraftServerMixin [01:27:12] [main/WARN] [mixin/]: Error loading class: net/minecraft/server/level/ServerLevel (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:12] [main/WARN] [mixin/]: @Mixin target net.minecraft.server.level.ServerLevel was not found citadel.mixins.json:ServerLevelMixin [01:27:12] [main/WARN] [mixin/]: Error loading class: net/minecraft/world/entity/LivingEntity (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:12] [main/WARN] [mixin/]: @Mixin target net.minecraft.world.entity.LivingEntity was not found bookshelf.common.mixins.json:entity.AccessorLivingEntity [01:27:12] [main/WARN] [mixin/]: Error loading class: net/minecraft/world/entity/LivingEntity (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:12] [main/WARN] [mixin/]: @Mixin target net.minecraft.world.entity.LivingEntity was not found bookshelf.common.mixins.json:entity.MixinLivingEntity [01:27:12] [main/WARN] [mixin/]: Error loading class: net/minecraft/server/MinecraftServer (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:12] [main/WARN] [mixin/]: @Mixin target net.minecraft.server.MinecraftServer was not found balm.mixins.json:MinecraftServerMixin [01:27:12] [main/ERROR] [ne.mi.fm.lo.RuntimeDistCleaner/DISTXFORM]: Attempted to load class net/minecraft/client/gui/screens/Screen for invalid dist DEDICATED_SERVER [01:27:12] [main/WARN] [mixin/]: Error loading class: net/minecraft/client/gui/screens/TitleScreen (java.lang.RuntimeException: Attempted to load class net/minecraft/client/gui/screens/Screen for invalid dist DEDICATED_SERVER) [01:27:12] [main/WARN] [mixin/]: @Mixin target net.minecraft.client.gui.screens.TitleScreen was not found tlskincape-mixins.json:MixinMainMenu [01:27:12] [main/WARN] [mixin/]: Error loading class: net/minecraft/client/model/PlayerModel (java.lang.ClassNotFoundException: net.minecraft.client.model.PlayerModel) [01:27:12] [main/WARN] [mixin/]: @Mixin target net.minecraft.client.model.PlayerModel was not found tlskincape-mixins.json:MixinPlayerModel [01:27:12] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:12] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:12] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:12] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:12] [main/WARN] [mixin/]: Error loading class: java/util/Map$Entry (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:12] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:12] [main/WARN] [mixin/]: Error loading class: java/util/Map$Entry (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:12] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [01:27:13] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) Exception in thread "main" java.lang.RuntimeException: java.lang.IllegalArgumentException: Unsupported class file major version 64 at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:32) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:53) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:71) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.Launcher.run(Launcher.java:106) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.Launcher.main(Launcher.java:77) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:26) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:23) at [email protected]/cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:141) Caused by: java.lang.IllegalArgumentException: Unsupported class file major version 64 at [email protected]/org.objectweb.asm.ClassReader.<init>(ClassReader.java:199) at [email protected]/org.objectweb.asm.ClassReader.<init>(ClassReader.java:180) at [email protected]/org.objectweb.asm.ClassReader.<init>(ClassReader.java:166) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.ClassTransformer.transform(ClassTransformer.java:75) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformingClassLoader.maybeTransformClassBytes(TransformingClassLoader.java:50) at cpw.mods.securejarhandler/cpw.mods.cl.ModuleClassLoader.getMaybeTransformedClassBytes(ModuleClassLoader.java:250) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformingClassLoader.buildTransformedClassNodeFor(TransformingClassLoader.java:58) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter.computeHierarchyFromFile(TransformerClassWriter.java:149) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter.computeHierarchy(TransformerClassWriter.java:112) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter$SuperCollectingVisitor.lambda$visit$0(TransformerClassWriter.java:185) at java.base/java.util.Spliterators$ArraySpliterator.forEachRemaining(Spliterators.java:1006) at java.base/java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:762) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter$SuperCollectingVisitor.visit(TransformerClassWriter.java:184) at [email protected]/org.objectweb.asm.ClassReader.accept(ClassReader.java:569) at [email protected]/org.objectweb.asm.ClassReader.accept(ClassReader.java:424) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter.computeHierarchyFromFile(TransformerClassWriter.java:151) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter.computeHierarchy(TransformerClassWriter.java:112) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter$SuperCollectingVisitor.lambda$visit$0(TransformerClassWriter.java:185) at java.base/java.util.Spliterators$ArraySpliterator.forEachRemaining(Spliterators.java:1006) at java.base/java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:762) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter$SuperCollectingVisitor.visit(TransformerClassWriter.java:184) at [email protected]/org.objectweb.asm.ClassReader.accept(ClassReader.java:569) at [email protected]/org.objectweb.asm.ClassReader.accept(ClassReader.java:424) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter.computeHierarchyFromFile(TransformerClassWriter.java:151) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter.computeHierarchy(TransformerClassWriter.java:112) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter$SuperCollectingVisitor.visit(TransformerClassWriter.java:177) at [email protected]/org.objectweb.asm.ClassReader.accept(ClassReader.java:569) at [email protected]/org.objectweb.asm.ClassReader.accept(ClassReader.java:424) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter.computeHierarchyFromFile(TransformerClassWriter.java:151) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter.computeHierarchy(TransformerClassWriter.java:112) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter$SuperCollectingVisitor.visit(TransformerClassWriter.java:177) at [email protected]/org.objectweb.asm.tree.ClassNode.accept(ClassNode.java:371) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter.computeHierarchy(TransformerClassWriter.java:99) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformerClassWriter.getCommonSuperClass(TransformerClassWriter.java:59) at [email protected]/org.objectweb.asm.SymbolTable.addMergedType(SymbolTable.java:1202) at [email protected]/org.objectweb.asm.Frame.merge(Frame.java:1299) at [email protected]/org.objectweb.asm.Frame.merge(Frame.java:1197) at [email protected]/org.objectweb.asm.MethodWriter.computeAllFrames(MethodWriter.java:1611) at [email protected]/org.objectweb.asm.MethodWriter.visitMaxs(MethodWriter.java:1547) at [email protected]/org.objectweb.asm.tree.MethodNode.accept(MethodNode.java:767) at [email protected]/org.objectweb.asm.tree.MethodNode.accept(MethodNode.java:647) at [email protected]/org.objectweb.asm.tree.ClassNode.accept(ClassNode.java:451) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.ClassTransformer.transform(ClassTransformer.java:133) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformingClassLoader.maybeTransformClassBytes(TransformingClassLoader.java:50) at cpw.mods.securejarhandler/cpw.mods.cl.ModuleClassLoader.readerToClass(ModuleClassLoader.java:113) at cpw.mods.securejarhandler/cpw.mods.cl.ModuleClassLoader.lambda$findClass$15(ModuleClassLoader.java:219) at cpw.mods.securejarhandler/cpw.mods.cl.ModuleClassLoader.loadFromModule(ModuleClassLoader.java:229) at cpw.mods.securejarhandler/cpw.mods.cl.ModuleClassLoader.findClass(ModuleClassLoader.java:219) at cpw.mods.securejarhandler/cpw.mods.cl.ModuleClassLoader.loadClass(ModuleClassLoader.java:135) at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521) at java.base/java.lang.Class.getDeclaredMethods0(Native Method) at java.base/java.lang.Class.privateGetDeclaredMethods(Class.java:3502) at java.base/java.lang.Class.getMethodsRecursive(Class.java:3643) at java.base/java.lang.Class.getMethod0(Class.java:3629) at java.base/java.lang.Class.getMethod(Class.java:2319) at MC-BOOTSTRAP/[email protected]/net.minecraftforge.fml.loading.targets.CommonServerLaunchHandler.lambda$launchService$0(CommonServerLaunchHandler.java:29) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:30) ... 7 more Presione una tecla para continuar . . .
  18. I have been trying to set up a server, but I keep having errors with so many of my mods. I even went through and found what mods were having issues. I have included the debug log, a list of the mods that failed to load during my tests, and a crash report from one of the mods on the list that crashed after the server had started. If this problem is too big or complicated to fix, please tell me so I can start looking into cutting mods instead of waiting for a reply. I really appreciate any help you can provide. https://pastebin.com/gCvEBrbP -- debug log https://pastebin.com/czAe2NZp -- crash report https://pastebin.com/xNyLwYtL -- broken mod list
  19. During the forge installation, I pressed the install client button and clicked ok, and then this error popped up
  20. When I launch the game, it closes regardless, I think it can only be done with optifine, when I install one more like a minimap or any other like the backpack mod, the game simply closes, so I can't play with mods in that version, any solution?
  21. My friend gave me his minecraft server with forge 1.18.2 installed and I can't get it started Logs: https://pastebin.com/smnLrwXz
  22. I'm launching run.bat and it gives me: D:\Forge>REM Forge requires a configured set of both JVM and program arguments. D:\Forge>REM Add custom JVM arguments to the user_jvm_args.txt D:\Forge>REM Add custom program arguments {such as nogui} to this file in the next line before the or D:\Forge>REM pass them to this script directly D:\Forge>java @user_jvm_args.txt @libraries/net/minecraftforge/forge/1.18.2-40.2.4/win_args.txt Error: Could not find or load main class @user_jvm_args.txt I changed the text file and it still didn't help user_jvm_args.txt: I tried two commands -Xmx9216M -Xms1024M "C:\Program Files\Java\jdk-20.0.2\bin\java.exe" -Xmx9216M -Xms1024M -jar forge-1.18.2-40.2.4-server.jar nogui I sit and think what's wrong, what I didn't finish or missed. I already want to die.
  23. I tried to install the Minecraft Forge, bet it keeps sending me an error that libraries failed to install, can somebody help me figure out what's wrong?
  24. 2023-08-03 03:46:40,421 main WARN Advanced terminal features are not available in this environment [03:46:40] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--launchTarget, forgeserver, --fml.forgeVersion, 43.2.0, --fml.mcVersion, 1.19.2, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20220805.130853] [03:46:40] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 10.0.8+10.0.8+main.0ef7e830 starting: java version 20.0.2 by Oracle Corporation; OS Windows 10 arch amd64 version 10.0 [03:46:41] [main/INFO] [mixin/]: SpongePowered MIXIN Subsystem Version=0.8.5 Source=union:/E:/Minecraft%20Server/libraries/org/spongepowered/mixin/0.8.5/mixin-0.8.5.jar%2363!/ Service=ModLauncher Env=SERVER [03:46:41] [main/WARN] [ne.mi.fm.lo.mo.ModFileParser/LOADING]: Mod file E:\Minecraft Server\libraries\net\minecraftforge\fmlcore\1.19.2-43.2.0\fmlcore-1.19.2-43.2.0.jar is missing mods.toml file [03:46:41] [main/WARN] [ne.mi.fm.lo.mo.ModFileParser/LOADING]: Mod file E:\Minecraft Server\libraries\net\minecraftforge\javafmllanguage\1.19.2-43.2.0\javafmllanguage-1.19.2-43.2.0.jar is missing mods.toml file [03:46:41] [main/WARN] [ne.mi.fm.lo.mo.ModFileParser/LOADING]: Mod file E:\Minecraft Server\libraries\net\minecraftforge\lowcodelanguage\1.19.2-43.2.0\lowcodelanguage-1.19.2-43.2.0.jar is missing mods.toml file [03:46:41] [main/WARN] [ne.mi.fm.lo.mo.ModFileParser/LOADING]: Mod file E:\Minecraft Server\libraries\net\minecraftforge\mclanguage\1.19.2-43.2.0\mclanguage-1.19.2-43.2.0.jar is missing mods.toml file [03:46:41] [main/INFO] [ne.mi.fm.lo.mo.JarInJarDependencyLocator/]: Found 7 dependencies adding them to mods collection [03:46:44] [main/INFO] [mixin/]: Compatibility level set to JAVA_17 [03:46:44] [main/INFO] [cp.mo.mo.LaunchServiceHandler/MODLAUNCHER]: Launching target 'forgeserver' with arguments [] [03:46:44] [main/WARN] [mixin/]: Reference map 'grapplemod.refmap.json' for grapplemod.mixins.json could not be read. If this is a development environment you can ignore this message [03:46:44] [main/WARN] [mixin/]: Reference map 'Weeping-Angels-forge-refmap.json' for weeping_angels.mixins.json could not be read. If this is a development environment you can ignore this message [03:46:44] [main/WARN] [mixin/]: Reference map 'insanelib.refmap.json' for insanelib.mixins.json could not be read. If this is a development environment you can ignore this message [03:46:44] [main/WARN] [mixin/]: Reference map '${refmap_target}refmap.json' for corgilib.forge.mixins.json could not be read. If this is a development environment you can ignore this message [03:46:44] [main/WARN] [mixin/]: Reference map 'immersive_paintings-common-refmap.json' for immersive_paintings.mixin.json could not be read. If this is a development environment you can ignore this message [03:46:44] [main/WARN] [mixin/]: Reference map 'yungsextras.refmap.json' for yungsextras.mixins.json could not be read. If this is a development environment you can ignore this message [03:46:44] [main/WARN] [mixin/]: Reference map 'yungsextras.refmap.json' for yungsextras_forge.mixins.json could not be read. If this is a development environment you can ignore this message [03:46:44] [main/WARN] [mixin/]: Error loading class: net/minecraft/server/level/ServerLevel (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:44] [main/WARN] [mixin/]: @Mixin target net.minecraft.server.level.ServerLevel was not found citadel.mixins.json:ServerLevelMixin [03:46:44] [main/WARN] [mixin/]: Error loading class: net/minecraft/server/level/ServerLevel (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:44] [main/WARN] [mixin/]: @Mixin target net.minecraft.server.level.ServerLevel was not found zombieawareness.mixins.json:MixinPlaySound [03:46:44] [main/WARN] [mixin/]: Error loading class: net/minecraft/server/level/ServerLevel (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:44] [main/WARN] [mixin/]: @Mixin target net.minecraft.server.level.ServerLevel was not found zombieawareness.mixins.json:MixinLevelEvent [03:46:44] [main/WARN] [mixin/]: Error loading class: net/minecraft/server/level/ServerLevel (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:44] [main/WARN] [mixin/]: @Mixin target net.minecraft.server.level.ServerLevel was not found supplementaries-common.mixins.json:ServerLevelMixin [03:46:45] [main/WARN] [mixin/]: Error loading class: net/minecraft/server/level/ServerLevel (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: @Mixin target net.minecraft.server.level.ServerLevel was not found corgilib.mixins.json:MixinServerLevel [03:46:45] [main/WARN] [mixin/]: Error loading class: net/minecraft/server/level/ServerLevel (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: @Mixin target net.minecraft.server.level.ServerLevel was not found enhancedcelestials.mixins.json:MixinServerWorld [03:46:45] [main/WARN] [mixin/]: Error loading class: net/minecraft/server/level/ServerLevel (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: @Mixin target net.minecraft.server.level.ServerLevel was not found byg.mixins.json:common.world.MixinServerLevel [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/util/Map$Entry (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/invoke/MethodHandles$Lookup (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/util/Map$Entry (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/lang/Record (java.lang.IllegalArgumentException: Unsupported class file major version 64) [03:46:45] [main/WARN] [mixin/]: Error loading class: java/util/Set (java.lang.IllegalArgumentException: Unsupported class file major version 64) Exception in thread "main" java.lang.RuntimeException: org.spongepowered.asm.mixin.transformer.throwables.MixinTransformerError: An unexpected critical error was encountered at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:32) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:53) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:71) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.Launcher.run(Launcher.java:106) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.Launcher.main(Launcher.java:77) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:26) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:23) at [email protected]/cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:141) Caused by: org.spongepowered.asm.mixin.transformer.throwables.MixinTransformerError: An unexpected critical error was encountered at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinProcessor.applyMixins(MixinProcessor.java:392) at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinTransformer.transformClass(MixinTransformer.java:250) at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.service.modlauncher.MixinTransformationHandler.processClass(MixinTransformationHandler.java:131) at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.launch.MixinLaunchPluginLegacy.processClass(MixinLaunchPluginLegacy.java:131) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.serviceapi.ILaunchPluginService.processClassWithFlags(ILaunchPluginService.java:156) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.LaunchPluginHandler.offerClassNodeToPlugins(LaunchPluginHandler.java:88) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.ClassTransformer.transform(ClassTransformer.java:120) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformingClassLoader.maybeTransformClassBytes(TransformingClassLoader.java:50) at cpw.mods.securejarhandler/cpw.mods.cl.ModuleClassLoader.readerToClass(ModuleClassLoader.java:113) at cpw.mods.securejarhandler/cpw.mods.cl.ModuleClassLoader.lambda$findClass$15(ModuleClassLoader.java:219) at cpw.mods.securejarhandler/cpw.mods.cl.ModuleClassLoader.loadFromModule(ModuleClassLoader.java:229) at cpw.mods.securejarhandler/cpw.mods.cl.ModuleClassLoader.findClass(ModuleClassLoader.java:219) at cpw.mods.securejarhandler/cpw.mods.cl.ModuleClassLoader.loadClass(ModuleClassLoader.java:135) at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521) at java.base/java.lang.Class.getDeclaredMethods0(Native Method) at java.base/java.lang.Class.privateGetDeclaredMethods(Class.java:3502) at java.base/java.lang.Class.getMethodsRecursive(Class.java:3643) at java.base/java.lang.Class.getMethod0(Class.java:3629) at java.base/java.lang.Class.getMethod(Class.java:2319) at MC-BOOTSTRAP/[email protected]/net.minecraftforge.fml.loading.targets.CommonServerLaunchHandler.lambda$launchService$0(CommonServerLaunchHandler.java:29) at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:30) ... 7 more Caused by: org.spongepowered.asm.mixin.throwables.ClassMetadataNotFoundException: java.util.Set at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinPreProcessorStandard.transformMethod(MixinPreProcessorStandard.java:754) at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinPreProcessorStandard.transform(MixinPreProcessorStandard.java:739) at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinPreProcessorStandard.attach(MixinPreProcessorStandard.java:310) at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinPreProcessorStandard.createContextFor(MixinPreProcessorStandard.java:280) at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinInfo.createContextFor(MixinInfo.java:1288) at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinApplicatorStandard.apply(MixinApplicatorStandard.java:292) at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.TargetClassContext.apply(TargetClassContext.java:383) at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.TargetClassContext.applyMixins(TargetClassContext.java:365) at MC-BOOTSTRAP/org.spongepowered.mixin/org.spongepowered.asm.mixin.transformer.MixinProcessor.applyMixins(MixinProcessor.java:363) ... 27 more Press any key to continue . . . I've removed client-side mods, allocated RAM, and even tested each mod out one by one. I'm already using JAVA 17 and IDK what else to do. Things being a pain. Help pls
  25. C:\Users\xsgra\Downloads\serverprime>java -Xmx4096M -Xms4096M -jar forgeserver.jar nogui 2023-07-31 23:50:12,533 main WARN Advanced terminal features are not available in this environment [23:50:12] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.39, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui] [23:50:12] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.1.3+8.1.3+main-8.1.x.c94d18ec starting: java version 17.0.8 by Oracle Corporation Exception in thread "main" java.lang.IllegalAccessError: class cpw.mods.modlauncher.SecureJarHandler (in unnamed module @0x78b729e6) cannot access class sun.security.util.ManifestEntryVerifier (in module java.base) because module java.base does not export sun.security.util to unnamed module @0x78b729e6 at cpw.mods.modlauncher.SecureJarHandler.lambda$static$1(SecureJarHandler.java:45) at cpw.mods.modlauncher.api.LamdbaExceptionUtils.uncheck(LamdbaExceptionUtils.java:95) at cpw.mods.modlauncher.SecureJarHandler.<clinit>(SecureJarHandler.java:45) at cpw.mods.modlauncher.Launcher.lambda$new$6(Launcher.java:55) at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1708) at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:52) at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:47) at cpw.mods.modlauncher.Environment.computePropertyIfAbsent(Environment.java:62) at cpw.mods.modlauncher.Launcher.<init>(Launcher.java:55) at cpw.mods.modlauncher.Launcher.main(Launcher.java:66) at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:49) at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:46) at net.minecraftforge.server.ServerMain.main(ServerMain.java:43) C:\Users\xsgra\Downloads\serverprime>PAUSE
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.