Jump to content

headless forge linux server - commands typed into terminal not doing anything


umitn

Recommended Posts

Hi there. I'm running Ubuntu Server 20.04, and used to run a Paper 1.16 server.

 

I'm trying to set up a Forge server to play with mods now, and it seems to work okay...except that I can't pass any commands to the server from the terminal its running in.

 

Here's an example of what I mean (screenshot):

hrdoguC.png

 

You can see that I tried to type "help" several times, even incorrectly etc, and nothing happened. I'm suspecting that the text isn't going to the server process at all, and is just being spit out to the text buffer itself and going nowhere.

 

When I run the server with the GUI (i.e. without passing nogui) I can of course use the GUI to enter commands functionally. But I cannot use this, as I'm trying to run this inside TMUX and be able to start and stop it through SSH. I didn't have this issue on Paper.

 

I did try deleting all of my mods and reinstalling forge server through the latest jar (I also tried the Recommended Stable) and the same issue occurs.

 

Has anyone else come across this problem? If so, how did you resolve it? I've looked around for at least two hours and have only found brief (unresolved) mentions of this. Thanks.

Link to comment
Share on other sites

I'd like to update my progress on this issue.

I figured out that it was my locale settings that were causing this. I had my locales set to Turkish, but once I switched them to American English the command input and all worked quite well.

I suppose others can refer to this post if they encounter similar issues.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.