Jump to content

Incomplete tag please help its been so long i read all the forums and nothing helped :(


Real_Swat

Recommended Posts

openjdk version "16.0.1" 2021-04-20
OpenJDK Runtime Environment (build 16.0.1+9-24)
OpenJDK 64-Bit Server VM (build 16.0.1+9-24, mixed mode, sharing)
:/home/container$ java -Xms128M -Xmx3072M -Dterminal.jline=false -Dterminal.ansi=true -jar server.jar.
[23:23:18] [main/INFO]: Environment: authHost='https://authserver.mojang.com', accountsHost='https://api.mojang.com', sessionHost='https://sessionserver.mojang.com', servicesHost='https://api.minecraftservices.com', name='PROD'
[23:23:19] [main/WARN]: Ambiguity between arguments [teleport, destination] and [teleport, targets] with inputs: [Player, 0123, @e, dd12be42-52a9-4a91-a8a1-11c01849e498]
[23:23:19] [main/WARN]: Ambiguity between arguments [teleport, location] and [teleport, destination] with inputs: [0.1 -0.5 .9, 0 0 0]
[23:23:19] [main/WARN]: Ambiguity between arguments [teleport, location] and [teleport, targets] with inputs: [0.1 -0.5 .9, 0 0 0]
[23:23:19] [main/WARN]: Ambiguity between arguments [teleport, targets] and [teleport, destination] with inputs: [Player, 0123, dd12be42-52a9-4a91-a8a1-11c01849e498]
[23:23:19] [main/WARN]: Ambiguity between arguments [teleport, targets, location] and [teleport, targets, destination] with inputs: [0.1 -0.5 .9, 0 0 0]
[23:23:19] [main/INFO]: Reloading ResourceManager: Default
[23:23:22] [Worker-Main-2/INFO]: Loaded 7 recipes
[23:23:22] [Worker-Main-2/INFO]: Loaded 927 advancements
[23:23:26] [Server thread/INFO]: Starting minecraft server version 1.16.5
[23:23:26] [Server thread/INFO]: Loading properties
[23:23:26] [Server thread/INFO]: Default game type: SURVIVAL
[23:23:26] [Server thread/INFO]: Generating keypair
[23:23:26] [Server thread/INFO]: Starting Minecraft server on 0.0.0.0:25568
[23:23:26] [Server thread/INFO]: Using epoll channel type
[23:23:27] [Server thread/WARN]: **** SERVER IS RUNNING IN OFFLINE/INSECURE MODE!
[23:23:27] [Server thread/WARN]: The server will make no attempt to authenticate usernames. Beware.
[23:23:27] [Server thread/WARN]: While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
[23:23:27] [Server thread/WARN]: To change this, set "online-mode" to "true" in the server.properties file.
[23:23:27] [Server thread/INFO]: Preparing level "world"
[23:23:27] [Server thread/INFO]: Preparing start region for dimension minecraft:overworld
[23:23:30] [Server thread/INFO]: Preparing spawn area: 0%
[23:23:30] [Server thread/INFO]: Preparing spawn area: 0%
[23:23:30] [Server thread/INFO]: Preparing spawn area: 0%
[23:23:30] [Server thread/INFO]: Preparing spawn area: 0%
[23:23:30] [Server thread/INFO]: Preparing spawn area: 0%
[23:23:30] [Server thread/INFO]: Preparing spawn area: 0%
[23:23:30] [Server thread/INFO]: Preparing spawn area: 0%
[23:23:36] [Worker-Main-2/INFO]: Preparing spawn area: 0%
[23:23:36] [Worker-Main-2/INFO]: Preparing spawn area: 0%
[23:23:36] [Worker-Main-2/INFO]: Preparing spawn area: 0%
[23:23:36] [Worker-Main-2/INFO]: Preparing spawn area: 0%
[23:23:36] [Worker-Main-2/INFO]: Preparing spawn area: 0%
[23:23:36] [Worker-Main-2/INFO]: Preparing spawn area: 0%
[23:23:36] [Worker-Main-2/INFO]: Preparing spawn area: 0%
[23:23:36] [Worker-Main-2/INFO]: Preparing spawn area: 0%
[23:23:36] [Worker-Main-2/INFO]: Preparing spawn area: 0%
[23:23:36] [Worker-Main-2/INFO]: Preparing spawn area: 0%
[23:23:36] [Worker-Main-2/INFO]: Preparing spawn area: 0%
[23:23:36] [Worker-Main-2/INFO]: Preparing spawn area: 0%
[23:23:36] [Server thread/INFO]: Preparing spawn area: 2%
[23:23:37] [Worker-Main-2/INFO]: Preparing spawn area: 35%
[23:23:38] [Worker-Main-2/INFO]: Preparing spawn area: 70%
[23:23:38] [Worker-Main-2/INFO]: Preparing spawn area: 83%
[23:23:38] [Worker-Main-2/INFO]: Preparing spawn area: 83%
[23:23:39] [Worker-Main-2/INFO]: Preparing spawn area: 83%
[23:23:39] [Worker-Main-2/INFO]: Preparing spawn area: 83%
[23:23:40] [Worker-Main-2/INFO]: Preparing spawn area: 83%
[23:23:40] [Server thread/WARN]: Trying to add entity with duplicated UUID 3edb239c-733a-4b12-9a60-2ceb593eb7df. Existing minecraft:salmon#66, new: minecraft:salmon#92
[23:23:40] [Worker-Main-2/INFO]: Preparing spawn area: 83%
[23:23:41] [Worker-Main-2/INFO]: Preparing spawn area: 83%
[23:23:41] [Worker-Main-2/INFO]: Preparing spawn area: 83%
[23:23:42] [Worker-Main-2/INFO]: Preparing spawn area: 83%
[23:23:42] [Worker-Main-2/INFO]: Preparing spawn area: 83%
[23:23:43] [Worker-Main-2/INFO]: Preparing spawn area: 84%
[23:23:43] [Server thread/INFO]: Preparing spawn area: 86%
[23:23:44] [Worker-Main-2/INFO]: Preparing spawn area: 87%
[23:23:44] [Server thread/INFO]: Preparing spawn area: 88%
[23:23:45] [Worker-Main-2/INFO]: Preparing spawn area: 89%
[23:23:45] [Server thread/INFO]: Preparing spawn area: 90%
[23:23:46] [Server thread/INFO]: Preparing spawn area: 93%
[23:23:46] [Server thread/INFO]: Preparing spawn area: 94%
[23:23:47] [Server thread/INFO]: Preparing spawn area: 96%
[23:23:47] [Worker-Main-2/INFO]: Preparing spawn area: 97%
[23:23:48] [Server thread/INFO]: Preparing spawn area: 99%
[23:23:48] [Server thread/INFO]: Time elapsed: 21220 ms
[23:23:48] [Server thread/INFO]: Done (21.395s)! For help, type "help"

Link to comment
Share on other sites

2 hours ago, diesieben07 said:

That is a vanilla server log. I assume you are trying to connect to it with a modded client, which can produce the error you mentioned.

Omg thx so much when I went to look if it even load forge/fabric I found out it don't and now I fixed it

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Here's a simple example to solve this particular issue: public class ModArmorMaterials { public static final DeferredRegister<ArmorMaterial> ARMORS = DeferredRegister.create(Registries.ARMOR_MATERIAL, MyModName.MOD_ID); public static final RegistryObject<ArmorMaterial> COPPER = registerArmor("copper", Util.make(new EnumMap<>(ArmorItem.Type.class), enumMap -> { enumMap.put(ArmorItem.Type.BOOTS, 1); enumMap.put(ArmorItem.Type.LEGGINGS, 4); enumMap.put(ArmorItem.Type.CHESTPLATE, 5); enumMap.put(ArmorItem.Type.HELMET, 2); enumMap.put(ArmorItem.Type.BODY, 4); }), 12, SoundEvents.ARMOR_EQUIP_IRON, 0.0F, 0.0F, () -> Ingredient.of(Items.COPPER_INGOT)); private static RegistryObject<ArmorMaterial> registerArmor(String pGroup, EnumMap<ArmorItem.Type, Integer> pEnumMap, int pEnchantmentValue, Holder<SoundEvent> pEquipSound, float pToughness, float pKnockbackResistance, Supplier<Ingredient> pRepairIngredient) { List<ArmorMaterial.Layer> pLayerList = List.of(new ArmorMaterial.Layer(new ResourceLocation(pGroup))); return registerArmor(pGroup, pEnumMap, pEnchantmentValue, pEquipSound, pToughness, pKnockbackResistance, pRepairIngredient, pLayerList); } private static RegistryObject<ArmorMaterial> registerArmor( String pGroup, EnumMap<ArmorItem.Type, Integer> pEnumMap, int pEnchantmentValue, Holder<SoundEvent> pEquipSound, float pToughness, float pKnockbackResistance, Supplier<Ingredient> pRepairIngredient, List<ArmorMaterial.Layer> pLayerList) { return ARMORS.register(pGroup, () -> new ArmorMaterial(pEnumMap, pEnchantmentValue, pEquipSound, pRepairIngredient, pLayerList, pToughness, pKnockbackResistance)); } public static void register(IEventBus eventBus) { ARMORS.register(eventBus); } } Essentially, the TierSortingRegistry has been removed and so you now need to set up your own DeferredRegister. Please see the minecraftforge GitHub for more information; I found this solution through their issues (https://github.com/MinecraftForge/MinecraftForge/issues/9961)
    • How did I even leave that in there? I’ll try it in a bit, that very well could be it.
    • Greetings, I met a problem with my Forge server (47.2.0-1.20.1) that I can't join with the following line. (singleplayer world working fine) [net.minecraft.server.network.ServerGamePacketListenerImpl/]: Sharyna lost connection: Internal Exception: io.netty.handler.codec.EncoderException: java.lang.NullPointerException: Cannot invoke "net.minecraft.resources.ResourceLocation.toString()" because "p_130086_" is null   At first it was errored with packet size error, but I fixed that with the Connectivity mod, however, after that this popped up and can't find the source of it. Since the logs are big, I couldn't upload on paste.gg or other site ... so here it is (if the files are deleted, please notice me and I'll upload again. Debug and Latest log
    • Дерево тис
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.