TheGreyGhost Posted July 12, 2013 Posted July 12, 2013 Hi I'm slowly wrestling my way through the various rendering code and I think I've come across a couple of mistakes. RenderBlocks has six renderFace methods (eg renderFaceYNeg), and these renderFace methods use some flags (set by the caller) to alter how the faces are rendered, for example uvRotateEast. The problem I'm found is that some of these aren't properly named. For example- renderFaceZPos uses the uvRotateWest flag, but the positive Z face is south, not west. Is there a robust way I can change these? i.e. so I can write renderBlock.uvRotateSouth = 1; renderBlock.renderFaceZpos(); I don't understand how Forge decompiles the Minecraft jar and gives meaningful names to everything - is this something I can customise (for example - giving better names to the parameters of various interface functions (eg par1, par2)), without having to do it all from scratch every time I update to a new version of Forge? Cheers Richard Quote
Recommended Posts
Join the conversation
You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.