Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

1.16.5 Forge server wont start


Recommended Posts

D:\Everything\Games\minecraft\Havocc - SMP V.2>java -Xmx4024M -Xms1024M -jar forge-1.16.5-36.1.10.jar nogui
2021-07-21 05:36:32,307 main WARN Advanced terminal features are not available in this environment
[05:36:32] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.1.10, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui]
[05:36:32] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 16.0.1 by Oracle Corporation
Exception in thread "main" java.lang.IllegalAccessError: class cpw.mods.modlauncher.SecureJarHandler (in unnamed module @0x4de5031f) cannot access class sun.security.util.ManifestEntryVerifier (in module java.base) because module java.base does not export sun.security.util to unnamed module @0x4de5031f
        at cpw.mods.modlauncher.SecureJarHandler.lambda$static$1(SecureJarHandler.java:41)
        at cpw.mods.modlauncher.api.LamdbaExceptionUtils.uncheck(LamdbaExceptionUtils.java:95)
        at cpw.mods.modlauncher.SecureJarHandler.<clinit>(SecureJarHandler.java:41)
        at cpw.mods.modlauncher.Launcher.lambda$new$6(Launcher.java:55)
        at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1708)
        at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:52)
        at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:47)
        at cpw.mods.modlauncher.Environment.computePropertyIfAbsent(Environment.java:62)
        at cpw.mods.modlauncher.Launcher.<init>(Launcher.java:55)
        at cpw.mods.modlauncher.Launcher.main(Launcher.java:66)
        at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63)
        at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60)
        at net.minecraftforge.server.ServerMain.main(ServerMain.java:57)

D:\Everything\Games\minecraft\Havocc - SMP V.2>pause
Press any key to continue . . .

 

Server brings this up every time I try and start it. Any Help?

Link to comment
Share on other sites

3 hours ago, diesieben07 said:

You don't need to uninstall it, however if you want to you use your normal operating system mechanisms for doing so.

For installing Java 8 we recommend https://adoptopenjdk.net/. Note that you don't need to get the full JDK, the JRE is enough to run Minecraft.

Cool it runs now! Thank you for the help! 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • So as the title says it seems im the only one with this issue, it was working fine yesturday. basically the server just keeps saying Pinging.... and doesn't load, i added a vanilla server to see if all servers would behave the same but no, my modded server was the only one. i asked some of my friends to try connecting and no problem so it seems on my end. I tried connecting even when it says pinging and it just stuck on Encrypting and then timed out Client log https://gist.github.com/thekingtoonboy/1c53875b856e0563b9313a8cc060a4a0.js latest Server log [19Sep2021 06:06:35.440] [Netty Epoll Server IO #2/INFO] [codechicken.lib.config.ConfigSyncManager/]: Skipping config sync, No mods have registered a syncable config. [19Sep2021 06:06:35.529] [Netty Epoll Server IO #2/WARN] [com.connectivity.Connectivity/]: Login payload for Registry minecraft:item is using 111.6286% of max allowed size and will cause errors during login if connectivity is not present on client side. [19Sep2021 06:06:35.543] [Netty Epoll Server IO #2/WARN] [com.connectivity.Connectivity/]: Login payload for Registry minecraft:block is using 87.6082% of max allowed size [19Sep2021 06:06:37.491] [User Authenticator #1/INFO] [net.minecraft.network.login.ServerLoginNetHandler/]: UUID of player KiingSultan is e69dbe58-dd8d-4d26-9317-a643a0ffde12 [19Sep2021 06:08:37.721] [Server thread/INFO] [net.minecraft.network.login.ServerLoginNetHandler/]: com.mojang.authlib.GameProfile@1b416c43[id=e69dbe58-dd8d-4d26-9317-a643a0ffde12,name=KiingSultan,properties={textures=[com.mojang.authlib.properties.Property@38939441]},legacy=false] (/5.193.109.22:50035) lost connection: Timed out [19Sep2021 06:13:10.808] [Netty Epoll Server IO #0/INFO] [codechicken.lib.config.ConfigSyncManager/]: Skipping config sync, No mods have registered a syncable config. [19Sep2021 06:13:10.867] [Netty Epoll Server IO #0/WARN] [com.connectivity.Connectivity/]: Login payload for Registry minecraft:item is using 111.6286% of max allowed size and will cause errors during login if connectivity is not present on client side. [19Sep2021 06:13:10.880] [Netty Epoll Server IO #0/WARN] [com.connectivity.Connectivity/]: Login payload for Registry minecraft:block is using 87.6082% of max allowed size [19Sep2021 06:13:18.792] [User Authenticator #2/INFO] [net.minecraft.network.login.ServerLoginNetHandler/]: UUID of player KiingSultan is e69dbe58-dd8d-4d26-9317-a643a0ffde12 [19Sep2021 06:15:19.013] [Server thread/INFO] [net.minecraft.network.login.ServerLoginNetHandler/]: com.mojang.authlib.GameProfile@28a892fa[id=e69dbe58-dd8d-4d26-9317-a643a0ffde12,name=KiingSultan,properties={textures=[com.mojang.authlib.properties.Property@53a47b26]},legacy=false] (/5.193.109.22:50239) lost connection: Timed out  
    • Sorry for the very late response, but mixed with what you said + looking at the twilight forest source code I was able to get it working
    • Hello Everyone! I just started learning how to code forge mods and this is my first post. I have been coding spigot plugins for 2 years so I'm not totally clueless. I just want to know how to get all the items from a Inventory/GUI. I have no clue how. I tried something like this. but it got me nowhere @SubscribeEvent public void onOpenInventory(GuiOpenEvent e) { e.getGui().itemsplsssss }  
    • I think that is the problem. I changed to using ResourceKeys instead and haven't seen the log since. 
    • That's how, thanks a lot! (≧ ▽ ≦)
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.