Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

1.17.1 i know


Recommended Posts

Befor u get mad. I readed every thing on the site en did my best to solve te problems without going to make a new topic.

 

the 1.17.1 forge version u put on download, i tryed on my game and i have java 8, so i did go check the topics for the java and all stuff on here.

But the forge wont start and stays craching while the previous version works fine. As i sayed i checked the things on here for the java and even add the rule u put in the topic for the java 16.

Tryed again and still crashes the game and wont start at all.

 

add pic to show what i mean.

 

u can see all 3: java about, edit the json file with the 2 new rules, the game with the crash screen.

 

hope this will besolved soon.

as i sayed dont get mad, i readed every thing and i also saw that u know about some stuff and that there is no need to make a topic for it,

but i dont know if this problem u are working on or already know, so i only want to help with this topic.

 

if needed/know just remove the topic.

 

with friendly greets Marobs, Big fan and forge user

 

 

Naamloos.png

  • Like 1
Link to comment
Share on other sites

The initial release of Forge 1.17.X is currently broken and being worked on, no manual changes to anything should be required.

  • Like 1

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.

 

As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.

 

For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.

Spoiler

Logs (Most issues require logs to diagnose):

Spoiler

Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.

 

What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...

 

...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension

 

Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.

 

Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

Spoiler
  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.

Video:

Spoiler

 

 

 

or alternately, 

 

Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft

 

Server Not Starting:

Spoiler

If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.

 

Reporting Illegal/Inappropriate Adfocus Ads:

Spoiler

Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.

 

Posting your mod as a GitHub Repo:

Spoiler

When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.

 

  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]

 

Link to comment
Share on other sites

The MDK seems to run my mod just fine, but after running the Forge installer, I cannot load Minecraft, with or without mods in the mods folder. At least I can start working on converting some of my mods to the new version.

error.png

Link to comment
Share on other sites

  • 1 month later...

I’m trying to play forge that 1.17 and all it ever has done was crash I have down lode it and deleted it motile time and don’t know what to of forge 1.16 still work how evry not 1.17 

it just crashes with error code 0

plz help me get this fix or fix it I want a sky bridge and I was to make stuff invisible with this mod I got for it.

Link to comment
Share on other sites

You see i thought i figured this ouy. But it turns out i didnt at first i was getting really annoyed. Then i remebered i had mods in my mod folder so i took em out. It worked i got in. Then i remembered WHAT IS THE PINT OF FORGE WITH NO FRICKIN MIDS INSTALLED

 

Link to comment
Share on other sites

9 hours ago, FR4GZz said:

You see i thought i figured this ouy. But it turns out i didnt at first i was getting really annoyed. Then i remebered i had mods in my mod folder so i took em out. It worked i got in. Then i remembered WHAT IS THE PINT OF FORGE WITH NO FRICKIN MIDS INSTALLED

 

Make your own thread and post logs.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.