Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Random Crashes on 1.16.5


SirUmnei
 Share

Recommended Posts

Hello. For the past few days I've been attempting to play a modpack of my own creation with the intent of testing it for use in a server. The pack contains 200 mods and appears to crash at completely random moments.

Sometimes, it crashes on startup, sometimes it crashes on world gen, sometimes it crashes randomly in game, or when I exit a menu. I've been attempting to pre-generate chunks with a mod, and the game would crash every time during the process. Even should I use the same exact seed and generate different amounts of chunks or generate it slower or faster, it would crash at some random moment. It never really crashes at the same point either, unless it's at startup.

I can usually play for sometime before I crash as well, which makes it even weirder. Happens out of nowhere, randomly. It does not corrupt my save, or at least has not until now.

I looked around for the main errors I could discern myself from the launcher log, forge's log, etc., but none of these yielded any results that would help me fix the problem. Most results I found said that the problem might be with Java and not Forge or Minecraft, however, even reinstalling both Java and Minecraft, using the MC Launcher by itself instead of CurseForge and many other "solutions" still yield the same issue. This issue sometimes happens as well if I attempt to run another different modpack, afterwards as well, usually crashing at startup.

The modpack is stable, other people have played with it and tried it out, and played for many hours, and they do not seem to encounter any issues whatsoever. I have then, given up trying solving the issue by myself and sought your help. 

I've linked below both the Forge log and the Launcher (?) log (the one that appears in my MC folder).

Forge Debug Log

HS_ERR_PID16640

Please let me know if I should provide any extra information, and thank you for your time.

Edited by SirUmnei
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
    • I didn't put in credentials, I used it only for testing installing forge. But still the problem mentioned above.
    • I am trying to use Forge 1.18.2, I have checked my firewall, redownloaded Forge, deleted the fml.toml file (which keeps reappearing) and looked at countless help pages. I am just trying to download and use forge so that I can play with my friends and it will not download. It tells me there may be an issue with the Java runtime config and that the exit code is one, and I have copied the exit code.   
    • Okay, i think i understand but im getting issues, i create another packet to sync entity to another players like this package com.naim.belloto.networking.packet; import com.naim.belloto.networking.handler.ClientSyncHandler; import net.minecraft.client.Minecraft; import net.minecraft.network.FriendlyByteBuf; import net.minecraftforge.api.distmarker.Dist; import net.minecraftforge.fml.DistExecutor; import net.minecraftforge.network.NetworkEvent; import java.util.Objects; import java.util.function.Supplier; public class ClientSyncPacket { public ClientSyncPacket() { } public ClientSyncPacket(FriendlyByteBuf buf) { } public void toBytes(FriendlyByteBuf buf) { } public boolean handle(Supplier<NetworkEvent.Context> ctx) { NetworkEvent.Context context = ctx.get(); context.enqueueWork(() -> { assert Minecraft.getInstance().player != null; int idplayer = Minecraft.getInstance().player.getId(); DistExecutor.unsafeCallWhenOn(Dist.CLIENT,() -> () -> ClientSyncHandler.handlePacket(ctx, idplayer)); }); return true; } } And in the handler: public class ClientSyncHandler { public static boolean handlePacket(Supplier<NetworkEvent.Context> ctx, int idPlayer) { Minecraft.getInstance().level.getEntity(idPlayer); return true; } } But is not working :// 
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.