Jump to content

[SOLVED] [1.18.1] Mixin apply failed


LazyTechwork

Recommended Posts

Hello! I have a problem with adding Immersive Engineering as a dependency. Error string: 

Mixin apply failed immersiveengineering.mixins.json:accessors.EntityAccess -> net.minecraft.world.entity.Entity: org.spongepowered.asm.mixin.gen.throwables.InvalidAccessorException No candidates were found matching f_19831_:I in net/minecraft/world/entity/Entity for immersiveengineering.mixins.json:accessors.EntityAccess->@Accessor[FIELD_GETTER]::getRemainingFireTicks()I [INJECT Applicator Phase -> immersiveengineering.mixins.json:accessors.EntityAccess -> Apply Accessors ->  -> Locate -> immersiveengineering.mixins.json:accessors.EntityAccess->@Accessor[FIELD_GETTER]::getRemainingFireTicks()I]

I manually found 

public int getRemainingFireTicks()

at net.minecraft.world.Entity, but Minecraft does not see it.

 

Used dependencies:

implementation fg.deobf("blusunrize.immersiveengineering:ImmersiveEngineering:1.18.1-7.1.0-145")
implementation fg.deobf("blusunrize.immersiveengineering:ImmersiveEngineering:1.18.1-7.1.0-145:datagen")

 

Edited by LazyTechwork
Solved
Link to comment
Share on other sites

  • LazyTechwork changed the title to [SOLVED] [1.18.1] Mixin apply failed

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.