Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[solved] Help trying to add a recipe in Minecraft 1.12.2


Recommended Posts

I'm a complete noob when it comes to anything technical like this and I'm not even sure if I'm on the right forum topic (please let me know if I need to move it).

I want to play the Pixelmon mod, and also have V0ids Smart Backpacks mod installed. One of the recipes requires Ender Dragon Scales (obtained as a drop from the Ender Dragon or crafted from the Dragon Egg), due to the way Pixelmon works there is no Ender Dragon and obviously no Dragon Egg. I would like to add a crafting recipe to Minecraft that would allow me to craft the Dragon Egg so that I can get the scales for the recipe. And just to be a pain, I'd also like to keep advancements enabled if possible. I am using CurseForge (not sure if that matters at all). Any help would be greatly appreciated and as stated, please let me know if I'm posting this in the wrong place.

Ideally I'd like the recipe to be:

[Null],            Obsidian,             [Null]

Obsidian,           Egg,                 Obsidian

Obsidian,     Ender Pearl,          Obsidian 

 

I did find a website that did this for me and supplied a json file but the earliest version of Minecraft it works on is 1.13. I'll supply the code it gave me anyway incase it helps:

 

{
    "type": "crafting_shaped",
    "pattern": [
        " # ",
        "#E#",
        "#U#"
    ],
    "key": {
        "#": {
            "item": "minecraft:obsidian"
        },
        "E": {
            "item": "minecraft:egg"
        },
        "U": {
            "item": "minecraft:ender_pearl"
        }
    },
    "result": {
        "item": "minecraft:dragon_egg",
        "count": 1
    }
}

Edited by Gh0st Corporal
Link to comment
Share on other sites

NVM I've figured it out on my own, I was just overcomplicating everything lol. If a moderator wants to remove this thread, feel free to do so

my new script is: 

recipes.addShaped(<minecraft:dragon_egg>, [
    [null, <minecraft:obsidian>, null],
    [<minecraft:obsidian>, <minecraft:egg>, <minecraft:obsidian>], 
    [<minecraft:obsidian>, <minecraft:ender_pearl>, <minecraft:obsidian>]
    ]);

Haven't bothered making it look tidy, just needed to be functional

I repeat moderators/admin/whatever label you have, I apologize if this is the wrong forum section, this is literally my first time on the site.

Link to comment
Share on other sites

  • Gh0st Corporal changed the title to [solved] Help trying to add a recipe in Minecraft 1.12.2
Guest
This topic is now closed to further replies.
 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.