Jump to content

Fluid not appearing in BC tank


endershadow
 Share

Recommended Posts

I tested out how the fluid added by my mod would render in a buildcraft tank. At first it rendered as the purple and black checkerboard pattern. But  then I added

.setIcons(Block.waterMoving.getIcon(0, 0))

to where I initialize the fluid. It then appeared as a weird mesh of a couple of vanilla textures. Anyone know how I can get the texture to work correctly?

Link to comment
Share on other sites

I tested out how the fluid added by my mod would render in a buildcraft tank. At first it rendered as the purple and black checkerboard pattern. But  then I added

.setIcons(Block.waterMoving.getIcon(0, 0))

to where I initialize the fluid. It then appeared as a weird mesh of a couple of vanilla textures. Anyone know how I can get the texture to work correctly?

Look at the vanilla lava and water classes and see how their coded see if you can figure out what your not doing

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.