Jump to content

Getting crafting components for Custom IRecipe types [SOLVED]


_bau5
 Share

Recommended Posts

So the way recipes work, as I understand it, is that when you place the components in the grid, it's checked against the CraftingManager looking for matches in item types and layouts. I'm implementing a method of crafting that doesn't hinge on the 3x3, or any layout, crafting grid at all, just the raw components themselves.

For vanilla recipes it works just fine, all IRecipes in the game (Shaped/Shapeless/Ore etc) have an array of all the item types and respective alternatives (such as for the ore dictionary recipes) so I can just go through and translate them all based on the case. However, this doesn't come as part of the interface, there is no way to be plainly given what's in the recipe. The only thing the interface offers is a way to check if it matches what is provided.

 

So this leaves me with the problem I've run into: What way is there to universally access all the components of a crafting recipe across all the custom handlers? I'm starting to get the feeling there isn't. Which is inconvenient.

 

SOLVED

This was the solution I came up with. Used cpw's reflection helper to go through all the fields until it throws an ArrayOutOfBounds exception and then break. Easy peasy.

try{
int i = 0;
do{
	try
        {
            Field f = rec.getClass().getDeclaredFields()[i++];
            f.setAccessible(true);
            Object obj = f.get(rec);
            if(obj != null){
            	if(obj instanceof Object[]){
            		Object[] objArr = (Object[])obj;
            		newRecItem.input = new Object[objArr.length];
            		for(int j = 0; j < objArr.length; j++){
            			Object obj2 = objArr[j];
            			newRecItem.input[j] = obj2;
            			if(obj2 == null){
            				if(newRecItem.items == null)
            					newRecItem.items = new ItemStack[objArr.length];
            			}else if(obj2 instanceof ItemStack){
            				if(newRecItem.items == null)
            					newRecItem.items = new ItemStack[objArr.length];
            				newRecItem.items[j] = ((ItemStack)obj2).copy();
            			}else if(obj2 instanceof String){
            				ItemStack oreStack = OreDictionary.getOres((String)obj2).get(0);
            				ItemStack newStack = new ItemStack(oreStack.itemID, oreStack.stackSize, OreDictionary.WILDCARD_VALUE);
            				if(newRecItem.items == null)
            					newRecItem.items = new ItemStack[objArr.length];
            				newRecItem.items[j] = newStack;
            			}else{
            				System.out.println("ProjectBench: Unaccounted for object type, disabling recipe. " +obj2);
            				newRecItem.forceDisable();
            			}
            				
            		}
            	}
            }
        }
        catch(ArrayIndexOutOfBoundsException ex)
        {
        	break;
        }
	catch(Exception ex){
		newRecItem.forceDisable();
	}
}
while(true);

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I created an SOUL_JAR Item that has been registered for each mob like - mod:soul_jar_minecraft_cow etc.. but it all has different registry names, i have a model file name soul_jar.json and i want to know how to bind each of those items to this class (When mod iterates through all of vanilla mobs and registering items for them).   I didn't found any info about it because all of info is outdated, and forge docs is complicated asf (i wish there would be more examples) i also used AI but it showing me only outdated info, but theres some code where i registering my item and trying to bind it to model ->   public static void register(IEventBus eventBus){ ITEMS.register(eventBus); Set<ResourceLocation> entityKeyList = ForgeRegistries.ENTITY_TYPES.getKeys(); for (ResourceLocation k : entityKeyList) { EntityType<?> entityType = ForgeRegistries.ENTITY_TYPES.getValue(k); if (!entityType.getCategory().equals(MobCategory.MISC)) { RegistryObject<Item> SOUL_JAR = ITEMS.register("soul_jar" + '_' + k.toString().replace(':', '_').replace('.', '_'), () -> new JarItem(new Item.Properties().rarity(Rarity.RARE).tab(ModTabs.MAGICAL_OBSESSION_JARS), entityType)); if (Thread.currentThread().getThreadGroup() == SidedThreadGroups.CLIENT) { ItemModelShaper itemModelShaper = Minecraft.getInstance().getItemRenderer().getItemModelShaper(); itemModelShaper.register(SOUL_JAR.get().asItem(), new ModelResourceLocation("item.soul_jar", "inventory")); } } } } I also have more questions like how to iterate through all other mods mobs also, or render mob inside of a jar in inventory, but i will try to figure it out.
    • I looked into OctoEconomyAPI and saw that it was a JAR api for fabric. This means you have a fabric mod in your mods folder. I downloaded your mod folder and wasted 2 solid hours creating a Python script to try to find the faulty mod, and eventually just gave up. I suggest you create two installations with half or the mods in each, find which one doesn't launch, cut that one in half, and repeat until you find the fabric mod. Investigué OctoEconomyAPI y vi que era una API JAR para fabric. Esto significa que tienes un mod de Fabric en tu carpeta de mods. Descargué su carpeta de mods y desperdicié 2 horas completas creando un script de Python para tratar de encontrar el mod defectuoso, y finalmente me di por vencido. Le sugiero que cree dos instalaciones con la mitad o las modificaciones en cada una, encuentre cuál no se inicia, córtela por la mitad y repita hasta que encuentre la modificación Fabric.   (The Python script I made is here): (El script de Python que hice está aquí):  
    • I've got it to work now. Instead of using the texture manager I used the Render System:   RenderSystem.setShaderTexture(0, new ResourceLocation("mcaquests", "textures/item/questbook.png"));  
    • Hello ive been having the same issue over Curse Forge's auto modding or when i use manual modding. The error seems to be within either Oculus or Rubidium. Im using 1.19 with the latest 1.19 forge + 1.19 compatible Oculus and Rubidium. Just in case the versions i am using; Oculus - oculus-1.4.3a Rubidium - rubidium-0.6.3 Note: I tried removing the two and add Optifine and it opens without a problem. I didnt use all 3 together to get this error im talking tho, i know they are not compatible with optifine dont worry. Logs Debug The actual error code im getting on start-up is ''1'' and nothing else on the pop up box. I have tried finding the jar files on the internet and insert them on my own but that didnt go too far.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.