Jump to content

[HELP] Error when testing mod through eclipse


SharkyGAMER

Recommended Posts

I get this error whenever I try to test my mod in eclipse.

 

 

Exception in thread "main" java.lang.NoClassDefFoundError: net/minecraft/launchwrapper/Launch

Caused by: java.lang.ClassNotFoundException: net.minecraft.launchwrapper.Launch

at java.net.URLClassLoader$1.run(URLClassLoader.java:202)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

 

 

 

There are absolutely no errors in my code, and when I launch Minecraft through magiclauncher it works fine.

Mod source code: http://github.com/DigitallyNative/Minextension1

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.