Jump to content

[SOLVED] Item: [modid]:[itemname] does not exist


WasteofSpaceYT

Recommended Posts

6 hours ago, WasteofSpaceYT said:

I get the error "Item: foodstuffs:cooked_rotten_flesh does not exist"

In the class ModEventBusEvents you are registering a recipe type using a vanilla registry! You should instead use the Forge registry, ForgeRegistries.RECIPE_TYPES, similar to how you register block and items. Also, looks like you missed an 's' in 'foodstuffs' in the smoked_steak.json file :)

  • Thanks 1
Link to comment
Share on other sites

  • WasteofSpaceYT changed the title to [SOLVED] Item: [modid]:[itemname] does not exist

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.