Jump to content

Starting help


MJDawson2

Recommended Posts

Hello,

In the past I have tried modding on older version of Minecraft with no issues, I know java and mostly know how gradle works. However when I tried coding for the latest version I ran into an issue. Basically when I try to run or build the client I get 

FAILURE: Build completed with 2 failures. 

And

*directory*\src\main\java\com\example\examplemod\ExampleMod.java:4: error: package net.minecraft.client does not exist
import net.minecraft.client.Minecraft;
                           ^

but like for every import. I have left the names default just to show I have edited nothing.

I am using java version "17.0.6" 2023-01-17 LTS. I have tried a lot to fix my issue but can't work anything else out.

 

The full log is here https://pastebin.com/mxbpCRfZ

 

Thanks.

 

edit: Thought I should mention I have tried gradlew --refresh-dependencies and gradlew clean with no luck.

 

Sorry I think I'm stupid, I used 1.19.2 rather than 1.19.3 and it worked, so I assume 1.19.3 is just not supported and I was just being dumb.

Edited by MJDawson2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.