Jump to content

[1.19.4] make a costume block to looks exactly as the vanilla water block ?

Recommended Posts


im doing a costume block to simulate a water stream the code it more or less done but the texture the rendered is not 

first the block is not translucent i take the water animated texture "water_still.png.mcmeta" an delete a frange to see  what happens and wtf  



soo i remove the tintindex thing to experiment and not it is not the problem 



there is in minecraft alredy transparent textures like the stained glass soo i set it whit the "light_blue_stained_glass.png" whit no tintindex 





theres some option or flag missing i alredy check the stained glass and dont see anyting usable 

public static final Block CYAN_STAINED_GLASS = register("cyan_stained_glass", stainedGlass(DyeColor.CYAN));

mi block declaraion 

	public static final RegistryObject<Block> RUNNING_WATER = registerBlock(
() -> new rwater(BlockBehaviour.Properties.copy(Blocks.WATER).noOcclusion(),
"en_us_lang" : "Running Water",
"es_es_lang" : "Corriente de Agua"
""", crear_archivos
) );



this is mi model for the block 


		    "credit": "Made with Blockbench",
		    "ambientocclusion": "true",
		    "render_type": "cutout",
		    "textures": {
		        "agua": "minecraft:block/water_still",
		        "particle": "minecraft:block/water_still"
		    "elements": [
		    { "from": [ 0, 0, 0 ],
		    "to": [ 16, 16, 16 ],
		    "faces": {
		            "down": { "uv": [ 0, 0, 16, 16 ], "texture": "#agua", "tintindex": 0, "cullface": "down" },
		            "up": { "uv": [ 0, 0, 16, 16 ], "texture": "#agua", "tintindex": 0, "cullface": "up" },
		            "north": { "uv": [ 0, 0, 16, 16 ], "texture": "#agua", "tintindex": 0, "cullface": "north" },
		            "south": { "uv": [ 0, 0, 16, 16 ], "texture": "#agua", "tintindex": 0, "cullface": "south" },
		            "west": { "uv": [ 0, 0, 16, 16 ], "texture": "#agua", "tintindex": 0, "cullface": "west" },
		                "east": { "uv": [ 0, 0, 16, 16 ], "texture": "#agua", "tintindex": 0, "cullface": "east" }



Mi target is to make mi custom water block to look like the vanilla water block 

what could be needed to make a block transparent in 1.19.4 ??








Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now


  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • https://pastebin.com/FaQ43RnJ  Este es un error que me lanza al momento de querer iniciar forge Intente de todo pero no sirve nada. This is an error that I get when I want to start forge. I tried everything but nothing works.
    • It was a stupid Eclipse problem ,the debugger was set to a lower version of java.  In what world would i want my development version different from the debugger version.   ty for looking
    • Caused by: java.lang.NullPointerException: Cannot read field "level" because "this.minecraft" is null This is my first big error when coding. I looked it up, but there are a bunch of references to Dawncraft and not enough to figure out what was going wrong. I found this, but it involves a command and my GUI only opens when you shift + right-click while holding an item. They fixed it by not calling it with a command, but I am not using a command. Here's the render of my menu, which is the only part that changed between it working and not:   @Override public void render(@Nonnull PoseStack mstack, int mouseX, int mouseY, float partialTicks) { int midx = this.width / 2; int midy = this.height / 2; this.renderBackground(mstack); drawCenteredString(mstack, font, I18n.get("config.shape_tool"), midx, 4, 0xC3D1D8); Utils.renderImage(midx - 12, midy, 20, 20, "textures/gui/plus.png", mstack); addRenderableWidget(new Button(midx - 12, midy, 10, 10, Component.translatable(""), this::increaseax)); Utils.renderImage(midx + 12, midy, 20, 20, "textures/gui/minus.png", mstack); addRenderableWidget(new Button(midx + 12, midy, 10, 10, Component.translatable(""), this::decreaseax)); drawCenteredString(mstack, font, String.valueOf(shapetoolax), midx, midy + 10, 0xC3D1D8); super.render(mstack, mouseX, mouseY, partialTicks); } Utils.renderImage is this:   public static void renderImage(int x, int y, int width, int height, String img, PoseStack mstack) { RenderSystem.setShaderColor(1, 1, 1, 1); RenderSystem.enableBlend(); RenderSystem.defaultBlendFunc(); RenderSystem.setShaderTexture(0, new ResourceLocation(PNegative.MODID, img)); blit(mstack, x, y, 0, 0, width, height, width, height); RenderSystem.disableBlend(); } I have used it before and it has worked, so it can't be a problem. 
    • I found a topic  with the very simmilar problems. I run modpack Direwolf20 1.19.2 version from FTB with dedicated server with my friends and i am the only who have this type of crashes. It has been through login process and after 5-6 crashes i can connect. And randombly it could crash me in game but mostly when i am tp'ing using Nether portals etc. I already setted up all privileges for javaw in firewall, flushed dns, reset network settings and etc. Changed java version to from FAQ too. Here's some logs from client side https://gnomebot.dev/paste/1158502890168664194 https://gnomebot.dev/paste/1158187264657063946    
    • Don't know why game keeps crashing after a few seconds or walking towards something, tried removing larger mods and someaddon performance mods but it's not working. Minecraft launchers telling me "Exit Code 1"
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.