Jump to content

Forge w/ Divine RPG server problem?


thegamervii

Recommended Posts

I recently tried making a forge server, and it worked. Allthough, when I installed divine RPG (by putting it in the mods folder), I got this:

 

---- Minecraft Crash Report ----

// Everything's going to plan. No, really, that was supposed to happen.

 

Time: 9/27/13 2:24 PM

Description: Exception in server tick loop

 

cpw.mods.fml.common.LoaderException: java.lang.NoClassDefFoundError: net/minecraft/client/multiplayer/WorldClient

at cpw.mods.fml.common.LoadController.transition(LoadController.java:149)

at cpw.mods.fml.common.Loader.loadMods(Loader.java:521)

at cpw.mods.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:99)

at cpw.mods.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:350)

at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:69)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:445)

at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:583)

Caused by: java.lang.NoClassDefFoundError: net/minecraft/client/multiplayer/WorldClient

at net.divinerpg.helper.proxy.CommonProxyDivineRPG.tickRegistry(CommonProxyDivineRPG.java:48)

at net.divinerpg.helper.proxy.CommonProxyDivineRPG.preInit(CommonProxyDivineRPG.java:31)

at net.divinerpg.DivineRPG.preInit(DivineRPG.java:52)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at cpw.mods.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:540)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)

at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)

at com.google.common.eventbus.EventBus.dispatch(EventBus.java:313)

at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)

at com.google.common.eventbus.EventBus.post(EventBus.java:267)

at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:194)

at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:174)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)

at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)

at com.google.common.eventbus.EventBus.dispatch(EventBus.java:313)

at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)

at com.google.common.eventbus.EventBus.post(EventBus.java:267)

at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:105)

at cpw.mods.fml.common.Loader.loadMods(Loader.java:520)

... 5 more

Caused by: java.lang.ClassNotFoundException: net.minecraft.client.multiplayer.WorldClient

at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:179)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

... 35 more

Caused by: java.lang.RuntimeException: Attempted to load class bdd for invalid side SERVER

at cpw.mods.fml.common.asm.transformers.SideTransformer.transform(SideTransformer.java:50)

at net.minecraft.launchwrapper.LaunchClassLoader.runTransformers(LaunchClassLoader.java:267)

at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:165)

... 37 more

 

 

A detailed walkthrough of the error, its code path and all known details is as follows:

---------------------------------------------------------------------------------------

 

-- System Details --

Details:

Minecraft Version: 1.6.4

Operating System: Windows 8 (amd64) version 6.2

Java Version: 1.7.0_25, Oracle Corporation

Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

Memory: 584688032 bytes (557 MB) / 630521856 bytes (601 MB) up to 1882783744 bytes (1795 MB)

JVM Flags: 0 total;

AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

Suspicious classes: FML and Forge are installed

IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

FML: MCP v8.11 FML v6.4.6.884 Minecraft Forge 9.11.0.884 4 mods loaded, 4 mods active

mcp{8.09} [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized

FML{6.4.6.884} [Forge Mod Loader] (minecraft_server.1.6.4.jar) Unloaded->Constructed->Pre-initialized

Forge{9.11.0.884} [Minecraft Forge] (minecraft_server.1.6.4.jar) Unloaded->Constructed->Pre-initialized

DivineRPG{1.4.0 Beta!} [Divine RPG] (DivineRPG.zip) Unloaded->Constructed->Errored

Profiler Position: N/A (disabled)

Is Modded: Definitely; Server brand changed to 'fml,forge'

Type: Dedicated Server (map_server.txt)

 

 

Thx for your help!

Link to comment
Share on other sites

Ive actually had the same problem, so i removed Divine rpg and tried it again and i received the same error NoclassfoundDefError and i noticed that it was trying to load it on the client side. i removed all my mods and the server started up fine. I tried to put 1 mod in this time it was ZansMinimap and i received the same error once again.  Ive been downloading the latest updates for 1.6.4 of both forge and minecraft along with the mods for 1.6.4 and cant seem to figure it out.  Ive been going through the forums and some one said to change the input method from client to server side and that you might need a proxy to do that but i cant figure out how to do that, and i have tried.  I then went and deleted minecraft completely and did a fresh install and again the same problems arise.  I have had a forge server with mods work in the past on 1.6.2 but eventually got the same problem when i was running biomes o plenty but i finally guessed it must be something with how the forge modloader is trying to run the mods.  I always download the latest forge update and retry my process but as of yet nothing has worked. i can post my crash reports or anything if i need to, but i dont believe its only Divine RPG that makes this problem come up.

 

P.S. i have been inputting the scala libraries manually since they sometimes dont download properly, so idk if it has something to do with the scala files either.

Link to comment
Share on other sites

Ehhh idk about that, i have had Zans minimap work on a forge server in the past. and i had other friends join the server and it didnt crash at all. after a couple of days after i ran a normal 1.6.2 server on accident then went back to the forge universal server; thats when i started getting the error.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • There's a scheme I got into where they promised to trade Bitcoin for me and take a cut as a commission. Seemed like a good idea at the time. But then, things went south real fast. They ended up transferring   $190,000 worth of my Bitcoin. I was devastated and felt completely helpless. That's when I stumbled upon the Wizard Web Recovery Tool. It was like a beacon of hope amid chaos. With this tool, I could finally start digging into what went wrong and hopefully get my Bitcoin back. Using Wizard Web was surprisingly easy. I just had to plug in some details about my Bitcoin account and let it do its thing. It started scanning the internet, looking for any clues about what happened to my Bitcoin. It felt like having a detective on my side, searching for answers. And guess what? Wizard Web found some leads. It uncovered evidence of the scheme's shady dealings and helped me track down the people responsible for losing my Bitcoin. Armed with this information, I took the case to court. After a long and hard-fought legal battle, the court ruled in my favor. The perpetrators were held accountable for their actions and faced criminal charges for their involvement in the scheme. It was a victory not just for me, but for anyone who's been taken advantage of by these kinds of scams. Thanks to Wizard Web Recovery, I was able to get justice and reclaim what was rightfully mine. It showed me that even in the face of adversity, there's always a way to fight back. And with the right tools and determination, anything is possible.   The following is the contact information for Wizard Web Recovery.   Email: wizard web recovery((@))programmer . net
    • Hello, good morning. I know some programming and I'm interested in mod creation. That's why I've decided to follow a tutorial guide on YouTube by TurtyWurty. https://www.youtube.com/watch?v=DhoX9cmAZqA&t=160s&ab_channel=TurtyWurty I've followed the tutorial perfectly. The problem is that when checking the food, the texture doesn't load for me. However, everything seems fine no matter how much I check. I'm sure it's something trivial, the problem is that I can't find it. Could you help me solve it, please? I leave a zip of my file so you can edit it freely. forge-1.20-Civicraft.rar
    • If you have nvidia graphics, it's important that you make sure Minecraft (and anything Minecraft-related) is set to prefer high performance graphics first. If you only update your AMD drivers it might fix the issue but cause severe performance loss vs Vanilla as it'll be running on the integrated graphics instead of dedicated nvidia graphics
    • Update your drivers: https://www.amd.com/en/support/downloads/drivers.html/processors/ryzen/ryzen-5000-series/amd-ryzen-5-5600g.html
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.