Jump to content

[Solved] IndexOutOfBoundsException & Decoder Exception: Unknown serializer type


Recommended Posts


I've got a weird problem, most likely involving one of the mods, but can't seem to find the culprit.
I've been playing on a bigger 1.19.4 cutom-made Forge modpack and got it running extremely well. But because of certain mods, I've been updating it to 1.20.1.
Right after I got the server and game to run, I've tried to join the server and have been getting some IndexOutOfBoundsException errors. I've been testing removing many mods, and out of nowhere it started working.

I've then exported the modpack setup via CurseForge and sent it and installed it on another laptop. But here's the kicker. I was able to join on the laptop, but not on the main pc anymore.
I've done more testing, removing stuff and all of a sudden the opposite happened. Now I was in the server on the main PC, but couldn't join on laptop. 
And what felt like random pattern I wasn't able to get online on both computers.

  • I've tried making a fresh world,
  • removing config folders on clients and server,
  • reinstalling server and moving over mods + world folders,

And I had one really odd experience. One time I actually was able to join the world with both clients. Laptop had a lucky run and was able to join.
Main PC was giving uknown serializer error, and when I removed player data of main PC account I was able to join, but whenever I went back to my previous spot it kicked me and was unable to join back in.
Oh and one more thing: On random rare occasion the client or server hits a fetal error while lunching - very randomly one of these 3 mods gets out of bounds error: Regions unexplored, let's do bakery, let's do candlelight. (Tried removing all 3 still doesn't work)

Here are the log files:
SERVER - Redacted cuz leaked IP (I didn't check it)
MAIN CLIENT (in this case it was working) - Redacted cuz leaked IP
LAPTOP CLIENT (Index 17196645 out of bounds for length 12) - Redacted cuz leaked IP

I've solved many modpack issues in the past, but I've been really lost here for too many days now. Everything feels random, and it would take a month to trough each mod individually, but can't seem to find anything in debug logs.

Thanks for any possible solutions.

For anybody searching for help, here's what helped me:

EDIT: Been doing more testing. On main PC the error encountered was this: https://www.reddit.com/r/ModdedMinecraft/comments/16wchk2/the_game_crashed_whilst_encountered_exception/
Solved by replacing Rubidium with Embedium. On the other laptop I was able to join a new world until getting the same error as before and being unable to join anymore. 

EDIT 2: Restarting the game & CurseForge Launcher on laptop made me able to join via laptop all of a sudden. It might be something up with CurseForge launcher.

FINAL EDIT: So 2 errors were fixed like mentioned in last 2 edits, the last one was on main PC trying to join my own server with error: Decoder Exception: Unknown serializer type (random numbers here like 99) and ultimately it was cause by the Cobblemon mod.
When updating the modpack to 1.20.1  the cobblemon had a big update, which broke "something idk what". And it was fixed by removing the mod from clients and server, logging in and then closing everything and adding back the mod. 

If you need log files for any reasons, msg me.


Edited by MacatMovie
Link to comment
Share on other sites

  • MacatMovie changed the title to [Solved] IndexOutOfBoundsException & Decoder Exception: Unknown serializer type

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.