Jump to content

[Solved] [1.20.1] Unable to Download Sources Due to Undefined Repositories


Recommended Posts

After a long hiatus in modding I'm updating a mod to 1.20.1. After downloading the appropriate Forge MDK and upgrading to Java 17 (through Adoptium JDK), I'm attempting to download sources but encounter this error:

Caused by: org.gradle.internal.resolve.ModuleVersionNotFoundException: Cannot resolve external dependency net.minecraftforge:mergetool:1.1.7 because no repositories are defined.


I've double checked that my system variables are correct and that the Intellij gradle JVM is pointing to the new Java version. This is likely a simple fix that's eluding me. Below are my build.gradle and settings.gradle. Any help is appreciated.




Edited by urbanxx001
Solved issue
Link to comment
Share on other sites

  • urbanxx001 changed the title to [Solved] [1.20.1] Unable to Download Sources Due to Undefined Repositories

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.