Jump to content

[SOLVED] SoundLoadEvent not being called


Recommended Posts

I'm having a weird problem. I'm trying to get my mod to play a sound file (update.wav), but I can't seem to get the SoundLoadEvent to fire. I know my load method is being called because the functionality from the ConnectionHandler and TickHandler all work fine, but the logs from my EventHandler are never called. I'm using forge build 737 for 1.5.2.


Main mod class:


package me.superckl.VoltzationClient;

import net.minecraftforge.common.MinecraftForge;
import cpw.mods.fml.common.Mod;
import cpw.mods.fml.common.Mod.Init;
import cpw.mods.fml.common.Mod.Instance;
import cpw.mods.fml.common.Mod.PreInit;
import cpw.mods.fml.common.SidedProxy;
import cpw.mods.fml.common.event.FMLInitializationEvent;
import cpw.mods.fml.common.event.FMLPreInitializationEvent;
import cpw.mods.fml.common.network.NetworkMod;
import cpw.mods.fml.common.network.NetworkRegistry;
import cpw.mods.fml.common.registry.TickRegistry;
import cpw.mods.fml.relauncher.Side;

@Mod(modid = "VoltzationClient", name = "Voltzation Client", version = "1.0", dependencies = "required-after:VoltzationCore")
@NetworkMod(clientSideRequired = true, serverSideRequired = false, channels = {"VoltzMoney", "VoltzMRequest"}, packetHandler = PacketHandler.class)
public class VoltzationClient
@Instance(value = "VoltzationClient")
public static VoltzationClient instance;

@SidedProxy(clientSide = "me.superckl.VoltzationClient.ClientProxy", serverSide = "me.superckl.VoltzationClient.CommonProxy")
public static CommonProxy proxy;

public static final String logFormat = "[VoltzationClient] %s";

public void preInit(final FMLPreInitializationEvent e)

public void load(final FMLInitializationEvent e)
	MinecraftForge.EVENT_BUS.register(new EventHandler());
	NetworkRegistry.instance().registerConnectionHandler(new ConnectionHandler());
	TickRegistry.registerTickHandler(new TickHandler(), Side.CLIENT);




package me.superckl.VoltzationClient;

import java.io.File;

import cpw.mods.fml.common.FMLLog;

import net.minecraftforge.client.event.sound.SoundLoadEvent;
import net.minecraftforge.event.ForgeSubscribe;

public class EventHandler {

public void onSoundLoad(final SoundLoadEvent e){
	FMLLog.info(VoltzationClient.logFormat, "Here it comes!");
	FMLLog.info(VoltzationClient.logFormat, VoltzationClient.class.getResource("/mods/voltzationclient/sounds/update.wav").getFile());
	e.manager.addSound("money/update.wav", new File(VoltzationClient.class.getResource("/mods/voltzationclient/sounds/update.wav").getFile()));


Any ideas?

Link to comment
Share on other sites

Thanks, that fixed it. But, I have another problem now. My sound isn't playing. My sound file, update.wav, is located in VoltzationClient.zip/mods/voltzationclient/sounds/update.wav. I use this to play the sound:


Minecraft.getMinecraft().theWorld.playSoundAtEntity(Minecraft.getMinecraft().thePlayer, "money.update", 20F, 1F);


Know what's wrong? The getResource call is pointing to:




I'm using a custom mod pack to test the mod, if you were wondering.

Link to comment
Share on other sites

Thats not how the string works. "money.update" would make Minecraft look in assets/Minecraft/sound/money for the update sound file.


Make an assets/[mod_id]/sound/money package and put in your update sound file in there.  Replace [mod_id] with the mod id of your mod and change "money.update" to "[mod_id]:money.update".


Minecraft.getMinecraft().theWorld.playSoundAtEntity(Minecraft.getMinecraft().thePlayer, "[mod_id]:money.update", 20F, 1F);


You will also need to change

		e.manager.addSound("money/update.wav", new File(VoltzationClient.class.getResource("/mods/voltzationclient/sounds/update.wav").getFile()));



Link to comment
Share on other sites

In 1.5 the folder was called 'mods' instead of 'assets', but the principle mentioned by Xenocider is the same. I'm not 100% this was also being applied for sounds by then, but you can at least try it.

Author of PneumaticCraft, MineChess, Minesweeper Mod and Sokoban Mod. Visit www.minemaarten.com to take a look at them.

Link to comment
Share on other sites

If I look back at how I've done it, it looks the same as how Xenocider described. The difference is that I'm using .ogg files instead of .wav which caused problems for me as well. So try converting the sound file to .ogg and retrying. There is a String only method, look for example at an older version of my Minesweeper Mod:




Author of PneumaticCraft, MineChess, Minesweeper Mod and Sokoban Mod. Visit www.minemaarten.com to take a look at them.

Link to comment
Share on other sites

I finally got it. I changed the registration to:


	e.manager.soundPoolSounds.addSound("mods/voltzationcore/sound/money.ogg", VoltzationCore.class.getResource("/mods/voltzationcore/sound/money.ogg"));


And I use this to play it:


Minecraft.getMinecraft().sndManager.playSoundFX("mods.voltzationcore.sound.money", 1.0F, 1.0F);


Thanks for all the help guys.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.