Jump to content

Uninstalled mod conflict 1.18.2 Forge -FIXED-


Recommended Posts

Posted (edited)

Turns out it was a conflict between a Forge version and Optifine.

 

Now, after pruning down my mods, I get the dreaded Exit Code: 1 message, my logs show mods i've uninstalled and a loader I got rid of, any fixes?

Log:

Spoiler

[16:37:42] [main/INFO]: Loading Minecraft 1.20.4 with Fabric Loader 0.15.11
[16:37:42] [ForkJoinPool-1-worker-8/WARN]: Mod mr_mo_variants uses the version 7.5.1J which isn't compatible with Loader's extended semantic version format (Could not parse version number component '1J'!), SemVer is recommended for reliably evaluating dependencies and prioritizing newer version
[16:37:42] [ForkJoinPool-1-worker-4/WARN]: Mod mr_scorched uses the version 1.1.3e which isn't compatible with Loader's extended semantic version format (Could not parse version number component '3e'!), SemVer is recommended for reliably evaluating dependencies and prioritizing newer version
[16:37:43] [main/WARN]: Mod resolution failed
[16:37:43] [main/INFO]: Immediate reason: [HARD_DEP_NO_CANDIDATE toomanyorigins 1.2.0-alpha.1 {depends origins @ [>=1.13.0-]}, ROOT_FORCELOAD_SINGLE toomanyorigins 1.2.0-alpha.1]
[16:37:43] [main/INFO]: Reason: [HARD_DEP toomanyorigins 1.2.0-alpha.1 {depends origins @ [>=1.13.0-]}, HARD_DEP toomanyorigins 1.2.0-alpha.1 {depends apugli @ [>=2.11.0-]}]
[16:37:43] [main/INFO]: Fix: add [add:origins 1.13.0- ([[1.13.0-,?)])], remove [], replace [[apugli 2.11.0-alpha.1] -> add:apugli 2.11.0- ([[2.11.0-,?)])]
[16:37:43] [main/ERROR]: Incompatible mods found!
net.fabricmc.loader.impl.FormattedException: Some of your mods are incompatible with the game or each other!
A potential solution has been determined, this may resolve your problem:
     - Install origins, version 1.13.0- or later.
     - Replace mod 'Apugli' (apugli) 2.11.0-alpha.1 with version 2.11.0- or later that is compatible with:
         - Other constraints that can''t be automatically determined
More details:
     - Mod 'TooManyOrigins' (toomanyorigins) 1.2.0-alpha.1 requires version 1.13.0- or later of origins, which is missing!
     - Mod 'TooManyOrigins' (toomanyorigins) 1.2.0-alpha.1 requires version 2.11.0- or later of mod 'Apugli' (apugli), which can't be loaded due to other constraints!
    at net.fabricmc.loader.impl.FormattedException.ofLocalized(FormattedException.java:51) ~[fabric-loader-0.15.11.jar:?]
    at net.fabricmc.loader.impl.FabricLoaderImpl.load(FabricLoaderImpl.java:195) ~[fabric-loader-0.15.11.jar:?]
    at net.fabricmc.loader.impl.launch.knot.Knot.init(Knot.java:146) ~[fabric-loader-0.15.11.jar:?]
    at net.fabricmc.loader.impl.launch.knot.Knot.launch(Knot.java:68) ~[fabric-loader-0.15.11.jar:?]
    at net.fabricmc.loader.impl.launch.knot.KnotClient.main(KnotClient.java:23) ~[fabric-loader-0.15.11.jar:?]
 

 

Edited by ARTHNASRTYJWSR46JRST6YJ
fixed it :D
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Yes, it is possible. You should develop the API as a separate project. Wether you want your mod to have the API integrated or have a dependency on it is up to you. I'd say that for testing the API integration, you should have it separated and add it as a dependency to your mod (at least, thats how I've done it in the past).   I recall there is also option to compile different parts of your project on different jars. Either way, thats more of a forgegradle question, if i understand it correctly
    • forge simply won't boot up no matter how many mods are installed, i tried only the 1.20.1 and 1.20.6 versions and the same thing happened: nothing. the only thing that shows up in the logs is this   [14jun.2024 11:07:34.757] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, {MINECRAFT_USERNAME}, --version, 1.20.1, --gameDir, C:\Users\{COMPUTER_USERNAME}\AppData\Roaming\com.modrinth.theseus\profiles\s, --assetsDir, C:\Users\{COMPUTER_USERNAME}\AppData\Roaming\com.modrinth.theseus\meta\assets, --assetIndex, 5, --uuid, {MINECRAFT_UUID}, --accessToken, ????????, --clientId, c4502edb-87c6-40cb-b595-64a280cf8906, --xuid, 0, --userType, msa, --versionType, release, --width, 854, --height, 480, --launchTarget, forgeclient, --fml.forgeVersion, 47.2.17, --fml.mcVersion, 1.20.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20230612.114412] [14jun.2024 11:07:34.765] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 10.0.9+10.0.9+main.dcd20f30 starting: java version 17.0.11 by Azul Systems, Inc.; OS Windows 10 arch amd64 version 10.0 [14jun.2024 11:07:34.946] [main/WARN] [net.minecraftforge.fml.loading.FMLConfig/CORE]: Configuration file C:\Users\{COMPUTER_USERNAME}\AppData\Roaming\com.modrinth.theseus\profiles\s\config\fml.toml is not correct. Correcting [14jun.2024 11:07:34.948] [main/INFO] [net.minecraftforge.fml.loading.FMLConfig/CORE]: Incorrect key [earlyWindowSkipGLVersions] was corrected from null to [] [14jun.2024 11:07:34.948] [main/INFO] [net.minecraftforge.fml.loading.FMLConfig/CORE]: Incorrect key [earlyWindowSquir] was corrected from null to false [14jun.2024 11:07:34.970] [main/INFO] [net.minecraftforge.fml.loading.ImmediateWindowHandler/]: Loading ImmediateWindowProvider fmlearlywindow [14jun.2024 11:07:35.208] [main/INFO] [EARLYDISPLAY/]: Trying GL version 4.6   i tried in two different computers and had the same results help.....
    • Get the latest drivers from their website - do not update via system
    • https://paste.ee/p/2yikd  After installing curse forge and running 1.20.1 with 0 mods, only forge 47.3.1, this report is being yielded. Vanilla minecraft is not crashing, and I initially thought it was a mod issue, but it is clear now there is some sort of interaction between forge and my computer occurring.  Here are my computer specs for anyone wondering: TUF gaming A15 ASUS running Windows 11 Processor: AMD Ryzen 7 4800H with Radeon Graphics, fully updated (31.0.12014.6) Graphics: NVIDIA GeFORCE GTX 1660 Ti, fully updated game-ready drivers (32.0.15.5599)  I have been told this an error code related to graphics drivers, but both my integrated and dedicated drivers are entirely up to date. My AMD drivers have no version to roll back to and have never previously encountered this issue. I am seriously confused by this because I have never had an issue with running forge in the past and frequently play modded MC. This issue was exactly the same when I ran 1.19.2 with Forge version 43.2.0,  again with no mods.  Please help!!
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.