Jump to content

Mixin Config crash error when initiating Minecraft 1.20.1 Forge 47.2.30


Recommended Posts

So launcher detect the next error: [02jun.2024 11:58:49.396] [main/ERROR] [mixin/]: Mixin config lolenderite.mixins.json does not specify "minVersion" property. Stoping the game to run normally, what should I do?

 

[02jun.2024 11:58:41.058] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, maaaarcoss, --version, 1.20.1-forge-47.2.30, --gameDir, C:\Users\marco\AppData\Roaming\.minecraft, --assetsDir, C:\Users\marco\AppData\Roaming\.minecraft\assets, --assetIndex, 5, --uuid, a9e19e1b4966318486d84346db748b2d, --accessToken, ????????, --clientId, 0, --xuid, 0, --userType, msa, --versionType, release, --launchTarget, forgeclient, --fml.forgeVersion, 47.2.30, --fml.mcVersion, 1.20.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20230612.114412]
[02jun.2024 11:58:41.058] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 10.0.9+10.0.9+main.dcd20f30 starting: java version 17.0.8 by Microsoft; OS Windows 11 arch amd64 version 10.0
[02jun.2024 11:58:43.251] [main/INFO] [net.minecraftforge.fml.loading.ImmediateWindowHandler/]: Loading ImmediateWindowProvider fmlearlywindow
[02jun.2024 11:58:43.473] [main/INFO] [EARLYDISPLAY/]: Trying GL version 4.6
[02jun.2024 11:58:43.969] [main/INFO] [EARLYDISPLAY/]: Requested GL version 4.6 got version 4.6
[02jun.2024 11:58:44.163] [main/INFO] [optifine.OptiFineTransformationService/]: OptiFineTransformationService.onLoad
[02jun.2024 11:58:44.165] [main/INFO] [optifine.OptiFineTransformationService/]: OptiFine ZIP file URL: union:/C:/Users/marco/AppData/Roaming/.minecraft/mods/OptiFine_1.20.1_HD_U_I6.jar%23268!/
[02jun.2024 11:58:44.171] [main/INFO] [optifine.OptiFineTransformationService/]: OptiFine ZIP file: C:\Users\marco\AppData\Roaming\.minecraft\mods\OptiFine_1.20.1_HD_U_I6.jar
[02jun.2024 11:58:44.174] [main/INFO] [optifine.OptiFineTransformer/]: Target.PRE_CLASS is available
[02jun.2024 11:58:44.246] [main/INFO] [mixin/]: SpongePowered MIXIN Subsystem Version=0.8.5 Source=union:/C:/Users/marco/AppData/Roaming/.minecraft/libraries/org/spongepowered/mixin/0.8.5/mixin-0.8.5.jar%23100!/ Service=ModLauncher Env=CLIENT
[02jun.2024 11:58:44.255] [main/INFO] [optifine.OptiFineTransformationService/]: OptiFineTransformationService.initialize
[02jun.2024 11:58:44.281] [pool-4-thread-1/INFO] [EARLYDISPLAY/]: GL info: Intel(R) Iris(R) Xe Graphics GL version 4.6.0 - Build 31.0.101.5522, Intel
[02jun.2024 11:58:45.120] [main/WARN] [net.minecraftforge.fml.loading.moddiscovery.ModFileParser/LOADING]: Mod file C:\Users\marco\AppData\Roaming\.minecraft\libraries\net\minecraftforge\fmlcore\1.20.1-47.2.30\fmlcore-1.20.1-47.2.30.jar is missing mods.toml file
[02jun.2024 11:58:45.238] [main/WARN] [net.minecraftforge.fml.loading.moddiscovery.ModFileParser/LOADING]: Mod file C:\Users\marco\AppData\Roaming\.minecraft\libraries\net\minecraftforge\javafmllanguage\1.20.1-47.2.30\javafmllanguage-1.20.1-47.2.30.jar is missing mods.toml file
[02jun.2024 11:58:45.314] [main/WARN] [net.minecraftforge.fml.loading.moddiscovery.ModFileParser/LOADING]: Mod file C:\Users\marco\AppData\Roaming\.minecraft\libraries\net\minecraftforge\lowcodelanguage\1.20.1-47.2.30\lowcodelanguage-1.20.1-47.2.30.jar is missing mods.toml file
[02jun.2024 11:58:45.387] [main/WARN] [net.minecraftforge.fml.loading.moddiscovery.ModFileParser/LOADING]: Mod file C:\Users\marco\AppData\Roaming\.minecraft\libraries\net\minecraftforge\mclanguage\1.20.1-47.2.30\mclanguage-1.20.1-47.2.30.jar is missing mods.toml file
[02jun.2024 11:58:45.869] [main/WARN] [net.minecraftforge.jarjar.selection.JarSelector/]: Attempted to select two dependency jars from JarJar which have the same identification: Mod File:  and Mod File: . Using Mod File: 
[02jun.2024 11:58:45.871] [main/WARN] [net.minecraftforge.jarjar.selection.JarSelector/]: Attempted to select a dependency jar for JarJar which was passed in as source: apexcore. Using Mod File: C:\Users\marco\AppData\Roaming\.minecraft\mods\apexcore-1.20.1-10.0.0.jar
[02jun.2024 11:58:45.871] [main/WARN] [net.minecraftforge.jarjar.selection.JarSelector/]: Attempted to select a dependency jar for JarJar which was passed in as source: expandability. Using Mod File: C:\Users\marco\AppData\Roaming\.minecraft\mods\expandability-9.0.0.jar
[02jun.2024 11:58:45.872] [main/INFO] [net.minecraftforge.fml.loading.moddiscovery.JarInJarDependencyLocator/]: Found 17 dependencies adding them to mods collection
[02jun.2024 11:58:46.452] [main/INFO] [optifine.OptiFineTransformationService/]: OptiFineTransformationService.transformers
[02jun.2024 11:58:46.457] [main/INFO] [optifine.OptiFineTransformer/]: Targets: 412
[02jun.2024 11:58:47.036] [main/INFO] [optifine.OptiFineTransformationService/]: additionalClassesLocator: [optifine., net.optifine.]
[02jun.2024 11:58:49.345] [main/INFO] [mixin/]: Compatibility level set to JAVA_17
[02jun.2024 11:58:49.396] [main/ERROR] [mixin/]: Mixin config lolenderite.mixins.json does not specify "minVersion" property
[02jun.2024 11:58:49.728] [main/INFO] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Launching target 'forgeclient' with arguments [--version, 1.20.1-forge-47.2.30, --gameDir, C:\Users\marco\AppData\Roaming\.minecraft, --assetsDir, C:\Users\marco\AppData\Roaming\.minecraft\assets, --uuid, a9e19e1b4966318486d84346db748b2d, --username, maaaarcoss, --assetIndex, 5, --accessToken, ????????, --clientId, 0, --xuid, 0, --userType, msa, --versionType, release]
[02jun.2024 11:58:49.783] [main/WARN] [mixin/]: Reference map 'handcrafted-forge-1.20.1-forge-refmap.json' for handcrafted.mixins.json could not be read. If this is a development environment you can ignore this message
[02jun.2024 11:58:49.797] [main/WARN] [mixin/]: Reference map 'letsdo-brewery-forge-forge-refmap.json' for brewery.mixins.json could not be read. If this is a development environment you can ignore this message
[02jun.2024 11:58:49.813] [main/WARN] [mixin/]: Reference map 'smallships-forge-refmap.json' for smallships.mixins.json could not be read. If this is a development environment you can ignore this message
[02jun.2024 11:58:49.824] [main/WARN] [mixin/]: Reference map 'octolib.refmap.json' for octolib.mixins.json could not be read. If this is a development environment you can ignore this message
[02jun.2024 11:58:49.831] [main/WARN] [mixin/]: Reference map 'graveyard-FORGE-forge-refmap.json' for graveyard-forge.mixins.json could not be read. If this is a development environment you can ignore this message
[02jun.2024 11:58:49.943] [main/WARN] [mixin/]: Reference map 'coroutil.refmap.json' for coroutil.mixins.json could not be read. If this is a development environment you can ignore this message
[02jun.2024 11:58:49.948] [main/WARN] [mixin/]: Reference map 'apexcore.refmap.json' for apexcore.mixins.json could not be read. If this is a development environment you can ignore this message
[02jun.2024 11:58:49.953] [main/WARN] [mixin/]: Reference map 'chiselsandbits.refmap.json' for chisels-and-bits.mixins.json could not be read. If this is a development environment you can ignore this message
[02jun.2024 11:58:50.487] [main/WARN] [mixin/]: Error loading class: dev/latvian/mods/kubejs/recipe/RecipesEventJS (java.lang.ClassNotFoundException: dev.latvian.mods.kubejs.recipe.RecipesEventJS)
[02jun.2024 11:58:50.487] [main/WARN] [mixin/]: @Mixin target dev.latvian.mods.kubejs.recipe.RecipesEventJS was not found mixins.hammerlib.json:bs.kubejs.RecipeEventJSMixin
[02jun.2024 11:58:51.074] [main/WARN] [mixin/]: Error loading class: sereneseasons/handler/season/RandomUpdateHandler (java.lang.ClassNotFoundException: sereneseasons.handler.season.RandomUpdateHandler)
[02jun.2024 11:58:51.074] [main/WARN] [mixin/]: @Mixin target sereneseasons.handler.season.RandomUpdateHandler was not found snowrealmagic.mixins.json:sereneseasons.RandomUpdateHandlerMixin
[02jun.2024 11:58:51.084] [main/WARN] [mixin/]: Error loading class: me/jellysquid/mods/sodium/client/render/chunk/compile/pipeline/BlockRenderer (java.lang.ClassNotFoundException: me.jellysquid.mods.sodium.client.render.chunk.compile.pipeline.BlockRenderer)
[02jun.2024 11:58:51.084] [main/WARN] [mixin/]: @Mixin target me.jellysquid.mods.sodium.client.render.chunk.compile.pipeline.BlockRenderer was not found snowrealmagic.mixins.json:sodium.BlockRendererAccess
[02jun.2024 11:58:51.086] [main/WARN] [mixin/]: Error loading class: me/jellysquid/mods/sodium/client/render/chunk/compile/pipeline/BlockRenderer (java.lang.ClassNotFoundException: me.jellysquid.mods.sodium.client.render.chunk.compile.pipeline.BlockRenderer)
[02jun.2024 11:58:51.086] [main/WARN] [mixin/]: @Mixin target me.jellysquid.mods.sodium.client.render.chunk.compile.pipeline.BlockRenderer was not found snowrealmagic.mixins.json:sodium.BlockRendererMixin
[02jun.2024 11:58:51.292] [main/WARN] [mixin/]: Error loading class: me/jellysquid/mods/sodium/client/render/chunk/compile/pipeline/FluidRenderer (java.lang.ClassNotFoundException: me.jellysquid.mods.sodium.client.render.chunk.compile.pipeline.FluidRenderer)
[02jun.2024 11:58:51.441] [main/WARN] [mixin/]: Error loading class: net/raphimc/immediatelyfast/feature/map_atlas_generation/MapAtlasTexture (java.lang.ClassNotFoundException: net.raphimc.immediatelyfast.feature.map_atlas_generation.MapAtlasTexture)
[02jun.2024 11:58:51.481] [main/WARN] [mixin/]: Error loading class: jeresources/api/util/LootConditionHelper (java.lang.ClassNotFoundException: jeresources.api.util.LootConditionHelper)
[02jun.2024 11:58:51.481] [main/WARN] [mixin/]: @Mixin target jeresources.api.util.LootConditionHelper was not found mixins.improvableskills.json:jer.LootConditionHelperMixin
[02jun.2024 11:58:51.902] [main/WARN] [mixin/]: Error loading class: twilightforest/TFMagicMapData$TFMapDecoration (java.lang.ClassNotFoundException: twilightforest.TFMagicMapData$TFMapDecoration)
[02jun.2024 11:58:52.327] [main/WARN] [mixin/]: Error loading class: me/cominixo/betterf3/modules/TargetModule (java.lang.ClassNotFoundException: me.cominixo.betterf3.modules.TargetModule)
[02jun.2024 11:58:52.328] [main/WARN] [mixin/]: @Mixin target me.cominixo.betterf3.modules.TargetModule was not found securitycraft.mixins.json:f3.BetterF3TargetModuleMixin
[02jun.2024 11:58:53.160] [main/INFO] [MixinExtras|Service/]: Initializing MixinExtras via com.llamalad7.mixinextras.service.MixinExtrasServiceImpl(version=0.3.5).
[02jun.2024 11:58:53.287] [main/WARN] [mixin/]: Injection warning: LVT in net/minecraft/client/gui/GuiGraphics::m_280497_(Lnet/minecraft/client/gui/Font;Ljava/util/List;IILnet/minecraft/client/gui/screens/inventory/tooltip/ClientTooltipPositioner;)V has incompatible changes at opcode 346 in callback relics.mixins.json:GuiGraphicsMixin->@Inject::onTooltipRender(Lnet/minecraft/client/gui/Font;Ljava/util/List;IILnet/minecraft/client/gui/screens/inventory/tooltip/ClientTooltipPositioner;Lorg/spongepowered/asm/mixin/injection/callback/CallbackInfo;Lnet/minecraftforge/client/event/RenderTooltipEvent$Pre;IIIILorg/joml/Vector2ic;)V.
 Expected: [Lnet/minecraftforge/client/event/RenderTooltipEvent$Pre;, I, I, I, I, Lorg/joml/Vector2ic;]
    Found: [Ljava/lang/Object;, I, I, I, I, Lorg/joml/Vector2ic;]
Available: [Ljava/lang/Object;, I, I, I, I, Lorg/joml/Vector2ic;, I, I, I, Lnet/minecraft/client/gui/Font;, I, I, Lnet/minecraft/client/gui/screens/inventory/tooltip/ClientTooltipComponent;]

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.