Jump to content

[1.6.4] Forge 9.11.1.965 - Src - Installation fails.


TheRealKANi

Recommended Posts

Hi Guys,

 

I'm currently trying to install forge but it fails to do so.

 

[spoiler=install.sh Output]

MCP Detected already, not downloading

Setting up MCP

Patching commands.py

patching file commands.py

    Commands patch applied successfully

Copying FML conf

Creating Repackaged data

    Creating re-packaged srg

    Creating re-packaged exc

    Creating re-packaged MCP patches

Traceback (most recent call last):

  File "install.py", line 76, in <module>

    decompile=options.decompile, gen_conf=False)

  File "install.py", line 17, in fml_main

    disable_assets=disable_assets)

  File "/Users/TheRealKANi/Desktop/minecraft Work Folder/forge/fml/fml.py", line 1027, in decompile_minecraft

    pre_decompile(mcp_dir, fml_dir, disable_assets=disable_assets)

  File "/Users/TheRealKANi/Desktop/minecraft Work Folder/forge/fml/fml.py", line 1075, in pre_decompile

    download_minecraft(mcp_dir, fml_dir)

  File "/Users/TheRealKANi/Desktop/minecraft Work Folder/forge/fml/fml.py", line 1139, in download_minecraft

    failed = download_libraries(mcp_dir, version_json['libraries'], mc_info['natives_dir']) or failed

  File "/Users/TheRealKANi/Desktop/minecraft Work Folder/forge/fml/fml.py", line 1208, in download_libraries

    except (HTTPError):

NameError: global name 'HTTPError' is not defined

 

 

 

I looked around on the forums and googled it for about 2 hours now.

No fixes, only leads to other errors.

 

And before you ask, I'm still using 1.6.4 for my server, and I'm in the middle of developing our server economy..

I just needed a clean start so I wiped the forge folder and re-downloaded forge source.

What can I do to get my modding environment back..?

 

Thanks in advance.

/TheRealKANi

Link to comment
Share on other sites

  • 3 weeks later...

I am having the same error - using 1.6.4 with Forge 9.11.1.965 and the python exception is 'HTTPError' is not defined in fml.py, line 1208. I'm on an Mac, 10.9.2 Mavericks.

 

If you worked around it I'd be interested.

 

Thanks, Matthew

 

UPDATE after some hacking

 

I'm getting a 403 when trying to download http://repo.maven.apache.org/maven2/org/scala-lang/scala-compiler/2.10.2/scala-compiler-2.10.2.jar; I'll see what else I can figure out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.