Jump to content

Jenkins error on :deobfBinJar


Recommended Posts

I'm using the latest version of Jenkins with Gradle 1.1 and I get this crash when I try to compile my library (not a mod) with ForgeGradle 964. Should this happen?




Started by user amadornes

Building in workspace /var/lib/jenkins/workspace/AmadornesLib

Fetching changes from the remote Git repository

Fetching upstream changes from https://github.com/amadornes/AmadornesLib.git

Checking out Revision 7d14ff4a79b708fbd3e2a9e00911c2f0e4078372 (origin/master)

[Gradle] - Launching build.

[AmadornesLib] $ /var/lib/jenkins/tools/hudson.plugins.gradle.GradleInstallation/Gradle/bin/gradle build -b build.gradle



Powered By MCP:           


Searge, ProfMobius, Fesh0r,

R4wk, ZeuX, IngisKahn     

MCP Data version : unknown


:downloadClient SKIPPED

:downloadServer SKIPPED


:mergeJars SKIPPED

:applyBinPatches SKIPPED

:downloadMcpTools UP-TO-DATE

:genSrgs UP-TO-DATE

:getJavadocs SKIPPED

:deobfBinJar FAILED


FAILURE: Build failed with an exception.


* What went wrong:

A problem was found with the configuration of task ':deobfBinJar'.

> File '/var/lib/jenkins/workspace/AmadornesLib/build/unpacked/conf/exceptor.json' specified for property 'exceptorJson' does not exist.


* Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.




Total time: 14.615 secs

Build step 'Invoke Gradle script' changed build result to FAILURE

Build step 'Invoke Gradle script' marked build as failure

Setting project description with contents of file [README.md]

Archiving artifacts

Finished: FAILURE



Build.gradle file: https://github.com/amadornes/AmadornesLib/blob/master/build.gradle


If you need my specific configuration for Jenkins I can post some screenshots. Thanks for the help :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.