Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.6.4] Cable Question


delemberen12
 Share

Recommended Posts

I'm making a custom cable and I want to know how to make it so if I place a block next to the block, they will connect. I've been looking online in the redstone code and trying it myself. I cannot get it!! I got the cable to work with the power and crap but the thing I was talking about up there ^^^^^ I don't get.

 

Could someone send me a code or something? It would help me a lot.

 

8)

 

 

Developer of MechanicalCraft.

 

Sadly not available to public yet :(

Link to comment
Share on other sites

Your in luck! Scratchforfun has just started a custom cable tutorial, try looking at that!

http://www.youtube.com/user/ScratchForFun&safe=active&ssui=on

ScratchForFun? Can really recommend his video tutorials. They helped me a lot with my rotate block problem....

Maybe i should add cables to my mod...

 

EDIT: You should have a look at Universal Electricity, its compatible with nearly every big mod...

EDIT2:wrong link:http://www.youtube.com/user/ScratchForFun

Here could be your advertisement!

Link to comment
Share on other sites

Your in luck! Scratchforfun has just started a custom cable tutorial, try looking at that!

http://www.youtube.com/user/ScratchForFun&safe=active&ssui=on

The video is decent as far as extreme slam-bang coding goes. However, he could have used half the code by utilizing ForgeDirection properly, creating submethods for partial rendering, using EnumSet for his connections, and decent looping techniques. All in all, it's pretty straightforward though.

Link to comment
Share on other sites

Guys, I already tried doing his tutorial for 1.6.4. It doesn't work!

 

 

We Can't hell YouTube it You don't show us your code.

It shouldn't je so diffizile ti downgrade This code.

 

And sequituri, quatsch exactly would you change? I don't warnt to just copy buildcraft or induatrialcraft Code. Can u Link.a.better Tutorial?

 

EDIT: diffizile? ti? What exactly is my autocorrection Doping? Trying.to learn spanish?  I will korrekt.Thierse Post as soon as.i get Home...

 

Sorry for the mess in the spoiler....reinstalled the factory rom on my smartphone and messed up my dictionary....

 

We can't help you if you don't show us your code....

It shouldn't be this difficult to downgrade this pipes. Why do you even use 1.6? The last 1.7 release is nearly perfect.

 

And @sequituri (<-- not sure if this works) what would you change? As far as i know there isn't any better tutorial out there and i don't want to copy paste buildcraft code....

 

And why did i click "thankyou"? I tried to quote you. Maybe i should switch back to cyanogenmod....

Here could be your advertisement!

Link to comment
Share on other sites

 

It shouldn't be this difficult to downgrade this pipes. Why do you even use 1.6? The last 1.7 release is nearly perfect.

 

The reason why I can't upgrade to 1.7 is because every time I try to upgrade from 1.6 to 1.7 :MinecraftRecomp Fails. I don't know why but i'm still trying to figure it out. Once I get to 1.7 I will delete this thread.

Developer of MechanicalCraft.

 

Sadly not available to public yet :(

Link to comment
Share on other sites

 

It shouldn't be this difficult to downgrade this pipes. Why do you even use 1.6? The last 1.7 release is nearly perfect.

 

The reason why I can't upgrade to 1.7 is because every time I try to upgrade from 1.6 to 1.7 :MinecraftRecomp Fails. I don't know why but i'm still trying to figure it out. Once I get to 1.7 I will delete this thread.

 

What OS are you using? I had the same problem on my mac.

Here could be your advertisement!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • you need to check if the EventHandler is called
    • update Forge to the latest version 1.16.5 requires java 8
    • C:\Users\(My Name)\Desktop\Clockwise server>java -Xmx10240M -Xms10240M -jar forgeserver.jar nogui 2022-05-26 12:35:05,381 main WARN Advanced terminal features are not available in this environment [12:35:05] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.1.30, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui] [12:35:05] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 1.8.0_333 by Oracle Corporation [12:35:06] [main/INFO] [ne.mi.fm.lo.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust [12:35:06] [main/INFO] [mixin/]: SpongePowered MIXIN Subsystem Version=0.8.2 Source=file:/C:/Users/Joshua%20Hague/Desktop/Clockwise%20server/libraries/org/spongepowered/mixin/0.8.2/mixin-0.8.2.jar Service=ModLauncher Env=SERVER [12:35:06] [main/WARN] [ne.mi.fm.lo.FMLConfig/CORE]: Configuration file C:\Users\Joshua Hague\Desktop\Clockwise server\config\fml.toml is not correct. Correcting [12:35:06] [main/WARN] [ne.mi.fm.lo.FMLConfig/CORE]: Incorrect key [defaultConfigPath] was corrected from null to defaultconfigs [12:35:06] [main/INFO] [cp.mo.mo.LaunchServiceHandler/MODLAUNCHER]: Launching target 'fmlserver' with arguments [--gameDir, ., nogui] Exception in thread "main" [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: java.lang.NoSuchMethodError: sun.security.util.ManifestEntryVerifier.<init>(Ljava/util/jar/Manifest;)V [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at cpw.mods.modlauncher.SecureJarHandler.createCodeSource(SecureJarHandler.java:66) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at cpw.mods.modlauncher.TransformingClassLoader$DelegatedClassLoader.findClass(TransformingClassLoader.java:275) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at cpw.mods.modlauncher.TransformingClassLoader.loadClass(TransformingClassLoader.java:136) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at cpw.mods.modlauncher.TransformingClassLoader.loadClass(TransformingClassLoader.java:98) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at java.lang.ClassLoader.loadClass(Unknown Source) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at java.lang.Class.forName0(Native Method) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at java.lang.Class.forName(Unknown Source) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at net.minecraftforge.fml.loading.FMLServerLaunchProvider.lambda$launchService$0(FMLServerLaunchProvider.java:51) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:37) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:54) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:72) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at cpw.mods.modlauncher.Launcher.run(Launcher.java:82) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at cpw.mods.modlauncher.Launcher.main(Launcher.java:66) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60) [12:35:07] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:         at net.minecraftforge.server.ServerMain.main(ServerMain.java:57) C:\Users\(My Name)\Desktop\Clockwise server>PAUSE Tried it again with just Java version 8 update 333, still nothing.
    • package com.zaksen.fancydecorativeblocks; import com.zaksen.fancydecorativeblocks.screen.FancyMenuTypes; import com.zaksen.fancydecorativeblocks.screen.WoodCrateScreen; import net.minecraft.client.gui.screens.MenuScreens; import net.minecraftforge.eventbus.api.SubscribeEvent; import net.minecraftforge.fml.common.Mod; import net.minecraftforge.fml.event.lifecycle.FMLClientSetupEvent; @Mod.EventBusSubscriber(modid = FancyDecorativeBlocks.MOD_ID) public class ClientSetup { @SubscribeEvent public static void clientSetup(final FMLClientSetupEvent Event) { Runnable runnable = new Runnable() { @Override public void run() { MenuScreens.register(FancyMenuTypes.WOOD_CRATE_MENU.get(), WoodCrateScreen::new); } }; Event.enqueueWork(runnable); } } I create new class for it, but how i need call it?
    • Hey thanks for the reply So I can't exactly remove mods from the modpack without causing severe problems with the world so I just tried increasing the max-tick-time and found out it happens between these lines   [26May2022 20:15:49.384] [Server thread/DEBUG] [mixin/]: Mixing MixinNetworkItemManager from creativewirelesstransmitter.mixins.json into com.refinedmods.refinedstorage.apiimpl.network.item.NetworkItemManager [26May2022 20:19:51.050] [Server thread/DEBUG] [mixin/]: Mixing MixinBlockEntityExtension from architectury.mixins.json into me.shedaniel.architectury.extensions.BlockEntityExtension Here's the full debug.log, had to shorten it a little cause it was too big for pastebin so I cut the start out, if you need it I can also send it Also because I increased the max-tick-time it didn't crash but I dont wanna keep it that way since a 4 minute tick has to have an explanation. So any idea of how to fix this?
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.