• Recently Browsing

    No registered users viewing this page.

  • Posts

    • So i was playing on my modpack and one time the world just dosen;t load and crashes the game i dont know why pls help me latest.log crash-2021-01-25_18.56.20-server.txt
    • Hello, when I run runClient (or server) it shows this output. It was on first start (never  started without problems before). I was reinstalling JDK and googling it but I didn't find anything. I didn't find anybody with this errror. [2021-01-25 18:47:55] [INFO ] Natives: C:\Users\Jakub\Desktop\testing\build\natives [2021-01-25 18:47:55] [INFO ] Main Class: net.minecraft.launchwrapper.Launch [2021-01-25 18:47:55] [INFO ] Srg2Mcp: C:\Users\Jakub\Desktop\testing\build\createSrgToMcp\output.srg [2021-01-25 18:47:55] [INFO ] Extra: [] [2021-01-25 18:47:55] [INFO ] Running with arguments: [--version, 1.12, --assetIndex, 1.12, --assetsDir, C:\Users\Jakub\.gradle\caches\forge_gradle\assets, --accessToken, {REDACTED}, --userProperties, [], --tweakClass, net.minecraftforge.fml.common.launcher.FMLTweaker] Exception in thread "main" java.lang.reflect.InvocationTargetException at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.base/java.lang.reflect.Method.invoke(Method.java:564) at net.minecraftforge.legacydev.Main.start(Main.java:86) at net.minecraftforge.legacydev.MainClient.main(MainClient.java:29) Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap') at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34) at net.minecraft.launchwrapper.Launch.main(Launch.java:28) ... 6 more have I attach some files? I'm relatively new to programming (I was programming some basic MC plugins), so I will be grateful for any help.
    • Ok. Sorry for wasting your time if you came here to help. The issue was something gradle-related. I hadn't added a Gradle Nature to my project in eclipse so it just didn't work properly. If you're having this issue on eclipse, try right-clicking your project, clicking "add gradle nature", and then building it again. I'll mark this as solved now.
    • Ah. Thank you!
    • You do know what that returned int does, right?
  • Topics

  • Who's Online (See full list)