Jump to content

I cant build with gradle, its using --source 1.6


KeeganDeathman

Recommended Posts

Hello,

I am building my mod for the first time in a while. But it fails upon entering the :compileJava phase. It points to a BufferedReader try () method I have, and is just all like, nope. You need --source 7, your using 1.6. Ive done this before, but my code was lost. Heres the interfering file:

https://github.com/KeeganDeathman/LabStuff/blob/master/java/keegan/LabStuff/io/ReadFile.java

[shadow=gray,left][glow=red,2,300]KEEGAN[/glow][/shadow]

Link to comment
Share on other sites

You need to specify the source java version (and probably the target one as well) in your build.gradle like this:

https://github.com/SanAndreasP/ClaySoldiersMod/blob/master/build.gradle#L58-L61

Don't ask for support per PM! They'll get ignored! | If a post helped you, click the "Thank You" button at the top right corner of said post! |

mah twitter

This thread makes me sad because people just post copy-paste-ready code when it's obvious that the OP has little to no programming experience. This is not how learning works.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.