Jump to content

[SOLVED] Tessellator's weird behavior


TheTrollguy_

Recommended Posts

  Hey guys. So recently I've started playing with the Tessellator and it's going really good actually. I used it for my item renderer because I have some weird shapes. But then I tried to use it in my custom block renderer and it got bad.

  So usually one will start with the tessellator by this: tessellator.startDrawingQuads(); and then you'll add vertices and then one will use tessellator.draw(); (with some translations and other lighting stuff which I'm capable of fixing). But there's one thing which bugs me the most. If I don't use the tessellator.startDrawingQuads(); it'll give me a crash report saying: "Not tessellating!" and if I use it it will say "Already tessellating!". Here's what I use for my code:

 

AsphaltRenderer_0.java (ISBRH) - renderWorldBlock method.

@Override
public boolean renderWorldBlock(IBlockAccess iBlockAccess, int X, int Y, int Z, Block block, int modelID, RenderBlocks renderer)
{
	Tessellator tessellator = Tessellator.instance;
	int metadata = iBlockAccess.getBlockMetadata(X, Y, Z);
	int lightValue = block.getMixedBrightnessForBlock(iBlockAccess, X, Y, Z);
	double blockHeight = 0.75D;

	tessellator.addTranslation(-0.5F, -0.5F, -0.5F);	
                tessellator.startDrawingQuads();	

                // Imagine if this was just adding vertices for the block's bottom face
	RenderingHelper.renderBlockBottomFace(tessellator, X, Y, Z, X + 1.0D, Y+ blockHeight, Z + 1.0D, AsphaltSet_0.mainTextures[0], 0, false);		
	tessellator.Draw();
	tessellator.addTranslation(0.5F, 0.5F, 0.5F);

	return true;
}

 

Can someone tell me why is this happening?

Link to comment
Share on other sites

you don't have to startDrawingQuads or draw, Minecraft code already does this when calling your method to render the block.

It gives you already Tessellating when you put startDrawingQuads because Minecraft calls it before calling your method, and it says not tessellating after you remove it because Minecraft tries to call draw after calling your method, but you already have called it.

Link to comment
Share on other sites

Exactly, it does it for EntityFXs too.

It doesn't call them for IItemRenderers because rendering custom items is totally made by forge, so it is not in vanilla Minecraft code, and apparently, forge doesn't call startDrawingQuads() and draw() when calling IItemRenderers's rendering methods.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Please share a link to your crash report on https://paste.ee, as explained in the FAQ. Dumping it directly into the thread often triggers the anti-spam and makes it hard to read due to word wrapping
    • Hi all, I'm running a 1.20.1 Minecraft Forge server with a hosting website and something seems to have gone wrong. It started as an occasional crash that has now become extremely frequent and I don't know what exactly is causing it. I already tried disabling watchdog but the server crashes anyway. Oddly it only occasionally generates a crash report after a crash occurs. Based on viewing the server console's research usage it seems that the CPU spikes astronomically high (100% usage), especially when chunks are being loaded or when a new person joins the server. I downloaded Spark to create a profile (https://spark.lucko.me/bBlWe7ou29) but I lack experience with this mod and don't understand what I'm looking at/how this should help me diagnose the issue. I am using a lot of mods so I'm guessing there is some sort of issue there or a corrupted chunk (although MCRF found no chunk errors). We actually don't experience any lag until the crash occurs, so it's some sort of sudden spike in resource usage. Based on the crash report I've already tried removing Canary and Modernfix but there was no change. Thanks for any help you can provide. Specs:  4 cores x 4200MHz AMD Ryzen 9 5950X 4GB RAM Crash report:  
    • will test that once i get home, thanks
    • I am getting this exception (I am new and just trying to create an item) Caused by: java.io.FileNotFoundException: abrasmagics:models/item/ingot_test.json at net.minecraft.client.resources.SimpleReloadableResourceManager.getResource(SimpleReloadableResourceManager.java:69) ~[SimpleReloadableResourceManager.class:?] at net.minecraft.client.renderer.block.model.ModelBakery.loadModel(ModelBakery.java:334) ~[ModelBakery.class:?] at net.minecraftforge.client.model.ModelLoader.access$1400(ModelLoader.java:115) ~[ModelLoader.class:?] at net.minecraftforge.client.model.ModelLoader$VanillaLoader.loadModel(ModelLoader.java:861) ~[ModelLoader$VanillaLoader.class:?] at net.minecraftforge.client.model.ModelLoaderRegistry.getModel(ModelLoaderRegistry.java:157) ~[ModelLoaderRegistry.class:?]   However the directory is set up correctly and the file does exist   idk how to upload images so here is a treeview of the directories:   src ├───main │ ├───java │ │ └───net │ │ └───abrasmods │ │ └───abrasmagics │ │ ├───init │ │ ├───items │ │ └───utils │ │ ├───handlers │ │ ├───misc │ │ └───proxy │ └───resources │ └───assets │ └───abrasmagics │ ├───models │ │ ├───block │ │ └───item │ └───textures └───test ├───java └───resources   the file ingot_test.json is under models/item. The directory seems fine and the file does exist so anyone plz help.   i am using intellij and is coding for 1.12.2
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.