Jump to content

[SOLVED] ForgeGradle - Build failed with an exception


Recommended Posts

This is the exception I get after I try any gradlew command.

Everything was working fine a few days ago pretty much perfectly so the only thing I can think of is it may be an internet issue that has arisen.


If you need any more information to help solve the issue, I'd be happy to provide.



FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'TestMod'.
> Could not resolve all dependencies for configuration ':classpath'.
   > Could not resolve net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT.
     Required by:
      > Unable to load Maven meta-data from http://repo1.maven.org/maven2/net/mi
         > Could not GET 'http://repo1.maven.org/maven2/net/minecraftforge/gradl
            > Invalid argument: connect
      > Unable to load Maven meta-data from http://files.minecraftforge.net/mave
         > Could not GET 'http://files.minecraftforge.net/maven/net/minecraftfor
            > Invalid argument: connect
      > Unable to load Maven meta-data from https://oss.sonatype.org/content/rep
         > Could not GET 'https://oss.sonatype.org/content/repositories/snapshot
            > Invalid argument: connect

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug
option to get more log output.


Total time: 3.453 secs


Thanks in advance,


Link to comment
Share on other sites

After wiping my .gradle folder, this is the error im getting.


Downloading https://services.gradle.org/distributions/gradle-2.0-bin.zip

Exception in thread "main" java.net.SocketException: Invalid argument: connect
        at java.net.DualStackPlainSocketImpl.connect0(Native Method)
        at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketI
        at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.ja
        at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocket
        at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java
        at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)
        at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
        at java.net.Socket.connect(Socket.java:579)
        at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
        at sun.security.ssl.BaseSSLSocketImpl.connect(BaseSSLSocketImpl.java:160
        at sun.net.NetworkClient.doConnect(NetworkClient.java:180)
        at sun.net.www.http.HttpClient.openServer(HttpClient.java:432)
        at sun.net.www.http.HttpClient.openServer(HttpClient.java:527)
        at sun.net.www.protocol.https.HttpsClient.<init>(HttpsClient.java:275)
        at sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:371)
        at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewH
        at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConne
        at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLCon
        at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(Http
        at org.gradle.wrapper.Download.downloadInternal(Download.java:56)
        at org.gradle.wrapper.Download.download(Download.java:42)
        at org.gradle.wrapper.Install$1.call(Install.java:57)
        at org.gradle.wrapper.Install$1.call(Install.java:44)
        at org.gradle.wrapper.ExclusiveFileAccessManager.access(ExclusiveFileAcc
        at org.gradle.wrapper.Install.createDist(Install.java:44)
        at org.gradle.wrapper.WrapperExecutor.execute(WrapperExecutor.java:126)
        at org.gradle.wrapper.GradleWrapperMain.main(GradleWrapperMain.java:56)


I've tried this on another computer on the same internet and it worked on there - Java is set up exactly the same on both PC's

Link to comment
Share on other sites

So, it looks like I've solved it and everything seems to be back to normal.

The problem was my network card drivers. The drivers that came on the disc with the network card seem to be faulty or incomplete, so as soon as I removed that driver and installed one from their website, everything worked after that.


Thanks for all the help to everyone who posted!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.