Jump to content

[Solved] Can't decompile Forge for the life of me


dmillerw

Recommended Posts

Solved. It was throwing a hissy fit over not having wine installed.

 

Using a fresh copy of MCP 7.2, a fresh copy of the Minecraft 1.3.2 bin and resources folder, and a fresh minecraft_server.jar, I simply can't get Forge to decompile. I didn't have an issue when running the standard decompile.sh file included with MCP though. Which is what makes me think I'm messing up, because going through the log (at the bottom of this post) it complains about not being able to find classes in minecraft.jar.

 

I've tried this both with Java 6 OpenJDK, and the official Java 7 release from Oracle.

 

So very confused...

 

mcp.log:

 

Two main things that caught my eye were "20:44:53 - # Warning: package net/minecraft/client not found in JAR" and "20:44:58 - # Warning: unknown class Side in cpw/mods/fml/common"

 

I'm pretty sure it's something wrong with the .jar, but the game itself runs fine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.