Jump to content

[Solved] Build fails: "Plugin with id 'forge' not found."


MrIbby

Recommended Posts

SOLUTION: Run as administrator.

 


 

Whenever I try to build my mod, it fails:

C:\oresplus>gradlew build

FAILURE: Build failed with an exception.

* Where:
Build file 'C:\oresplus\build.gradle' line
: 18

* What went wrong:
A problem occurred evaluating root project 'oresplus'.
> Plugin with id 'forge' not found.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug
option to get more log output.

BUILD FAILED

Total time: 5.547 secs

 

Here's my build.gradle file:

buildscript {
    repositories {
        mavenCentral()
        maven {
            name = "forge"
            url = "http://files.minecraftforge.net/maven"
        }
        maven {
            name = "sonatype"
            url = "https://oss.sonatype.org/content/repositories/snapshots/"
        }
    }
    dependencies {
        classpath 'net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT'
    }
}

apply plugin: 'forge'

version = "1.0-alpha-2"
group = "com.outlook.siribby.oresplus"

minecraft {
    version = "1.7.10-10.13.0.1180"
    runDir = "eclipse"

    replaceIn "OresPlus.java"
    replace "@VERSION@", project.version
}

archivesBaseName = "oresplus-" + project.minecraft.version

processResources {
    inputs.property "version", project.version
    inputs.property "mcversion", project.minecraft.version

    from(sourceSets.main.resources.srcDirs) {
        include 'mcmod.info'
        expand 'version':project.version, 'mcversion':project.minecraft.version
    }

    from(sourceSets.main.resources.srcDirs) {
        exclude 'mcmod.info'
    }
}

 

I've tried building my other mods, and the same error occurs. Does anyone know why this happens?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.