Jump to content

SOLVED [1.7.10] java.lang.ClassNotFoundException: ?-Xmx4G?


Recommended Posts



I am trying to run a "bash gradlew build" for my mod, of which I have done before and it has worked fine. I have changed nothing but some of my source code inside eclipse.


When trying to run the line above through Terminal I get this...

Exception in thread "main" java.lang.NoClassDefFoundError: ?-Xmx4G?
Caused by: java.lang.ClassNotFoundException: ?-Xmx4G?
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)


No idea why...any help please?


Quick Edit: Running "bash gradlew build" causes it but I also tried "bash gradlew" and clean, etc. etc. and they all give the same error.



EDIT (solved): I cd'ed to the wrong directory (went to a fresh, empty directory), works fine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.