Jump to content

[1.6.4] Help with Installing Forge and Using Eclipse: Lots of problems!


Recommended Posts

Hi, I have been trying to install Minecraft Forge for creating mods for two days now, reading guides watching videos, searching through forum posts, and I have always had the same issue. I install the Java JDK and JRE and set the path for them, I download and extract the SRC version of Forge, and I install Eclipse. After running install.cmd, at the end it always says something like "download of minecraft_server_1.6.4.jar failed, hash check". I tried ignoring this, and continued on with the various different tutorials online. When it came time to start up Eclipse, at first I noticed that the things in the Project Explorer looked different. I then read something that said "feel free to look in the src folder to find out how Minecraft works", so I attempted to open the src folder, only to find that there was nothing in it! Ignoring this again, I continued on starting to create my first mod. In the main file, however, the whole script that I had pasted in from a tutorial was covered int he red "Error" lines. Having used Eclipse for something like this before, I knew to hover over the error, and Eclipse would present me with an option to fix it. In the tutorials, when the user hovered over the occasional error, it gave them an option that was totally unavailable to me. At this point I just gave up. Also, after creating my first package under the src folder, the src folder completely disappeared from the Project Explorer. Please help me! I am running Windows 8.1 Pro on a very capable computer, if that makes any difference.


Edit: I also tried completely redownloading everything multiple times, and running all the "compile", "decompile", and "reobfusticate" files.

Link to comment
Share on other sites

I recommend using forge 1.7.2 or higher. Just shift right click on the file where all the extracted forge stuff is and type 'gradlew setupDecompWorkspace eclipse' and it'll set up. Most people are using 1.7,2 now anyways, plus it's more updated anyway so that's what I say.

It says "'gradlew' is not recognized as an internal or external command, operable program or batch file". I have tried this before with that same error. I am trying it in the main "forge" folder, should I try it somewhere else?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.