Jump to content

Can't use Thermal Expansion in dev enviroment


Recommended Posts

I have a mod that interacts with Thermal Expansion's RF system.

I try installing CoFHCore, Thermal Foundation, and Thermal Expansion, all the latest versions, in my dev envoriment, and a custom technic launcehr modpack.

On the modpack, it works fine.

But in the mod dev, I get this...

java.lang.NoSuchFieldError: field_150325_L

Any ideas? It's in CoFHCore, main class, line 179.


Link to comment
Share on other sites

I recently tried updating CoFHCore, Thermal Expansion and Thermal Foundation in my workspace and got the same error from thermal expansion. My guess is that field was somehow missed by the deobfuscation process and CCC isnt fixing it because the rest of the mod is already deobfuscated. But thats just a guess. I updated to the latest NON dev version and that fixed the problem.

I am the author of Draconic Evolution

Link to comment
Share on other sites

I ment get the latest non dev version of thermal expansion. I am using the following versions.







Only thing is i have CCC setup as a dependency so its not actually installed in the mods folder but that shouldnt make a difference.

I am the author of Draconic Evolution

Link to comment
Share on other sites

Now I'm trying to install mekanism because TE by itself doesnt have power conduits, so I  tried for universal cables, but I get this

java.lang.NoClassDefFoundError: thermalexpansion/block/cache/TileCache
at thermalexpansion.block.TEBlocks.initialize(TEBlocks.java:60) ~[TEBlocks.class:?]


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.