Jump to content

Something wrong with code please help :(


Recommended Posts

Im making my first mod and I learned how to make crafting recipes. When i tried to test it out the game launched and I could play but when I tried the crafting recipe nothing happened :(. Any help would be great :D




package com.ethan.ethansmod;

import net.minecraft.init.Blocks;

import net.minecraft.init.Items;

import net.minecraft.item.ItemStack;

import cpw.mods.fml.common.Mod;

import cpw.mods.fml.common.Mod.EventHandler;

import cpw.mods.fml.common.event.FMLInitializationEvent;

import cpw.mods.fml.common.registry.GameRegistry;


@Mod(modid = Ethansmod.MODID, version = Ethansmod.VERSION)


public class Ethansmod {

public static final String MODID = "my mod";

    public static final String VERSION = "1.0";


    public void init(FMLInitializationEvent event)


    GameRegistry.addRecipe(new ItemStack(Items.baked_potato),




    'a', Blocks.bookshelf








I am using forge for 1.7.10 on a mac

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.