Jump to content

mcmod.info dosn't work. Intellij IDEA


nikko4913

Recommended Posts

Hello!

I want to make it clear that I'm not a very experienced modder, and i do not know too much of the coding itself.

 

Well, i recently followed Pahimars tutorials on YouTube(Great youtuber BTW), and in the episode concerning the mcmod.info file, i got stuck. I had followed his tutorial completely, and i tried various "versions" of the file layout but no matter what i did it was like Forge didn't really "pick it up"... I know i got the right file in the resources folder and even my friend(Who's an experienced modder) Couldn't seem to find the error. I'm quite sure that i have the right coding in the .info..

 

I already tried nearly everything i could find regarding this issue. Nothing worked.

 

I use Itellij IDEA (newest version)

And Forge (1.7.10 - Latest, as of yesterday)

And Java JDK (Newest as well)

 

Please go easy on the "You're a noob" attitude. I will try to understand as much as possible!

 

Any help appreciated,

nikko4913

Link to comment
Share on other sites

Did you read the third sentence?

 

If you are using Intellij 14 (which you should) you need to add the following to the end of your build.gradle before importing:

sourceSets { main { output.resourcesDir = output.classesDir } }

If you don't do that, your assets will not work. (Thanks to Cazzar for this solution)

 

mcmod.info is part of your mod's assets.

Don't make mods if you don't know Java.

Check out my website: http://shadowfacts.net

Developer of many mods

Link to comment
Share on other sites

Hey.

I now did what it said multiple times, adding the code, but i still have the same issue. I also tried moving the file around to other possible directories but nothing helps. I even tried reinstalling the workspace... Could you maybe tell me a little bit more specific about where to actually paste this code?

-nikko4913

Link to comment
Share on other sites

No i disd not open the build.gradle and pasted the code before doing gradlew idea. So i now have tried this 2 times in a row, by just deleting the forge and files for the mod. But when i tried to install the workspace again i would no longer have the feature of running minecraft.  I then tried again, but this time i ran the clean commands from when typing gradlew tasks, it looked right, but still no minecraft for testing the mcmod.

Link to comment
Share on other sites

Those are also cached in a central location.

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.

 

1.12 -> 1.13 primer by williewillus.

 

1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.

 

http://www.howoldisminecraft1710.today/

Link to comment
Share on other sites

Okay...

So i followed your tutorial: http://www.minecraftforge.net/forum/index.php/topic,21354.0.html

And this is exactly what i did, setp-by-step:

1. I got the newest version of Forge. And extracted the files inside, into a separate folder.

2. I opened CMD and ran gradlew tasks, followed by gradlew setupDecompWorkspace.

3. When that was done, i opened build.gradle in Notepad++, to edit the following at the complete buttom: sourceSets { main { output.resourcesDir = output.classesDir } }

4. Then i opened Intellij and clicked import project. I selected the folder where the Forge is in. I used the already selected default wrapper.

5. Intellij then runs for a minute, and i get the default screen where i can edit files. I can see that the code i entered from step 3 is at the buttom.

6. Now i cannot run the MC Client, and when trying to open the Minecraft jar, i error out.. Of cause that was a long shot, but doesn't hurt to test it.

 

There you go. This is all i have done, multiple times. What am i doing wrong?

Link to comment
Share on other sites

So this time i followed your tutorial(hopefully right this time) and when finished the genIntellijRuns, i tried running Minecraft, of cause it required a JDK, which i assigned and tried running. Now i got another error...

 

Exception in thread "main" java.lang.NoClassDefFoundError: com/mojang/authlib/exceptions/AuthenticationException
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:191)
at com.intellij.rt.execution.application.AppMain.main(AppMain.java:116)
Caused by: java.lang.ClassNotFoundException: com.mojang.authlib.exceptions.AuthenticationException
at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
... 3 more

Process finished with exit code 1

 

What did i do wrong?

Link to comment
Share on other sites

  • 2 weeks later...

Hello.. again...

So i got it all working at first. I followed Pahimars tutorials further, but after setting up my references i ran a quick minecraft to just see if everything was still working. BUT, now my mcmod.info dosn't show up again... I no longer have the mcmod.infos content displayed under the modlist ingame. I didn't change anything inside the mcmod.info... What could i have done wrong? Sorry for my returning on this matter. But i'm learning...

Link to comment
Share on other sites

First of all, i placed the mcmod.info at the following path:

 

src>main>resources>mcmod.info

 

By references i mean creating a java class under the com.nikko4913.letsmodreboot in a reference-folder, which holds references.. Just like pahimar. The file contains something like the following:

 

package com.nikko4913.letsmodreboot.reference;

public class Reference
{
    public static final String MOD_ID = "LetsModReboot";
    public static final String MOD_NAME = "Lets Mod Reboot";
    public static final String VERSION = "1.7.10-1.0";
    public static final String CLIENT_PROXY_CLASS = "com.nikko4913.letsmodreboot.proxy.ClientProxy";
    public static final String SERVER_PROXY_CLASS = "com.nikko4913.letsmodreboot.proxy.ServerProxy";
    public static final String GUI_FACTORY_CLASS = "com.nikko4913.letsmodreboot.client.gui.GuiFactory";
}

 

That about it...

Link to comment
Share on other sites

Already did this before, and that didn't help...

I now changed "LetsModReboot" to "letsmodreboot" in these files:

 

-build.gradle

-mcmod.info

-LetsModReboot.java

-Reference.java

 

Ran Minecraft and no visible changes were made...

 

BTW... I also tried renaming the LetsModReboot.java no changes anyways...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.