Jump to content

[Solved] Failed to apply plugin [id 'forge'] resource GradleStart.java not found


delvr

Recommended Posts

Hi,

 

I'm getting this error whenever I attempt to run any task (build, setupDecompWorkSpace etc) on my existing IntelliJ project's build.gradle:

 

A problem occurred evaluating script.
> Failed to apply plugin [id 'forge']
   > resource GradleStart.java not found.

 

Stacktrace ends with:

 

Caused by: java.lang.IllegalArgumentException: resource GradleStart.java not found.
at com.google.common.base.Preconditions.checkArgument(Preconditions.java:145)
at com.google.common.io.Resources.getResource(Resources.java:197)
at net.minecraftforge.gradle.tasks.CreateStartTask.addResource(CreateStartTask.java:118)
at net.minecraftforge.gradle.user.UserBasePlugin.tasks(UserBasePlugin.java:636)
at net.minecraftforge.gradle.user.UserBasePlugin.applyPlugin(UserBasePlugin.java:87)
at net.minecraftforge.gradle.user.patch.UserPatchBasePlugin.applyPlugin(UserPatchBasePlugin.java:44)
at net.minecraftforge.gradle.common.BasePlugin.apply(BasePlugin.java:148)
at net.minecraftforge.gradle.common.BasePlugin.apply(BasePlugin.java:49)
at org.gradle.api.internal.plugins.ImperativeOnlyPluginApplicator.applyImperative(ImperativeOnlyPluginApplicator.java:35)
at org.gradle.api.internal.plugins.RulesCapablePluginApplicator.applyImperative(RulesCapablePluginApplicator.java:42)
at org.gradle.api.internal.plugins.DefaultPluginManager.doApply(DefaultPluginManager.java:133)
... 65 more

 

I do see said Java file in my user .gradle\caches\modules-2\files-2.1\net.minecraftforge.gradle\ForgeGradle\1.2-SNAPSHOT\7c022f7189f49b5064399d85a1271ef9c90384d1\ForgeGradle-1.2-SNAPSHOT.jar.

 

Last time it worked was about a week ago I believe. I haven't yet found a change of mine that would have caused this.

 

Things I've tried:

- Deleting user .gradle/ directory

- Deleting project .gradle/ and gradle/ directories and getting a fresh Gradle wrapper

- Gradle versions 2.1, 2.2 and 2.3

- Forge versions 10.13.2.1291 and 10.13.2.1307-1.7.10

- Retrying periodically over the course of two days

 

Any help would be greatly appreciated. Thanks!

Link to comment
Share on other sites

I just solved the problem - it was caused by having "apply plugin: 'forge'" in a local file imported by build.gradle with "apply from:" instead of directly inside build.gradle. This had always worked for me but it seems the latest ForgeGradle 1.2 snapshot doesn't like it.

Link to comment
Share on other sites

  • 2 years later...

Hi,

 

I've the same problem, and to avoid to create the same topic, i prefer post here (sorry for the up of more than a year). My project is for MC 1.7.10 with forge 10.13.4.1614, and I use Eclipse as IDE.

 

error.jpg.2a19baefcf7dd363d83310c97c6921e4.jpg

 

The compilation fail at line 18 with

apply plugin: 'forge'

 

 

I've tested by changing 'forge' with 'forge-1.7.10-10.13.4.1614-1.7.10' or 'net.minecraftforge.gradle.forge' but it still failed. On internet, I've found build.gradle with 'forge' so I'm a bit confused. I even tried moving my code and build.gradle to my forge directory (in modMcAchiev, I've separed forge and my code in different directories) and build with gradle, no success. I searched for clue to solve my problem and I tried to delete my .gradle in my user directory and redo the config of forge in my workspace (with gradlew setupDecompWorkspace of course) but same result. The code work fine when launched from Eclipse. I've also use the --refresh-dependencies argument with gradle build.

 

My build.gradle is the following :

buildscript {
    repositories {
        mavenCentral()
        maven {
            name = "forge"
            url = "http://files.minecraftforge.net/maven"
        }
        maven {
            name = "sonatype"
            url = "https://oss.sonatype.org/content/repositories/snapshots/"
        }
    }
    dependencies {
        classpath 'net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT'
    }
}

apply plugin: 'forge'

sourceCompatibility = 1.7

version = "0.1.0-mc1.7.10"
group= "achievbook" // http://maven.apache.org/guides/mini/guide-naming-conventions.html
archivesBaseName = "Achievement Book"

sourceSets {
    main {
        java { srcDirs = ["C:/Users/User/Dropbox/Projets perso/modMcAchiev/workspace/src/java"] }
        resources { srcDirs = ["C:/Users/User/Dropbox/Projets perso/modMcAchiev/workspace/src/resources"] }
    }
}

minecraft {
    version = "1.7.10-10.13.4.1614-1.7.10"
    runDir = "eclipse"
}

processResources
{
    // this will ensure that this task is redone when the versions change.
    inputs.property "version", project.version
    inputs.property "mcversion", project.minecraft.version

    // replace stuff in mcmod.info, nothing else
    from(sourceSets.main.resources.srcDirs) {
        include 'mcmod.info'
                
        // replace version and mcversion
        expand 'version':project.version, 'mcversion':project.minecraft.version
    }
        
    // copy everything else, thats not the mcmod.info
    from(sourceSets.main.resources.srcDirs) {
        exclude 'mcmod.info'
    }
}

reobf {deobfFile = new net.minecraftforge.gradle.delayed.DelayedFile(project, "build/tmp/deobfBinJar/deobfed.jar") }

I made a scan, and the complete stacktraces are at https://scans.gradle.com/... .

 

I've not much experience with minecraft modding, and it's maybe a stupid error for my side, but I'm out of solution to solve this problem. Thanks by advance.

 

Edit : The tutorial I used was the one from Bedrock Miner, and I modified the given build file at the minecraft part to be like the part in my forge build file (the one given by default as example).

Edited by Edorion
Adding informations
  • Like 1
Link to comment
Share on other sites

1.7.10 is no longer supported on this forum. Please update if you want support. Also, this thread is almost 3 years old. Please make your own thread if you updated.

Edited by larsgerrits
  • Sad 1

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.

 

1.12 -> 1.13 primer by williewillus.

 

1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.

 

http://www.howoldisminecraft1710.today/

Link to comment
Share on other sites

  • Guest locked this topic
Guest
This topic is now closed to further replies.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.