Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Cancel Water/Lava From Pouring


WVAviator
 Share

Recommended Posts

I've tried cancelling the following events to prevent water from being poured:

PlayerUseItemEvent

PlayerInteractEvent

BlockEvent.PlaceEvent

FillBucketEvent

 

So far the issue is that the placed water updates before the cancellation occurs but the bucket is still full for the player. Trying to stop players from using buckets in certain areas (so I need to get the player from the event).

 

I need something like a BlockUpdateEvent that I can .getPlayerWhoCaused() and even more ideally but not really totally necessary .getPos() (So I can use the blocks position vs. the players position, which if I did I'm assuming the player could stand outside of the protected area and pour water into the protected area, unless I did something fancy like get the Vec3 and find out where the player was looking when the event occured, etc.)

 

Maybe there's a FluidEvent I can use for this? Maybe I can use the BlockEvent.PlaceEvent and get the BlockPos and if the player's item in hand is a water or lava bucket, set the block at BlockPos to air? Does placing water from a bucket even fire the PlaceEvent?

Link to comment
Share on other sites

[embed=425,349]public class InteractHandler {

 

@SubscribeEvent

public void onInteract(PlayerInteractEvent e) throws SQLException {

 

 

EntityPlayerMP player = (EntityPlayerMP) e.entityPlayer;

BlockPos pos = e.pos;

 

if (ChunkManager.canPlayerUse(pos, player) == false) {

 

Chat.toChat(player, Chat.noBuild);

e.setCanceled(true);

}

 

}

 

}[/embed]

Link to comment
Share on other sites

I hate to play the noob card but I know nothing of packets.

 

Been trying to figure out how to do it, best tutorial I've found s far is yours http://www.minecraftforge.net/forum/index.php/topic,20135.0.html

 

I've created my Message and MessageHandler classes, but at this point I have no clue where to go.

I noticed S23PacketBlockChange has .read and .write methods built in, do I need to declare the instance of that in the Message class then? What should the code be inside the EventHandler? Just ModClass.networkWrapper.sendTo(Message message, EntityPlayerMP player) ? What do I put for (Message message)? An instance of my Message class?

 

Sorry I'm trying to learn, maybe it's something simple, like I said I just have no experience in packets sending/receiving.

 

Thanks for your help!

Link to comment
Share on other sites

That tutorial is for custom packets, here you need to send a vanilla packet though.

Just make a new instance of the packet (the constructor takes 3 ints, the coordinates, and a world). The pass that to player.playerNetServerHandler.sendPacket() (player being an EntityPlayerMP) and it will send that packet to that player's client.

Link to comment
Share on other sites

Wow thanks. All that research... Lol

 

Anyway I guess for 1.8 the constructor has changed (now S23PacketBlockChange(World, BlockPos))

It still isn't working, but I added a debug line to report which block is updated, and it appears to be updating the block with coordinates (x-1, y-1, z-1) from the original block that is right clicked (not the block the water is placed in).

 

I'm going to see if I can get an array of all BlockPos's adjacent to the one that is clicked and just update all 7 blocks (that should cover the placement of water/lava on any of the block faces.)

 

Would that be slow?

Link to comment
Share on other sites

Ok with that method the correct block is logged, however the water still places. Here is my code:

 

e.setCanceled(true);

 

BlockPos updatePos = pos.offset(e.face);

S23PacketBlockChange s23 = new S23PacketBlockChange(world, updatePos);

System.out.println("Sending packet for " + updatePos.getX() + ", " + updatePos.getY() + ", " + updatePos.getZ() + " to " + player.getName());

player.playerNetServerHandler.sendPacket(s23);

Link to comment
Share on other sites

I added some more debug code before the packet is sent:

 

Code:

System.out.println("This will send information for server block " + world.getBlockState(updatePos).getBlock().toString());

 

Result:

This will send information for server block net.minecraft.block.BlockAir@1d87e84f

 

When placing water.

So I guess the server is sending air to the client, but water is still being placed.

 

Also I thought I'd note that water can also be removed with an empty bucket as well.

 

Link to comment
Share on other sites

I figured it out. It was the FillBucketEvent all along.

 

@SubscribeEvent

public void onBucketUse(FillBucketEvent e) {

 

if (!(e.entity instanceof EntityPlayerMP)) return;

 

EntityPlayerMP player = (EntityPlayerMP) e.entity;

        MovingObjectPosition mop = e.target;

        BlockPos pos = mop.getBlockPos();

   

    try {

if (ChunkManager.canPlayerUse(pos, player)) {

return;

}

} catch (SQLException e1) {

e1.printStackTrace();

}

   

   

    e.setCanceled(true);

 

}

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • What do you mean "not working"? Your code (if it were logical) does nothing. Additionally, you have the following issues: You are using a client-only class (Minecraft) from common code (ClientSyncPacket). Your packet does not tell the client which player this is about. It needs to do so using the player's ID. Currently your packet just uses Minecraft#player, which is not necessarily the correct player.
    • when i tried joining a world my mc crashed exit code -805306369
    • Hello There! In the 73rd episode of Bed Wars we get into a lobby with a guy who had a cool name and for some reason Ben is very impressed with the name and thus the title!  
    • I have been trying to install forge, but I can't even get the installer to run. I'm really not sure what the issue is, first let me make sure I am even using the installer right, I downloaded the forge installer matching my minecraft version (1.19.2), if I double click the .jar from the download then I see a flash of a black window that immediately disappears. If I use a command prompt, I receive the following output: C:\Users\austi> java -jar forge-1.19.2-43.0.19-installer.jar Error: Unable to access jarfile forge-1.19.2-43.0.19-installer.jar   I feel like this is more likely a java issue than a forge issue but I was hoping that people here might be able to help. I've tried a couple versions of java, at first I was using 8 I believe because all of the install guides for forge were a bit older so they linked to the java website rather than oracle. I tried version 18 from the oracle site and received the same result from command prompt. It is also entirely possible that I am doing something else wrong that is blatantly obvious to everyone else.
    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.