Jump to content

[1.7.10] server - NoClassDefFoundError


xert7xainsf

Recommended Posts

Hi so I am running a forge 1.7.10 server (installer/version: forge-1.7.10-10.13.3.1355-1.7.10-installer )

I am using a .bat file to launch the server here is the code:

-------------------------------------------------------------------------------

java -Xms4G -XX:MaxPermSize=4096m -jar forge-1.7.10-10.13.3.1355-1.7.10-universal.jar -o true nogui

pause

-------------------------------------------------------------------------------

But I keep getting this error code:

-------------------------------------------------------------------------------

[17:44:02] [server thread/INFO]: Starting minecraft server version 1.7.10

[17:44:30] [server thread/INFO]: Loading properties

[17:44:30] [server thread/INFO]: Default game type: SURVIVAL

[17:44:30] [server thread/INFO]: Generating keypair

[17:44:30] [server thread/INFO]: Starting Minecraft server on *:25565

[17:44:35] [server thread/INFO]: Preparing level "world"

[17:44:36] [server thread/INFO]: Preparing start region for level 0

[17:44:37] [server thread/INFO]: Preparing spawn area: 87%

[17:44:37] [server thread/INFO]: Done (2.022s)! For help, type "help" or "?"

[17:44:37] [server thread/ERROR]: Encountered an unexpected exception

java.lang.NoClassDefFoundError: org/lwjgl/LWJGLException

at net.minecraft.profiler.Profiler.func_76320_a(Profiler.java:64) ~[qi.class:?]

at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:546) ~[MinecraftServer.class:?]

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:427) [MinecraftServer.class:?]

at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685) [li.class:?]

Caused by: java.lang.ClassNotFoundException: org.lwjgl.LWJGLException

at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_51]

at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_51]

at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_51]

at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_51]

at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_51]

at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) ~[?:1.7.0_51]

at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_51]

at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:106) ~[launchwrapper-1.11.jar:?]

at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_51]

at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_51]

... 4 more

[17:44:37] [server thread/INFO]: Stopping server

[17:44:37] [server thread/INFO]: Saving players

[17:44:37] [server thread/INFO]: Saving worlds

[17:44:37] [server thread/INFO]: Saving chunks for level 'world'/Overworld

[17:44:37] [server thread/INFO]: Saving chunks for level 'world'/Nether

[17:44:37] [server thread/INFO]: Saving chunks for level 'world'/The End

-------------------------------------------------------------------------------

Any help?

thanks -Guy

 

 

 

Link to comment
Share on other sites

Ignore what that other guy said about the MaxPermSize, you're doing that fine. I am pretty sure that the issue is that you are either missing some server libraries, or you are trying to run client side mods on the server.

If I ever say something stupid, or simply incorrect, please excuse me. I don't know anything about 1.8 modding, and I don't know much about entities either, But I try to help when I can.

Link to comment
Share on other sites

Hi,

thanks for the help I figured what he said wasn't true as i use the same code for other servers.

as i am kinda an idiot can you tell me which of these are client mods (these are the mods i am running)

>mods

1.7.10

      CodeChickenLib-1.7.10-1.1.1.99-universal.jar

      ForgeMultipart-1.7.10-1.1.0.314-universal.jar

carpentersblocks

mcheli

[1.7.10] SecurityCraft 1.7.2.jar

Artifice-1.7.10-1.1.4-310.jar

AsieLib-1.7.10-0.3.9.jar

BigReactors-0.4.1A2.jar

buildcraft-6.3.6.jar

Carpenter's Blocks v3.3.5 - MC 1.7.10.jar

ChickenChunks-1.7.10-1.3.4.16-universal.jar

Chisel-1.7.10-1.5.7.jar

CodeChickenCore-1.7.10-1.0.4.29-universal.jar

CoFHCore-[1.7.10]3.0.0B9-138.jar

DynamicTransport-0.1.2.0.jar

Flans Mod-1.7.10-4.9.0.jar

LunatriusCore-1.7.10-1.1.2.21-universal.jar

Mantle-1.7.10-0.3.2.jar

Mekanism-1.7.10-7.1.1.127.jar

MekanismGenerators-1.7.10-7.1.1.127.jar

MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar

MrCrayfishFurnitureModv3.4.7(1.7.10).jar

OpenModularTurrets-1.7.10-1.3.4-27.jar

OptiFine_1.7.10_HD_B5.jar

RedstonePasteMod-1.7.10-1.6.2.jar

Schematica-1.7.10-1.7.5.113-universal.jar

secretroomsmod-1.7.10-4.7.1.404.jar

SlimevoidLibrary-2.0.4.7.jar

statues-1.7.10-2.1.4.jar

TConstruct-1.7.10-1.8.2a.jar

ThermalFoundation-[1.7.10]1.0.0RC1-13.jar

TMechworks-1.7.10-0.2.12.95.jar

Waila-1.5.9_1.7.10.jar

WR-CBE-1.7.10-1.4.1.9-universal.jar

 

Thanks -Guy

 

 

Link to comment
Share on other sites

1. If you set the MaxPermSize too high, the java garbage collector needs more time - So normally you can choose a high number and lower it (half the amount everytime), till you get an error (not this error). Then just double it and you have the perfect amount (normally it is 256m, but not more than 2048m!!(and that's rare))

2. Optifine is causing the trouble....

 

And sorry, that I was telling you something wrong...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Ho installato Forge 1.20.2, ho cliccato col tasto sinistro due volte su installer.jar, non si apre e crea solo un file .log Il file contiene: JVM info: Oracle Corporation - 1.8.0_401 - 25.401-b10 java.net.preferIPv4Stack=true Current Time: 27/02/2024 18:18:10 Host: files.minecraftforge.net [51.79.83.165] Host: maven.minecraftforge.net [51.79.83.165] Host: libraries.minecraft.net [13.107.213.45, 13.107.246.45] Host: launchermeta.mojang.com [13.107.246.45, 13.107.213.45] Host: piston-meta.mojang.com [13.107.246.45, 13.107.213.45] java.net.UnknownHostException: authserver.mojang.com     at java.net.Inet4AddressImpl.lookupAllHostAddr(Native Method)     at java.net.InetAddress$2.lookupAllHostAddr(Unknown Source)     at java.net.InetAddress.getAddressesFromNameService(Unknown Source)     at java.net.InetAddress.getAllByName0(Unknown Source)     at java.net.InetAddress.getAllByName(Unknown Source)     at java.net.InetAddress.getAllByName(Unknown Source)     at net.minecraftforge.installer.DownloadUtils.getIps(DownloadUtils.java:290)     at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:120) Exception in thread "main"  java.lang.NullPointerException     at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:120)
    • Suddenly the installer stopped working, both forge and neoforge, I've tested it on almost all versions of java and it didn't solve my problem.] Here is the log that appears after trying to open the file: JVM info: Oracle Corporation - 21.0.2 - 21.0.2+13-LTS-58 java.net.preferIPv4Stack=true Current Time: 27/02/2024 13:55:14 Host: maven.neoforged.net [172.67.165.187, 104.21.89.226] Host: libraries.minecraft.net [13.107.246.33, 13.107.213.33] Host: launchermeta.mojang.com [13.107.246.33, 13.107.213.33] Host: piston-meta.mojang.com [13.107.246.33, 13.107.213.33] java.net.UnknownHostException: Este host nᅢᆪo ᅢᄅ conhecido (authserver.mojang.com)     at java.base/java.net.Inet6AddressImpl.lookupAllHostAddr(Native Method)     at java.base/java.net.Inet6AddressImpl.lookupAllHostAddr(Inet6AddressImpl.java:52)     at java.base/java.net.InetAddress$PlatformResolver.lookupByName(InetAddress.java:1211)     at java.base/java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1828)     at java.base/java.net.InetAddress$NameServiceAddresses.get(InetAddress.java:1139)     at java.base/java.net.InetAddress.getAllByName0(InetAddress.java:1818)     at java.base/java.net.InetAddress.getAllByName(InetAddress.java:1688)     at net.minecraftforge.installer.DownloadUtils.getIps(DownloadUtils.java:296)     at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:124) Exception in thread "main" java.lang.NullPointerException: Cannot invoke "java.util.List.stream()" because the return value of "net.minecraftforge.installer.DownloadUtils.getIps(String)" is null     at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:124)   If anyone knows how to solve this please tell me.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.