Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

How do I set the resource domain of a programmatically added resource pack?


ashjack
 Share

Recommended Posts

I have successfully reflected the list that Minecraft uses to store resource packs, and I have added a new one programmatically, which adds some external textures to Minecraft. The problem I have, is that after successfully adding this resource pack, it turns out the resource domain is blank. The resource domain is the first string that is required in making an instance of ResourceLocation (new ResourceLocation("ResourceDomain", "Path")).

 

How can I set the resource domain of this resource pack? If you're wandering, the resource pack is an instance of FileResourcePack.

Link to comment
Share on other sites

This is not really how design works.

The domain is literally named by assets themself.

 

Let say you want to load customResource.zip which contains:

assets.domain.textures.gui.someGui.png

 

After adding this IResource into default list (accessed by reflection) the domain is "domain".

In other words - the domain is literally first filename after assets/'here'.

1.7.10 is no longer supported by forge, you are on your own.

Link to comment
Share on other sites

I assumed you did that, did you?

 

You have to realod mc resources after ANY changes in resource list. Thats what MC does (and why you get lag for few sec) after you load rsc-pack in ResourcePack menu.

 

I don't remember exact method but something like:

Minecraft.getMinecraft().reloadResources()

Corrected:

Minecraft.getMinecraft().refreshResources();

 

Edit: I am blindly guessing solutions. If above is not the case, you will need to post code - Git would be nice.

1.7.10 is no longer supported by forge, you are on your own.

Link to comment
Share on other sites

I did have some uppercase directory names, however, upon correcting them to lowercase the problem still persisted. I have just tried the method (refreshResources()) and the texture is still not found. I am sure that I have spelt the directory and file names correctly

Link to comment
Share on other sites

In scale from BAD to GOOD you are at UGLY. (I just really hope someone gets reference).

 

What you are doing will not work outside dev and is simply overkill.

List<IResourcePack> defaultResourcePacks = ObfuscationReflectionHelper.getPrivateValue(Minecraft.class, Minecraft.getMinecraft(), "defaultResourcePacks", "field_110449_ao");

Use this code.

Then simply:

defaultResourcePacks.add(new IResourcePack()) // your class that implements it.
// Example:
new RaceResourcePack(new File("C:/Users/You/.../.../.minecraft/SUK2/Resources/RacesResources.zip")

The implementation:

public class RaceResourcePack extends FileResourcePack

 

There is simply NO way that calling this in FMLInitializationEvent will not work. (with refreshing resources).

 

If your rsc won't be found using above mistake is in assets.

 

Edit: I'll look deeper, soon.

1.7.10 is no longer supported by forge, you are on your own.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.