Jump to content

[1.8] [SOLVED] Custom tool Rendering in Dev But not Published


cclloyd9785

Recommended Posts

I have a custom tool that is rendering in the development environment, but when I publish it and run it on real minecraft with the same forge version only the diamond one registers.  It says in the game output

 

[Client thread/ERROR] [FML]: Model definition for location ccmodpack:itemToolHammerIron#inventory not found

 

For all but the diamond hammer.  And I can't figure out why.

 

Code:  https://github.com/cclloyd/CCModpack/tree/master/src/main

Link to comment
Share on other sites

So if I'm correct just the diamond hammer renders correctly? The others just give the famous black/purple block? I've taken a gaze through your code and just can't find anything. check all the punctuation and capitalization, if there's a difference between the diamond hammer and the others that's probably where your problem is. I'll put it in a dev environment in a sec to test ^-^

Link to comment
Share on other sites

Checked the .jar file to make sure it was packing correctly.  And I found out that it was capitalizing the json files of the other hammers to ItemToolHammerX.  So that's what the issue was.

 

So I ran gradle clean then gradle build and it worked.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.