Jump to content

[SOLVED] Having Trouble Adding API to Eclipse Workspace


Recommended Posts

I'm trying to make an API that I can use in various other modding projects, but when I try to add it to my workspace and compile, I get this error:


java.lang.NoSuchMethodError: net.minecraft.nbt.NBTTagCompound.func_150297_b(Ljava/lang/String;I)Z
at com.himself12794.powersapi.powerfx.PowerEffect.getActiveEffects(PowerEffect.java:209)
at com.himself12794.powersapi.util.DataWrapper.<init>(DataWrapper.java:38)
at com.himself12794.powersapi.util.DataWrapper.get(DataWrapper.java:21)
at com.himself12794.powersapi.event.UpdatesHandler.updates(UpdatesHandler.java:14)
at net.minecraftforge.fml.common.eventhandler.ASMEventHandler_6_UpdatesHandler_updates_LivingUpdateEvent.invoke(.dynamic)
at net.minecraftforge.fml.common.eventhandler.ASMEventHandler.invoke(ASMEventHandler.java:55)
at net.minecraftforge.fml.common.eventhandler.EventBus.post(EventBus.java:138)
at net.minecraftforge.common.ForgeHooks.onLivingUpdate(ForgeHooks.java:336)
at net.minecraft.entity.EntityLivingBase.onUpdate(EntityLivingBase.java:1777)
at net.minecraft.entity.EntityLiving.onUpdate(EntityLiving.java:273)
at net.minecraft.world.World.updateEntityWithOptionalForce(World.java:2031)
at net.minecraft.world.WorldServer.updateEntityWithOptionalForce(WorldServer.java:758)
at net.minecraft.world.World.updateEntity(World.java:1997)
at net.minecraft.world.World.updateEntities(World.java:1823)
at net.minecraft.world.WorldServer.updateEntities(WorldServer.java:587)
at net.minecraft.server.MinecraftServer.updateTimeLightAndEntities(MinecraftServer.java:774)
at net.minecraft.server.MinecraftServer.tick(MinecraftServer.java:669)
at net.minecraft.server.integrated.IntegratedServer.tick(IntegratedServer.java:171)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:540)
at java.lang.Thread.run(Unknown Source)


I'm pretty sure I have an idea of what is happening, to a certain extent, but I don't know how to prevent. I believe it's running the compiled code, not before adding it to the mods. I followed the adding an external API forge guide, but I still get this error. It must be I am compiling it incorrectly, or setting up the API incorrectly. Anyone have advice on how to fix this?

The mod I'm attempting to use as an API is here: https://github.com/Himself12794/Powers-API

And the mod I'm trying to run using this API is here: https://github.com/Himself12794/Heroes-Mod

With all due respect, sir: I do, what I do, the way I do it. ~ MacGyver

Link to comment
Share on other sites

You should have the deobfuscated version of API...

I. Stellarium for Minecraft: Configurable Universe for Minecraft! (WIP)

II. Stellar Sky, Better Star Rendering&Sky Utility mod, had separated from Stellarium.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.